Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu May 24, 2018 6:48 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 158 posts ]  Go to page Previous 16 7 8 9 10 11 Next
Author Message
PostPosted: Thu Jan 04, 2007 8:01 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
they tell me that i have to do everything by myself.

Code:
Greetings, 
  All of our SVN operations are self-serve. You can set it up by following
the instructions on our documentation page at
https://sourceforge.net/docs/
  The specific document you're looking for is
https://sourceforge.net/docs/E09
 
-Jay Bonci
Sourceforge.net


hell this is a jungle of docs!

i am looking up to you lb_worm....because you managed to setup the cvs in ppc_evtd....

i still do not know how to switch to svn.....and how to initialize the repository.

here is the project page again
http://sourceforge.net/projects/linkstationwiki/

and here the webpage hosted there:
http://linkstationwiki.sourceforge.net/

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Thu Jan 04, 2007 8:10 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Looks like you have to convert from cvs to svn by making a patch dump and then importing this back into sourceforge and from the admin page select to import the data file (it is a pain, but I had to do all this with the CVS too). Shame it is not possible to toggle between either cvs or svn repositories. Maybe you can. Will look into it a bit more. Have you established admin for anyone else?

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Thu Jan 04, 2007 8:15 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
everyone is invited to join my little project and he will become an admin instantly.

i did not use cvs before....the project was setup that way from the very beginning.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Thu Jan 04, 2007 8:20 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
I have just had a look at mine and you can go into admin and subversion and enable it from the drop down menu. You can then un tick cvs from admin too. You can then browse to your area (server: https://<NAME>.svn.sourceforge.net) at /svnroot/<NAME>.

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Thu Jan 04, 2007 8:25 pm 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
how do I join you "little project"? I'm registered at sourceforge as jonli447, but I don't know how to actually join an already existing project.

_________________
http://www.opifer.net


Top
   
PostPosted: Thu Jan 04, 2007 8:28 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
@mindbender: I have sent you an e-mail with my sourceforge details if you could please so kindly add me to the project :)

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Thu Jan 04, 2007 8:39 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
you are an admin now...

i have sent them another request about how to switch from CVS to SVN.

i will post updates when there are any.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Thu Jan 04, 2007 8:40 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Tar. I will take a look at the svn setup :)

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Thu Jan 04, 2007 8:42 pm 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
@mindbender, what info do you need for me to join please?

_________________
http://www.opifer.net


Top
   
PostPosted: Thu Jan 04, 2007 8:42 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Right, SVN is now enabled. Setup from linux via: [code]svn co https://linkstationwiki.s vn.sourceforge.net/svnroot/linkstationwiki linkstationwiki[/code]

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Thu Jan 04, 2007 8:44 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
@jonli447: Just needs user ID and user name. Send via private message :)

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Thu Jan 04, 2007 9:25 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
lb_worm wrote:
Right, SVN is now enabled.


nice.

i feel stupid now....

just4info:
to edit the html-page anyone needs shell access to shell.sourceforge.net...you need to create ssh-keys and so on...

at least i did that...

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Jan 15, 2007 8:43 pm 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
@mindbender: In your last PM you asked where I got the info for the acp_commander from...
Sniffing to the network traffic with ethereal as jonli initially suggested. EricC did a good job on the basic ACP-codes (see page 2) he already identified some of the data in the packets. So I only had to finish his work and put the puzzle together.

so to put it into Status of Development-style: praise EricC!
(btw. shouldn't the above thread be named 11.01._07_? I think I can remember some kind of event about two weeks ago. ;) )

Just updated the current state of the packet classes (didn't even try to compile them, yet) to sourceforge/SVN. Hope, I didn't screw up everything. Just thought the classes might make the packets a bit clearer.

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
PostPosted: Fri Jan 19, 2007 7:47 am 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
Received the development box yesterday, but thanks to Kyrill I couldn't do anything after coming home from work. Blackouts
Will be off during the whole weekend, but I'll take the laptop with me. Maybe I can preceed with the acp_commander.

Recently stumbled over

echo "fwupdate" >/var/run/fwupdate

in clientUser_util. Could that be the signal to install an updated firmware during the next reboot?

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
PostPosted: Sat Jan 20, 2007 12:59 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
so i don`t know if anyone tried before.

i messed up my freelink installation with an enhanced freelinkomatix and thought that it would be best to reflash it....so get into EM Mode vi boot_options and reflash when in EM. i directly used jtymods firmware....and filled up /dev/sda1 (= /boot in hddrootfs-mode)

as i was sick of opening the box again to connect the hdd to a workstation i just thought that acp_commander worked for the hddrootfs....but hey it also works in EM Mode :)

just execute acp_commander with the "-o" option and you can connect to the LS Pro via telnet while in EM Mode as root :up:

then i just needed to mount /dev/sda1 to /mnt/disk1/
and had to delete a big file from there...i chose hddrootfs.buffalo.updated

Code:
mount /dev/sda1 /mnt/disk1 
cd /mnt/disk1
delete hddrootfs.buffalo.updated


it is really nice that EM mode is also open...as fdisk + support for ext2/ext3 and XFS is supported, you can repartition your harddrive as you like directly in EM Mode. mkfs.xfs + mkfs.ext2 + mkfs.ext3 are inside EM Mode..

it might be a nice idea to add a note for this in the freelink installation...there the space is needed desperately...

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 158 posts ]  Go to page Previous 16 7 8 9 10 11 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited