Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Aug 20, 2018 9:22 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 15 posts ] 
Author Message
PostPosted: Fri Apr 10, 2009 5:22 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
I built these for my LS1, but they are also running in my LS-HG. dtb files are already in /boot. The newer .dtb-aware uboot is required.

Download them here: kernel_and_modules_for_lsppc-2.6.29.1.tar.gz

Feature set:
    listofmodules-overview2.6.29.1-lsppc.txt,
    in-kernel support for ext4,
    modulized support for (bleeding edge) btrfs,
    netconsole kernel access
    in-kernel USB storage support (should allow tftp-kernel + USB Flash drive rootfs booting)

Code:
cd /
wget http://downloads.buffalo.nas-central.org/Users/davy_gravy/kernelpackages/lsppc_kernel-mod_packages/kernel_and_modules_for_lsppc-2.6.29.1.tar.gz
tar zxvf kernel_and_modules_for_lsppc-2.6.29.1.tar.gz

Check to see that uImage is properly symlinked to uImage-2.6.29.1, and then
Code:
reboot

...and then after rebooting...
Code:
cd /lib/modules/2.6.29.1
depmod

so that your modules are recognized properly.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Fri Apr 10, 2009 4:57 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
This works for me on the HG. However, the permissions are "linkstation:linkstation" where they should be "root:root".


Top
   
PostPosted: Fri Apr 10, 2009 5:30 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
Thanks andre, I'll tweak my script and fix that. ... then repost them.

EDIT: I found the typo - I used -r instead of the required -R. :D . Thanks for the tip, and if you see anything else that needs a fix, please let me know.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Fri Apr 10, 2009 6:09 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Just wanted to let me know this kernel saved me from more frustration. I had swapped my LS1/Debian and HG/OpenLink hard drives, as the HG was able to use kernel 2.6.18 from uboot 1.20. The result was I could only "run bootcmd2" successfully on the HG w/ the Debian HDD, mindbender's 2.4.33v2. Nothing else worked. Your kernel does work, gives me 16K NFS speeds (the first kernel since 2.6.18 that performs better than 8K), and is a very good basis further tests, hopefully resulting in 32K NFS mounts. Thank you!

How did you create the .dtb files, by the way?


Top
   
PostPosted: Fri Apr 10, 2009 6:18 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
:biglol:
... send me your requests for tweaks and feature changes/additions ... I sometimes test compile on my LS1, but the actual ones that I put up and use myself are made with the OpenEmbedded cross compiler stuff that timtimred set up... so rolling a new one only takes 30 min or less.

For the dtb files, when I do it by hand...
Code:
root@LinkStation:/usr/src/linux-2.6.29.1/arch/powerpc/boot/dts# ../dtc -I dts -O dtb -V 16 -o /tmp/kuroboxHG.dtb kuroboxHG.dts
DTC: dts->dtb  on file "kuroboxHG.dts"
root@LinkStation:/usr/src/linux-2.6.29.1/arch/powerpc/boot/dts# ../dtc -I dts -O dtb -V 16 -o /tmp/kuroboxHD.dtb kuroboxHD.dts
DTC: dts->dtb  on file "kuroboxHD.dts"

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Fri Apr 10, 2009 8:13 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
I thought I'd take your .config and start experimenting from there. Maybe NFSv2 or NFSv4 related code interferes with the NFSv3 I need for these old dbox clients.


Top
   
PostPosted: Fri Apr 10, 2009 8:37 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
If you want me to try a build, with a certain config (or several different ones), I can do that.

Ubuntu does all the work, I'd just have to pop in the different configs and build it, tar it and ftp it up to the server.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Sat Apr 11, 2009 1:00 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Thanks, I've already tested various NFS configurations. 16K it is for now.


Top
   
PostPosted: Sat Apr 11, 2009 6:52 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
Is it giving good enough speeds for your video recording/dbox setup then?

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Sun Apr 12, 2009 7:55 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
I can't tell yet. The bitrate varies too much. But I'll keep you posted.

Frohe Ostern!


Top
   
PostPosted: Sun Apr 12, 2009 8:02 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
andre wrote:
Frohe Ostern!


Danke! Back at you! :)

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Thu Apr 16, 2009 3:51 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
I found a limitation/problem that will be fixed in the tarball for 2.6.29.2.

The mtd drivers are not working at all. I am hoping this is just a config mistake I made. I've lost no data, everything boots, all good, but if you want to switch back to something that you can flash to the mtd devices with, I suggest you try the 2.6.28.8 images in my user upload area.

Sorry for any inconvenience this creates.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Thu Apr 16, 2009 5:13 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
They must have changed something upstream. With tonyo's patch and

CONFIG_MTD_PHYSMAP_START=0xffc00000
CONFIG_MTD_PHYSMAP_LEN=0x400000
CONFIG_MTD_PHYSMAP_BANKWIDTH=1

(as it used to be), I only get /dev/mtd*0 but not the rest.


Top
   
PostPosted: Thu Apr 16, 2009 12:49 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
thanks andre, that helps ... I'll take a look at it this weekend ... they should be rolling out 29.2 any day now...

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Thu May 14, 2009 9:21 pm 
Offline
Newbie

Joined: Sun Aug 31, 2008 11:07 pm
Posts: 48
davy_gravy wrote:
thanks andre, that helps ... I'll take a look at it this weekend ... they should be rolling out 29.2 any day now...


I have already reported those problems in the 29-rc* days. You can see it for yourselves here:

http://lkml.org/lkml/2009/3/4/316

Regards, Rogério Brito.

P.S.: I've been using these newer kernels (actually, bleeding edge kernels, even from Linus' git tree, with some experimental patches) and I do want to get them fixed. If possible, some other posts supporting me in the lkml would be appreciated, so that they see that there are other people that see the need of getting everything working with kuroboxes/linkstations.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 15 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited