Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Aug 20, 2018 9:23 am

All times are UTC+01:00

Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sat Mar 07, 2009 9:53 pm 
User avatar

Joined: Sun Feb 22, 2009 1:18 pm
Posts: 12
I have installed uboot and a uboot kernel on my LS1.

Everything appeared to be working fine until today. I had a minor problem and decided to reboot. Unfortunately, now when I turn it on it is not sending any data out of the network port. I was happily using nc to monitor uboot but now nothing seems to happen.

There was one thing that, in hindsight probably should have made me pause before installing uboot. I compiled the ROM image myself and it booted perfectly and nc worked fine. However, the buttons on the LS1 didn't stop the boot process as described in the docs and the power light slowly dimmed and brightened (like the power light on a Mac which is asleep) even after the boot process had completed. Otherwise, everything seemed to work as described and so I wasn't too concerned about this.

So, my question is, how do I reflash my LS1 if uboot appears not to be working properly? Is it possible without a JTAG port (I certainly hope so)?

PostPosted: Sat Mar 07, 2009 11:11 pm 
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
flashing uboot from within linux or from uboot itself is pretty easy and painless...

If you can get it booted, thats the fastest way to go... have you tried a sniffer on your network to see what's happening? Wireshark is a good bet ... see if you can detect any activity from your box ...

Did you change anything on your network or change any uboot env values that would have cause it to no longer boot?

If you can't boot it (EDIT: or connect to it w/ netconsole or serial - see Kuroguy's excellent comment below! He makes a very good point...) , then JTAG would be your only option. It isn't as difficult as it looks to use JTAG ... the first time it seems hard, but after one flash and after you have stuff set up, it is pretty easy ... though soldering takes some time to do carefully.

There is a guide here : http://buffalo.nas-central.org/index.ph ... /Openwince

LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
Unknown command 'wooohooo!' - try 'help'

PostPosted: Sun Mar 08, 2009 3:41 am 
Site Admin
User avatar

Joined: Tue Mar 21, 2006 9:11 pm
Posts: 658
it sounds like your uboot is set to use the serial port instead of the netconsole. When set to serial port it sends nothing to the netconsole. I'd try connecting a serial cable before attempting JTAG. The slow flashing leads me to believe that uboot is working.

You should be able to see the boot messages by just connecting a serial cable (withour bridging the resistor on the serial receive line).


My completely scratch built 832 push-pull tube amplifier with Padauk frame. It matches my custom mini-ITX machine.

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited