Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Aug 19, 2018 5:08 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Linkstation 220DE
PostPosted: Mon Oct 20, 2014 1:50 pm 
Offline
Total Newbie

Joined: Mon Oct 20, 2014 1:41 pm
Posts: 2
Hello,
Hopefully someone can help me. I've got a linkstation 220DE that I have been trying to root for two days.

I've tried the following:
Rolling a custom firmware (SFTP check blocked out, sshd_config edited, authorized_keys created)
ACP-Commander GUI
ACP-Commander Command line using -c (the WVL way)

And all commands work, but I just get connection refused on trying to telnet or SSH in.

Is it possible with this model? Can anyone tell me what the model type even is for this is? WXL/WVL?

I just want to drop mysql and nzbget on there.

Thanks.


Top
   
 Post subject: Re: Linkstation 220DE
PostPosted: Sat Mar 07, 2015 8:37 pm 
Offline
Total Newbie

Joined: Sat Mar 07, 2015 8:33 pm
Posts: 1
I was able to get it working with the ACP Commander GUI: http://www.gry.ch/Java/styled/

Then I used some commands I found on a german site: http://forum.nas-hilfe.de/buffalo-techn ... t2165.html

Below is the relevant sectioon that seemed to fix it. :D
Each line was pasted in the GUI ACP Commander thing, then hit GO. Make sure you fill in your admin password in the box.

Code:
chmod 0755 /etc/init.d/sshd.sh

(echo newrootpass;echo newrootpass)|passwd

sed -i 's/#Port 22/Port 22/g' /etc/sshd_config

sed -i 's/#Protocol 2/Protocol 2/g' /etc/sshd_config

sed -i 's/#PermitRootLogin yes/PermitRootLogin yes/g' /etc/sshd_config

sed -i 's/#StrictModes yes/StrictModes yes/g' /etc/sshd_config

sed -i 's/\/usr\/lib\/sftp-server/\/usr\/local\/libexec\/sftp-server/g' /etc/sshd_config

sed -i 's/"${SUPPORT_SFTP}" = "0"/"${SUPPORT_SFTP}" = "1"/g' /etc/init.d/sshd.sh

/etc/init.d/sshd.sh restart


Top
   
 Post subject: Re: Linkstation 220DE
PostPosted: Sat Aug 29, 2015 3:25 pm 
Offline
Total Newbie

Joined: Mon Oct 20, 2014 1:41 pm
Posts: 2
Hey Wrexem,
I know it's a late reply (I actually gave up until coming back here recently) and this worked!

Much thanks!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited