Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat Apr 21, 2018 6:51 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Oct 01, 2013 7:25 am 
Offline
Newbie

Joined: Tue Oct 01, 2013 6:52 am
Posts: 14
Dear fellow members,

I am a newbie and I was trying to open the stock firmware for my Linkstation pro with stock firmware 1.64, but I was reading the wrong wiki page and accidentally executed "java -jar acp_commander.jar -t 192.168.1.2 -o -addons". I read from here http://buffalo.nas-central.org/wiki/Open_Stock_Firmware_LS-VL, what I did would copy the wrong software onto the box. Although, nothing seems wrong so far, but I am getting a bit worried about what I have done... could someone tell me whether there is a way to fix it?

Also, when I try to follow the instruction on the correct wiki page on opening the stock firmware, I still wasn't able to gain access... when I run the acp_commander, the following shows up:

C:\LinkStation>java -jar acp_commander.jar -t 192.168.1.2 -ip 192.168.1.2 -pw password -c 'ls /mnt/disk1/share/'
Oct 01, 2013 1:59:35 AM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
ACP_commander out of the nas-central.org (linkstationwiki.net) project.
Used to send ACP-commands to Buffalo linkstation(R) LS-PRO.

WARNING: This is experimental software that might brick your linkstation!

Using random connID value = 6DAF3EE06D97
Using target: 192.168.1.2/192.168.1.2
Starting authentication procedure...
Sending Discover packet...
Found: MediaNAS (/192.168.1.2) LS-VL(JOMEI) (ID=00022) mac: 10:
6F:3F:70:BE:FC Firmware= 1.640 Key=1B3D4CBA
Trying to authenticate EnOneCmd... ACP_STATE_OK
Trying to authenticate with admin password... ACP_STATE_OK
>'ls
OK (ACP_STATE_OK)
Changeing IP: ACP_STATE_PASSWORD_ERROR
Please note, that the current support for the change of the IP is currently very
rudimentary.
The IP has been set to the given, fixed IP, however DNS and gateway have not bee
n set. Use the WebGUI to make appropriate settings.


Could someone let me know what is "ACP_STATE_PASSWORD_ERROR"?


Top
   
PostPosted: Tue Oct 01, 2013 8:15 am 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2717
original FW open ssh
open SSH

Code:
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw adminpassword -c "(echo newrootpass;echo newrootpass)|passwd"
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw adminpassword -c "sed -i 's/UsePAM yes/UsePAM no/g' /etc/sshd_config"
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw adminpassword -c "sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/sshd_config"
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw adminpassword -c "/etc/init.d/sshd.sh restart"


from
http://forum.nas-hilfe.de/buffalo-technology-nas-anleitungen/fw-1-56-offen-ssh-auf-eine-ls-chlv2-fw-1-56-t1220.html

with Shonks Mod use telnet


Top
   
PostPosted: Tue Oct 01, 2013 4:22 pm 
Offline
Newbie

Joined: Tue Oct 01, 2013 6:52 am
Posts: 14
Thanks Oxygen8! I`ve got it working!
It took me a while to understand the commands and realizing that "newrootpass" is the new password! hahaha... I know I am a bit dumb, but thanks so much!!!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited