Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Aug 17, 2017 12:39 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
 Post subject: CS-WV to LS-WVL
PostPosted: Thu Apr 20, 2017 11:56 am 
Offline
Total Newbie

Joined: Thu Apr 20, 2017 7:48 am
Posts: 2
Hi there,

I've received an old Cloudstation CS-WV unit. I received it without any drives, so had plenty of practice with tftpboot and flashing the firmware. It's all up and running but I'm interested in seeing what features the LS-WVL has over the CS-WV. It's not being used for anything so no concerns with continually wiping it in order to try different things.

I've seen various comments that it's possible to convert the Cloudstation to a Linkstation but nothing detailing how. As both machines are so old and no longer sold, I just wondered if anyone can post how?

Last night I enabled ssh and used the dumpnf command to see what that was. It gave a PID of 0x0000300A as expected. I used setnf to change that to 0x00003008 (LS-WVL) along with a few things such as series and model name. I put a blank HDD in and when I put it in EM, NasNavigator displayed it, but with a name of "None". I tried to flash LS-WVL firmware, which it took but I couldn't get it to boot once it had completed. I switched the HDD back to one with CS-WV firmware and it booted straight into the Cloudstation firmware. I used setnf to restore everything to how it was.
Have I gone about it the wrong way? Or made a silly mistake somewhere?


Top
   
 Post subject: Re: CS-WV to LS-WVL
PostPosted: Thu Apr 20, 2017 1:30 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2680
try this way



Code:
dumpnf > /tmp/nas_feature

sed -i 's/PID=0x0000300A/PID=0x00003008/g' /tmp/nas_feature

sed -i 's/NAS_FEATURE_VERSION=0.0.0/NAS_FEATURE_VERSION=3.0.0/g' /tmp/nas_feature

setnf < /tmp/nas_feature


Top
   
 Post subject: Re: CS-WV to LS-WVL
PostPosted: Thu Apr 20, 2017 6:49 pm 
Offline
Total Newbie

Joined: Thu Apr 20, 2017 7:48 am
Posts: 2
That did it! I wasn't changing NAS_FEATURE_VERSION. All loaded without a problem.

Quite interesting I can go back and forth between Cloudstor and Linkstation simply by swapping the Hard Drive now.

Out of interest, all the flags in nas_feature from dumpnf - other than PID what are they actually used for?
For example, I've changed RAID0 from 0 to 1 and just installing the firmware now to see the outcome. Will RAID0 be an option for me now, or is that still controlled through firmware, ultimately controlled by the PID flag?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited