Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Nov 17, 2017 8:26 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Upgrade PHP
PostPosted: Thu Oct 17, 2013 5:36 pm 
Offline
Total Newbie

Joined: Thu Oct 17, 2013 5:20 pm
Posts: 2
Hi, I wanted to know if is possible to upgrade the PHP version of Linkstation.

OwnCloud but I try to install another version of PHP requires higher.

PHP 5.3.2 is required. Please ask your server administrator to update PHP to version 5.3.2 or higher. PHP 5.2 is no longer supported by ownCloud and the PHP community.


thank you very much


Top
   
 Post subject: Re: Upgrade PHP
PostPosted: Fri Oct 18, 2013 12:54 am 
Offline
Newbie

Joined: Fri Oct 18, 2013 12:50 am
Posts: 5
+1 here

BUFFALO LS-WX4.0TL/R1
Firmware: 1.65


Top
   
 Post subject: Re: Upgrade PHP
PostPosted: Fri Oct 18, 2013 12:32 pm 
Offline
Total Newbie

Joined: Thu Oct 17, 2013 5:20 pm
Posts: 2
Hi thanks for reply, my NAS is the LS-WX2.0TL/R1 with 1.65 firmware ..

And the version of PHP is 5.2 in this firmware ... there is another version of firmware 5.3.2 PHP?

thanks!


Top
   
 Post subject: Re: Upgrade PHP
PostPosted: Fri May 02, 2014 9:21 pm 
Offline
Newbie

Joined: Fri May 02, 2014 9:12 am
Posts: 16
I'm also looking to upgrade PHP to a newer version.

ferrec you can start by installing shonk's 1.65mod1b firmware. That will give you access to root via SSH which you will need to upgrade. Just do a search for 1.65 mod on this forum and you'll find it.

Hopefully someone will post with step-by-step instructions on the PHP install.


Top
   
 Post subject: Re: Upgrade PHP
PostPosted: Fri Oct 30, 2015 12:57 am 
Offline
Total Newbie

Joined: Thu Oct 29, 2015 11:49 pm
Posts: 3
Funny. This is an old one, but I got PHP problems, too, a few days ago.

I tried to install Owncloud.

First try:
I started the internal web and MySQL server. Then I downloaded the Owncloud installation script and put it in the right folder. After I started the script, it stopped with the message, that PHP and MySQL are too old.

Second try:
I gained root access, I installed wget, I installed ipkg, I installed Apache2, the most recent PHP version and the most recent MySQL version with ipkg. I configured it all. Then I used the install script again. Same message. PHP and MySQL too old.

What did I do wrong?

By the way: Removing this hole stuff is not as easy as installing.


Top
   
 Post subject: Re: Upgrade PHP
PostPosted: Sun Dec 04, 2016 5:19 pm 
Offline
Total Newbie

Joined: Mon Jan 12, 2015 7:30 pm
Posts: 3
+1


Top
   
 Post subject: Re: Upgrade PHP
PostPosted: Sun Dec 04, 2016 11:09 pm 
Online
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/Packages

Package: mysql5
Version: 5.0.88-1

Package: phpmyadmin
Version: 2.6.2-2

Package: lighttpd
Version: 1.4.28-1


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited