Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Jul 16, 2018 7:52 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Mar 26, 2014 9:02 pm 
Offline
Total Newbie

Joined: Wed Mar 26, 2014 8:41 pm
Posts: 2
Hello!

I received this unit with fully erased bootloader. I can desolder the flash chip and program externally.
So I need a saved bootloader urgently!


Top
   
PostPosted: Thu Mar 27, 2014 7:38 pm 
Offline
Total Newbie

Joined: Mon Mar 24, 2014 11:11 pm
Posts: 2
HI,

read this topic, i have reinstall my LS-CH500L v1 with it on a new disk and all is OK

http://forums.buffalotech.com/index.php?topic=10185.0


Top
   
PostPosted: Fri Mar 28, 2014 4:07 am 
Offline
Total Newbie

Joined: Wed Mar 26, 2014 8:41 pm
Posts: 2
nosset wrote:
HI,

read this topic, i have reinstall my LS-CH500L v1 with it on a new disk and all is OK

http://forums.buffalotech.com/index.php?topic=10185.0


Hello!

Thanks for the link, but the problem is basically is in the 512KB sized SPI flash.
The owner is overwrited the device bootloader with inappropriate version of bootloader, so the device was in full brick state.
JTAG probably isn't work, so I desoldered the flash and read what it contains, after I rewrited the bootloader named "u-boot.buffalo.updated" from "lschl-110" version named archive.
After the unit starts "living". Blue and REDs LED are works.
But the next problem is the following. This is u-boot bootloader, so it have an "ART" partition http://wiki.openwrt.org/doc/howto/restore_art_partition

I don't know that part is overwrited or not, but I sadly see at the file end this from hex editor "LS-CHL-V2(YURYAKU".
Probably overwrited the ART partition too with a V2 (japan) u-boot flash file, so missing this part, thus the device don't know its MAC and IP addresses.

The next problem is the following: I can't ping the device and I can't find via LSUpdater.exe. I don't know, the device is know this addresses or not, so I need to know the serial pinouts, to get serial output log.

Darkmodding
(hobby router servicer)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited