Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat May 26, 2018 3:29 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Wed Aug 17, 2011 2:05 pm 
Offline
Total Newbie

Joined: Wed Aug 17, 2011 12:50 pm
Posts: 3
Location: Finland
Hi,

I'm getting really upset with the problem I've tried figure out for 3-4 days now. The problem is that I'm totally unable to connect my LS-CHLv1 both with Ubuntu Linux & Windows 7. The linkstation is not recognized on my local network, no matter whether it is connected to router (Telewell TW-EA510v4) or straight to computer with ethernet cable. I've tried connection with 3 different computers; 2 laptops (Ubuntu 10.04 + Win7) and my desktop PC (Ubuntu 11.04). I've used also 2 ethernet cables.

On Ubuntu, I've used nmap -sP 192.168.0.0/24 command in terminal to ping my network devices. Every other device is recognized but not the Linkstation. While taking a look into Linkstation's ethernet connector, I can see green light blinking as it should do. However, I can't see any activity on the other side of the cable; no packages received on computer, and connection light at the router's side stays idle. SSH connection is not possible either (~Ubuntu/Win7 + Putty).

Because of this problem, I'm unable to have any connection to my Linkstation. As a possible solution, I've looked for making serial port connection to get inside the box and see what is the real problem there. Another solution is to buy a new Linkstation but I really don't like to do that due to high prices (~114€).

This linkstation unit has not been used for a half year and I've handled it with care as well. The last time I used this Linkstation (early 2011), I didn't have any problems with connections.

I checked the microchip (MVKKT-BB). It seems not to be damaged and capacitors are OK, too. No a sign of scorches either. The linkstation runs fine and blue light blinks normally while booting up. The only, and only problem is that I can't connect the Linkstation through network in any case.

---------------------------------------------------

About my Linkstation:
- Two HDD's tried out; Samsung 1.0TB HD103UI (default) and Seagate 1.5TB ST31500341AS. Earlier I didn't have any problems with both of these HDD's.
- I have two separate HDD image backups; Default Linkstation HDD image and Hacked Debian Lenny HDD image. Both tried out & restored without success into both HDD's. Linkstation runs normally with both images (not in EM mode).

- /dev/sda6 partition not included in mentioned HDD images. With linux (Gparted utility), sda6 partition is either not recognized (? symbol) or it's free/un-used. sda1, sda2, sda3 & sda5 = OK
- On the Linkstation's side, hosts.allow & hosts.deny + /root/hosts.allow, all checked and all traffic allowed. (ALL : ALL : allow)
- SSH is running and listening to port 22, according to Linkstation's /var/log messages.
- Rest of the logs are OK, there is not sign of very serious error messages.
- EM mode blinking (purple) = OK, red light blinking (without HDD) = OK. So the microchip detects various HDD conditions.
- Linkstation's ethernet connector blinks heavily after having connected to any computer with the cable. So, there is activity, but for some reason there's no any sign (~IP address) that Linkstation really is on the network.
- Linkstation recognizes whether it is connected to any other network device, according to the fact that the ethernet connector light turns off immediately when unplugging the LAN cable from the other device.

---------------------------------------------------

I'm almost ready to give up with this problem since nothing seems to help and I've tried many solutions without success. The only explanation I can see for this strange problem....Either something is still bloking the connection on Linkstation's side, or worse: Is it possible that the microchip is somehow broken and unable to handle network traffic correctly? I haven't modified the microship itself (e.g. by soldering...), only the HDD software.

I really appreciate any hint that can help figuring out this stressful problem. Thanks. :)


Last edited by Fincer on Wed Aug 17, 2011 9:37 pm, edited 1 time in total.

Top
   
PostPosted: Wed Aug 17, 2011 4:51 pm 
Offline
Moderator

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
How about using Ethercap during the startup of the LS?
The box should, at least, try to get an IP address from
a DHCP server and therefore send some broadcasts.
Run Ethercap on a PC directly connected to the LS (but
use a cross over cable or ensure the PC has an auto-x
feature) and watch for broadcasts or ARP pakets.
Maybe the DHCP server fails to send a IP address and the
box switches to the default zero conf IP in the range of
169.254.x.x ?

_________________
Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)


Top
   
PostPosted: Wed Aug 17, 2011 6:21 pm 
Offline
Total Newbie

Joined: Wed Aug 17, 2011 12:50 pm
Posts: 3
Location: Finland
Thanks for suggestions, kenatonline

It seems that I'm unable to find that IP address directly in Ubuntu. Linux sees Eth0 connection available but can't connect, even after multiple attempts. However, in Windows 7, typing ipconfig /all in command line gives one interesting shot for Ethernet adapter when cable is directly connected to the Linkstation. You are right about the default zero conf IP address, I confirmed that it is 169.254.21.22

Due to IP detection problems between Linux computer & Linkstation, I installed Ettercap on the Windows machine. However, the program crashes all the time when trying to sniff the connection in Windows. I don't know if it is because of Windows 7 is newer than the program itself.

Anyway, since I already find out Linkstation's IP address which seems to be 169.254.21.22, I plugged ethernet cable back to the Linux computer and typed two commands in terminal:

Code:
fincer@Fincer-MAIN-PC:~$ nmap -sP 169.254.21.22

Starting Nmap 5.21 ( http://nmap.org ) at 2011-08-17 19:34 EEST
Note: Host seems down. If it is really up, but blocking our ping probes, try -PN
Nmap done: 1 IP address (0 hosts up) scanned in 3.00 seconds

fincer@Fincer-MAIN-PC:~$ nmap -PN 169.254.21.22

Starting Nmap 5.21 ( http://nmap.org ) at 2011-08-17 19:35 EEST
Nmap scan report for 169.254.21.22
Host is up (0.032s latency).
All 1000 scanned ports on 169.254.21.22 are filtered

Nmap done: 1 IP address (1 host up) scanned in 8.55 seconds


So it seems that either something is blocking the connection on Linkstation's side or some data may be corrupted on the chip/HDD. I don't know for sure about the exact failure itself. However, this failure causes the Linkstation to become unavailable on my network, though IP address can still be digged out.

I see a few possibilities to solve the problem:
1) Establishing direct serial connection to see what's happening inside the box
2) ...or reflash pure/formatted HDD with Buffalo's firmware
3) Both of these
4) Buying a new Linkstation, paying through the nose for a new unit
5) Something else

Well, I try to make sda6 partition at first, then HDD reflashing and finally, if the problem still exists, establishing serial connection to LS. I'll post the results of these actions.

Btw. Just came to mind: Is it possible that this connection problem is caused by non-existence of sda6 partition? Can microchip data become corrupted, for example, by power failure or invalid detachment of hard disk while Linkstation is still running? Is it possible to fix that kind of microchip problems using straight serial connection if needed?

Too many question, too few answers. :roll: Very interesting problem, just to say... :shock:


Top
   
PostPosted: Wed Aug 17, 2011 9:29 pm 
Offline
Total Newbie

Joined: Wed Aug 17, 2011 12:50 pm
Posts: 3
Location: Finland
All right, tested a few things while ago...

When I remove HDD from the microchip and turn power on, the function LED starts blinking red light in a cycle of 7 flashes

According to Linkstation's manual:
7 flashes - Problem with motherboard (RAM, LAN, or Hard Drive controller)

I did hard reset for the microchip by following manual instructions, with and without HDD + fan. No success.

Well, you can say that those flashes refers to the HDD removal. However, the manual says that HDD has an unique cycle for flashes, making a difference for motherboard problems:

6 flashes - Hard Drive can not be recognized

And because I'm getting 7 flashes instead of 6, even HDD removed, I guess the problem is related to the microchip itself. A problem with LAN maybe.

I looked for JTAG (which is not possible with LS-CHL due to lack of JTAG connectors in the microchip) and serial port methods. Unfortunately, getting a microchip flash/image is difficult (at least I haven't found any microchip stuff for LS-CHL). So, it seems that if I don't get a correct flash/image for the Linkstation's microchip anywhere, I can forgive making this Linkstation back to life again and settle the fate of having an extra papercraft toy on my table.

Even buying a USB-TTL serial cable is not worthwhile because of the quite high price (~31€) + work + difficulty of getting a flash image in addition. That's not worth trying, honestly.

I have no idea why the chip broke or what series of events caused that....I can hardly even speculate. The microchip has only been lying inside a plastic bag in a safe place for a half year...until I tested it a couple of days ago. So, I greatly believe it's dead now. I'm disappointed.


Edit: WTF...suprisingly, it seems that hard reset even did the trick! :up: I can finally see the Linkstation listed on my Windows network devices. Hopefully Linux recognizes LS as well. :) So I think it really was a microchip problem but hard reset fixed it. (~holding down function button)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited