Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Aug 17, 2018 6:40 am

All times are UTC+01:00

Post new topic  Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Tue Jul 09, 2013 8:40 pm 
Regular Member

Joined: Mon Jan 16, 2012 8:14 am
Posts: 85
I bought the LS-CHL V2 with 2 TB in 2011, and today I got a flashing red light error. NAS Navigator reports that it's an E30, so I will have to replace the drive. Right now, the drive is still working, although the red light appears after an hour or so. I'm currently just copying the few incomplete torrents and the torrent directory to my desktop (which runs on Win 7 HP 64-bit).

I read the wiki entry for this model and tried the company website but could not get a lot of details on replacing the hard drive. The wiki entry says that it's a 2 TB Model WD Caviar Green WD10EADS 7200 RPM. I'd like to know if I can buy something similar to the hard drive or if I should buy the same model.

Next, is this the correct process? I buy an enclosure for the new hard disk and connect it the USB slot of the NAS. From there I back up (or clone?) the system to the new drive. After that, I replace the old hard disk with the new one. Will the NAS run after that with no additional configurations?

Finally, if I choose not to back up and just insert a new, blank hard drive, will the NAS run right away?

Thanks for the help.


I found this page:


I think I need to connect a USB flash drive and copy the mnt, after which I replace the old hard drive with the new one, then flash?

PostPosted: Wed Jul 10, 2013 11:55 am 
Regular Member

Joined: Mon Jan 16, 2012 8:14 am
Posts: 85
The unit kept hanging as I tried to connect a USB drive to it, and I could not copy transmission-daemon to another hard disk via the Win 7 desktop, so I researched further and did the ff.

- Telnetted to the NAS
- copied transmission-daemon to another directory
- ran chmod 777 -R transmission-daemon
- was able to copy it to a spare HD

for the incomplete directory, I just copied it to the spare HD together with others. I hope this is right.

Finally, I've decided not to use the old system and just reinstall the modded firmware and transmission. Do I follow this process?

- put in the new HD
- start the unit
- run LSUpdater
- follow the instructions for installing Transmission
- if everything is right, copy back the incomplete and resume directories from the spare HD

edit: also, the torrents directory

PostPosted: Fri Jul 12, 2013 12:44 pm 
Regular Member

Joined: Mon Jan 16, 2012 8:14 am
Posts: 85
Here's what I gathered so far:

I have to move all large files from the old HD to a new one. Once in a while, copying will stop due to sector errors. After that, I have to remove the old HD.

Next, I put the old HD in an enclosure.

Then, I install a multi-tool open-source operating system in a USB and boot it from a PC.

I connect the enclosure to the PC and run a disk cloning program found in the USB to make an image of the old HD in the HD of the local PC.

After that, I disconnect the enclosure, replace the old HD with the new HD in the enclosure, connect the enclosure to the PC, and then run the same disk cloning program to restore the image to the new HD.

Finally, I insert the new HD in the NAS. If the unit goes into EM mode, I have to re-load the modded firmware.

Some notes:

I could not find any reference to preparing the new hard disk. From what I gathered, some sources suggested an empty drive while others stated that it has to be formatted in ext3. One guide required cloning the old HD, as the NAS requires particular partitions to operate (e.g., two ext3, two unknown, one linux swap, one xfs).

I'm currently stuck with cloning the old HD. It seems to be stuck at 9.37% and I can't find any instructions for preparing a new HD without cloning the old one.

With that, I'll probably just connect the new HD to an old laptop running Win XP to continue the torrents until I find a system that will allow me to back up data and replace HDs easily.

PostPosted: Fri Jul 12, 2013 4:33 pm 

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Current consensus in this board regarding replacing the disks:
start with plain, unformatted, unpartitioned disks and use TFTP.
If the disks exceed 1TB, the firmware flash step has to be done
twice. Once to partition and format and a second time for the real
firmware writing WITHOUT formatting.
Blame Buffalo for this.

Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)

PostPosted: Thu Aug 15, 2013 5:11 pm 
Regular Member

Joined: Mon Jan 16, 2012 8:14 am
Posts: 85
Thanks! I got it working now. Here's what I did:

I downloaded the latest navigator, firmware, and TFTP boot image mentioned here:

http://buffalo.lithium.com/t5/Storage/F ... d-p/100319

I formatted the new hard disk in Win 7 using NTFS with everything in default.

I opened the NAS using instructions I found in Youtube (e.g., remove fan screw, pull out and unplug fan, insert pin in hole and then pry open enclosure, remove screws from HD, remove old HD), put in the new HD, and closed the unit.

Then, I used TFTP following instructions above.

Next, I installed new firmware following these instructions:

http://buffalo.lithium.com/t5/Storage/F ... d-p/100317

The system timed out several times, but I just kept re-installing the firmware. After I rebooted the unit, the lights indicated two short and three yellow lights, which means the firmware is being reset. After a few minutes, a solid blue light appeared.


I forgot to add that the menu configurations were in Japanese, so I used the "translate to" option in Chrome to go to the language setting and use the correct language.

PostPosted: Sun Aug 18, 2013 7:59 am 
Regular Member

Joined: Mon Jan 16, 2012 8:14 am
Posts: 85
Some more points:

I used a 500 GB HD as a replacement and got it running. Later, I checked the 2 TB HD that was replaced and saw no errors, so when I tried to put it back, I could not make the process work due to an ACP_STATE_FAILURE, which according to some means that the boot area is full. I used ACP commander to clean it out but that didn't work.

I found out that another way is to clone the HD but it takes a lot of time to do this. With that, I decided to use the free version of Macrium Reflect to make an image of the 500 GB HD, which took around 5 hours. It's taken longer to write the image to the 2 TB HD. (I'll use a partition manager to extend the last partition to use the remaining HD space.)

In general, I find the process too tedious. I think a better option is to just use a system where the OS is in a storage device that is separate from the data and torrent files, such as a memory card for the OS and an external HD for data and torrents.


I think I finally got it after several attempts. Here's what I remember doing:

Opened unit, inserted HD in an enclosure, cloned it using Macrium Reflect Free, used a partition manager to remove partitions, then checked it for errors. When there were none, I put the HD back in the unit.

Disabled all antivirus programs and firewalls in PC.

Set the IP address to

Connected LAN cable from unit to PC.

Turned on unit. After the light started blinking red, pressed the reset button. The light started blinking blue.

Ran TFTP boot recovery 1.53. Blocks served. Closed TFTP.

Waited for the light to become solid blue.

Set the IP address to automatic.

Ran lsupdater for v1.54 mod 1 to get the IP address of the unit. Closed lsupdater without updating.

Opened command prompt and ran

java -jar acp_commander.jar -t <IP address of unit> -cb

to clean boot area.

Ran lsupdater for v1.54 mod 1, opened debug window, and checked the boxes for all config options.

Updated firmware until the light started blinking yellow, which means the firmware is being reset.

PostPosted: Tue Aug 20, 2013 11:37 am 
Regular Member

Joined: Mon Jan 16, 2012 8:14 am
Posts: 85
One more thing I realized: if it takes many attempts to update the firmware (including formatting the HD), and after doing so, the unit is slow when it comes to restarting, shutting down, and accessing the HD, then the HD is likely faulty.

PostPosted: Fri Jan 03, 2014 11:31 am 
Total Newbie

Joined: Fri Jan 03, 2014 11:19 am
Posts: 1
Hi , the links above have been moved / deleted.
Im a novice with a LS x2.0L... about 12 months old but the disk has bad sectors at emergency levels. Ive bough and enclosure and a new drive but can any one help with a step by step idiots guide to replacing the drive and recovering the data from the old drive ? Im running windows 8.1, so how do I do it ? What if any special software or programs do I need ?
Yours, wishing he was more geeky

PostPosted: Sat Nov 12, 2016 6:27 pm 
Total Newbie

Joined: Sun Feb 07, 2010 11:17 pm
Posts: 3
This is an old thread but I just replaced the 1tb hard drive in my LS-Chl v2 with a 2 tb. I put both the old 1tb drive and new 2tb drive in a computer and used the unix "dd" command to clone the old drive to the new one. The new drive runs fine in this configuration but it only uses 1tb of the disk space. How do I use the entire space on the new disk? Simply resizing the partition (sda6) using qparted did not work.

PostPosted: Sat Nov 12, 2016 6:52 pm 

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2734


Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 10 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited