Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Jul 22, 2018 9:54 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Aug 27, 2011 3:37 pm 
Offline
Newbie

Joined: Sat Aug 27, 2011 3:33 pm
Posts: 5
I'm attempting to turn my LS-CHL v2 into a portable LAMP (PHP/MySQL) webserver.

So far, I've updated the firmware to ls_series-137-mod1. This has allowed me to access the device via telnet with root privileges.

I'm not sure where to go from here. My goal is to have as lightweight a setup as possible. Could I simply install the required LAMP stack onto the existing OS? or would it be better to update to a Debian operating system in order to achieve LAMP?

Any advice would be greatly appreciated.

Thanks


Top
   
PostPosted: Sun Aug 28, 2011 7:11 am 
Offline
Moderator

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Take the optware package system to get PHP, Apache etc..
There are several threads dealing with this topic.
You will need the optware package for feed cs08q1armel.

_________________
Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)


Top
   
PostPosted: Mon Sep 05, 2011 10:11 am 
Offline
Newbie

Joined: Sat Aug 27, 2011 3:33 pm
Posts: 5
Thanks kenatonline.


Top
   
PostPosted: Mon Sep 05, 2011 2:15 pm 
Offline
Newbie

Joined: Sat Aug 27, 2011 3:33 pm
Posts: 5
I've got as far as installing ipkg and I've issued an ipkg update to get the freshest repository.

Following that I did ipkg install php-apache.

The installation finished and I tried to 'up' the webserver with /opt/sbin/httpd

I get:
Code:
httpd: Syntax error on line 74 of /opt/etc/apache2/httpd.conf: Cannot load /opt/libexec/mod_ext_filter.so into server: /opt/libexec/mod_ext_filter.so: undefined symbol: apr_procattr_limit_set


Am I missing a step?


Top
   
PostPosted: Thu Sep 15, 2011 2:01 pm 
Offline
Newbie

Joined: Sat Aug 27, 2011 3:33 pm
Posts: 5
bump


Top
   
PostPosted: Thu Sep 15, 2011 2:58 pm 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2731
Use FW 1.54 Mod1

Webserver with php and mysql is preinstalled.


Top
   
PostPosted: Fri Sep 16, 2011 10:05 am 
Offline
Newbie

Joined: Sat Aug 27, 2011 3:33 pm
Posts: 5
Thanks oxygen8.

All up and running now :)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited