Buffalo NAS-Central Forums

Serial port on LS-CHLv2
Page 1 of 1

Author:  Fadoski [ Mon Feb 08, 2010 12:21 pm ]
Post subject:  Serial port on LS-CHLv2

Hello everyone!

I've been trying to search information on how to get a serial port to LS-CHLv2. Haven't find anything useful yet, so now I'm asking here if anyone could help me?
Basically, I don't know where the serial port header or pins or solder points are located on the board.
Here's some pics from the board, just in case:


Author:  snipes420 [ Tue Sep 06, 2011 12:50 am ]
Post subject:  Re: Serial port on LS-CHLv2

I am trying to figure out this one as well.

The board pictures linked to in the wiki page for this device are not the same as mine.
Your pictures look exactly like mine.

This device (LS-XHL) looks pretty close as well and may be the hint needed to find the solder points.
http://buffalo.nas-central.org/wiki/Ser ... ort_LS-XHL

more looking when i have time

EDIT: I removed the obfuscating resisters and used wire to jump the points indicated on that LS-XHL page but then after that the pins labled TX and RX had a steady 3.3 volts on them and it didn't put anything out to my CA-42 usb ttl/serial adaptor. Its not looking right.

Author:  Xykon [ Sat Oct 15, 2011 12:08 am ]
Post subject:  Re: Serial port on LS-CHLv2


I just finished removing the two resistors and bridging the connectors with little wires. Now when I check TX vs GND I have changing voltage levels for a short moment when plugging in the power (I assume for the normal poweron messages) and more when I start up the device (boot log).

I don't have any uart <-> RS232 converter atm so I cannot make the connection with my PC to check for the actual output yet, but I am quite positive that at least for the serial console port the instructions are identical.

I should be receiving my JTAG module sometime next week so I'll let you know how that will be going. I'll also let you know as soon as I found a serial converter to check console messages on my PC and also check if bi-directional communication is working.

Author:  Xykon [ Wed Oct 26, 2011 11:49 pm ]
Post subject:  Re: Serial port on LS-CHLv2


I received my USB <-> UART converter today so I checked it out with my LS-CHLv2. Unfortunately I don't get any serial output either.

I verified that the converter is working by using it with my WRT54GL (Wifi router from Linksys/Cisco) which works perfectly fine. I don't know if those strap resistors you are supposed to solder in are really just a blank wire or if there is more to it. I ordered some 0OHM resistors just to make sure but they will take a while to arrive.

I don't think I'll do anything with the JTAG port until I got those strap resistors just to make sure I won't kill my brand new jtag programmer right away.

I was just wondering if maybe the current uboot on my LinkStation simply has serial output disabled and that's why I don't see anything. Anyone know if Buffalo might actually be that evil? :twisted:

Anyways the order that has those strap resistors also contains a 16port logic analyzer so maybe that will reveal some more info about that serial port... but unfortunately that shop (I couldn't find them anywhere else) is quite slow in getting things sent so it might be another week or two before I can continue with this experiment.

Author:  Xykon [ Sat Nov 05, 2011 11:01 pm ]
Post subject:  Re: Serial port on LS-CHLv2

Well I got the Logic analyzer and checked those two ports... they don't seem to contain any UART signal. There is some data being transmitted on both RX and TX (which is already strange) but I wasn't able to decode it.

I used the Logic analyzer on several other UART ports and it worked fine every time (even at 115200bps), so that's not the problem. I also measured directly at the pins I soldered into R253 and I get the same results that I get on the pins... which means that the bridge is working fine.

If I have the time I might check the CPU specs to see if it actually has a UART port and how it may or may not be configured for debugging. But other than that I'm not going to wast too much time on this as I have other, more interesting devices to work/play with that are a lot easier accessible than this one :)

So unless someone has another idea or solution...

Author:  Xykon [ Tue Nov 08, 2011 5:34 am ]
Post subject:  Re: Serial port on LS-CHLv2

Well I checked the data sheet of the CPU... the uart ports aren't in a fixed location but can be programmed to use any of the gpio ports. It's even possible that Buffalo disabled the uarts completely because they are not needed for normal product use.

I don't know if you can read the MPP control register via software (my guess is no). And since I have no information about the layout of jtag pins I won't even try to connect my jtag programmer to it (I need that programmer more than I need the NAS).

I'm still curious what the signals are that they send to these 12 pins. According to the picture linked above there are 4 pins for SPI (I would assume DIN is MISO and DOUT is MOSI) but I don't know what you could possibly do with that data (plus it seems I'd have to remove the sata connector first... SPI_DOUT is only available if you stuff a DNP resistor under the SATA connector).

I was just thinking that maybe they put the I2C pins on the header instead of uart0. Not sure if that would help anything but I'll try to check that out...

Author:  basicentity [ Thu Nov 10, 2011 11:32 am ]
Post subject:  Re: Serial port on LS-CHLv2

I just came across your postings. I have a bricked LS-CHLv2 and try to find a way to access serial or JTAG. I found this pages:

http://www.yamasita.jp/linkstation/2008 ... emble.html
http://www.yamasita.jp/linkstation/2008 ... ole_1.html

Unfortunately they are in japan, so I don't understand the text parts, but the images look much like yours. Maybe you can interpret the pages - google translate does a very funny but not very helpful job here ;)

Do you think that the hardware is similar or identical to ours? I haven't had the time to open my box but I will - mabye I can tell you more by then.

Thanks for your posts!

Author:  Xykon [ Thu Nov 10, 2011 3:32 pm ]
Post subject:  Re: Serial port on LS-CHLv2

It's not the same board.

Author:  Xykon [ Fri Nov 11, 2011 6:28 am ]
Post subject:  Re: Serial port on LS-CHLv2

Just in case someone was wondering... there is nothing under R255 and removing it will break the board (no blue blinking when turning it on). I just verified that :biglol:

Author:  Xykon [ Wed Nov 16, 2011 6:45 pm ]
Post subject:  Re: Serial port on LS-CHLv2

Unfortunately I got so curious about this little piece of hardware that now I cannot stop myself... :twisted:

In order to find the correct layout of jtag ports I was thinking of two different methods:

a) Simply try out every possible combination. Is there a chanche to damage the jtag module or the board? Of course I can first check the ports vs. ground to see if there is any voltage on them and also protect my jtag module with diodes... but there is still a risk of frying the CPU if I put voltage on a pin that isn't expecting it...

b) Remove the CPU, trace the jtag data lines from the CPU socket to the connector pads, reball and replace the CPU. Sounds like an aweful lot of work just to find those pins. On the positive side, I could take my time to check every data line from the CPU to map where it will go on the board (at least those that aren't obvious). Then once I can get access to the CPU via jtag I can also check which pins have UART0 and then find the serial console as well (or configure it to use some connectors that aren't used for anything else).

Any other ideas that I haven't thought of yet?

I still think it's a hell of a lot of work for this little thing. I'm actually planning to exchange the 3.5'' disk by a solid state 2.5'' hdd and then run a vlan router on it. Of course I can do that without serial console but especially for testing the firewall it might be helpful to have one. And of course it would be a lot cheaper to simply buy something like a sheeva plug but what's the fun in getting something that works out of the box 8-)

Author:  Xykon [ Fri Dec 16, 2011 12:40 am ]
Post subject:  Re: Serial port on LS-CHLv2

I finally had a chance to check my available stencils for one that does fit the CPU, and unfortunately I didn't find any. I might still get by with a generic stencil though but that's a lot more work. It might be easier to just order a replacement CPU that's already fully balled, though I haven't found an end user vendor yet.

As for the balls they support 0.5-0.7mm which is good as I have both 0.5 and 0.6mm available.

I'm not sure I want to go the route of re-balling the CPU just yet... I might try some guesswork on the jtag layout first. It can't be too much off from a standard 10 socket jtag port but the fact that pins 3 and 5 are connected together on ground doesn't make much sense to me.

Either way I'll have to wait until early January to continue working on this board as I won't be home. If anyone has any suggestions how to avoid reballing the CPU I'd be happy to know. I don't have a $1000 rework station so any rework I do has a risk on frying the CPU. At least it would be good to know where to get a replacement CPU if things don't work out.

Author:  ThreeColoursRed [ Fri Jan 13, 2012 1:50 pm ]
Post subject:  Re: Serial port on LS-CHLv2

Using the LS-XHL diagrams,
http://buffalo.nas-central.org/wiki/Ser ... ort_LS-XHL
I tried unsoldering R253 on my LS-CHLv2, then realised that I didn't know what was meant by "For a (non AC coupled) UART port you have to short the vias underneath R253 with a 0R resistor". So instead I put back R253 (or actually, just soldered a wire across - since it's a 0Ohm "Resistor" I take it to mean that a piece of wire is the same). Anyway, for plan B I've tried connecting up a 3.3v -> 5v RS232 converter to my PC's serial port, and connecting the TXD, RXD & GND ports marked on the diagram above (on the edge of the board where the SATA connector lives).

Then trying to connect with minicom I get some response if I type on my keyboard, but all garbage. I've tried every possible combination of parity, stop bits, data bits @ 115200 baud, but I just get garbage. The fact that this bears some relationship to me typing (garbage characters are only generated when I type) suggests that I'm seeing some serial communication but it's not quite there yet: I get the garbage characters in response intermittently; I've tried other speeds and don't see any improvement (although ssh into the NAS suggests it's running at 115200 baud, esp. 'ps' showing "/sbin/getty -L ttyS0 115200 vt100" as running). I'm not getting *any* correct characters appearing though - what does appear is entirely garbage.

So that's FYI my progress. I'm currently using a jumble of serial cables, null modem, adapters to connect the Linkstation to the PC. This is such a mess, I'll try and get some wires & connectors together so that I can try eliminating all that clutter and see if I get better results.

Meanwhile I'll be very interested to hear anyone else's experiences...

Author:  ThreeColoursRed [ Fri Jan 13, 2012 3:34 pm ]
Post subject:  Re: Serial port on LS-CHLv2

I forgot to add: I tried using a multimeter on the contacts on the edge of the board. I found 12V on one contact that the LS-XHL diagram labels as 3v3, so I think the contacts are different from the LS-XHL. My meter suggests (starting from the end near the 2 capacitors, working towards the corner of the board),

LS-XHL      LS-CHLv2
 3v3          3v3
 GND          3v3
 SPI_CLK      11.5V(huh?)
 SPI_DIN      ?
 SPI_DOUT     ?
 SYSRST       ?
 n.c.         GND
 TXD          TXD?
 RXD          RXD?
 3v3          12V (from PSU?)
 GND          GND

Author:  ThreeColoursRed [ Fri Jan 13, 2012 5:32 pm ]
Post subject:  Re: Serial port on LS-CHLv2

I managed to simplify my adapters etc.... and end up with no output. BUT I also connected the Vcc on my 3.3V-->TTL (5V) converter to a 3.3v point on the Linkstation. I wonder whether my earlier promising results were just the result of 'noise' since I now realise the converter (MAX3232 based) wouldn't have had any power source since I'd connected only GND, ?TXD?, ?RXD? - perhaps without power the chip generates a bit of 'noise' when a signal is received.

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited