Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 12:23 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 165 posts ]  Go to page 1 2 3 4 511 Next
Author Message
 Post subject: avr_evtd [kuroevtd]
PostPosted: Wed Jun 21, 2006 10:19 am 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Still to let people know that the latest version is in test. Known to support LS1, LSII (PPC) and HGs. Many new additions and minor bug fixes. Will keep this thread updated with news as appropriate.

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Wed Jun 21, 2006 10:51 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
do not forget: moderators here can make topics sticky now....so if you think it is worth, tell me.

i think i will make you a moderator for the software section as well.

EDIT: lb_worm is now a moderator in all software forum sections

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Thu Jun 22, 2006 8:33 am 
Offline
Developer

Joined: Mon Oct 03, 2005 11:32 pm
Posts: 399
Location: France
Next features look really great :D
I also have a request :
With my Debian installation on my kurobox, if i do not have udev installed, i have a /dev/AVR00 that points to the AVR serial link, but /dev/ttyS1 is not pointing to the AVR device !
Code:
$ cat /proc/tty/driver/serial 
serinfo:1.0 driver revision:
0: uart:16550A mmio:0x80004600 irq:26 tx:14162 rx: 0 RTS|DTR
1: uart:16550A mmio:0x80004500 irq:25 tx:832 rx:1  RTS|DTR
2: uart:unknown port:00000000 irq:0
3: uart:unknown port:00000000 irq:0


So there is two way to make your startup script working for me :
- making /dev/ttyS1 node points the right place (i have no idea on how to achieve such a thing)
- making the script to points to /dev/AVR00 if it exists ! =>
Code:
if [ -e /dev/AVR00 ]; then 
DEVICE=/dev/AVR00
else
cat /proc/tty/driver/serial | grep 80004500 | grep  -q 0: && DEVICE=/dev/ttyS0 || DEVICE=/dev/ttyS1 u name -m | grep -q mips && MIPS=YES
fi


Could you think about adding this in your next release ? (maybe needs some adaptions for the MIPS hardware ?)

_________________
Kurobox Pro 500GB (for dev) / Freelink / 2.6.26-rc4 kernel, QNAP TS-409 Pro 1TB, Maxtor Shared Storage II 500GB


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Thu Jun 22, 2006 10:51 am 
Offline
Developer

Joined: Mon Oct 03, 2005 11:32 pm
Posts: 399
Location: France
Ok, i found how to recreate the correct node :
mknod -m 666 /dev/ttyS1 c 4 65
My request is now useless, but i can't edit my previous post with this new forum :down:

Thanks for your great job, it allows me to to switch off my kurobox with the power button with my debian distribution ! Can't wait for the next avr_evtd release :up:

_________________
Kurobox Pro 500GB (for dev) / Freelink / 2.6.26-rc4 kernel, QNAP TS-409 Pro 1TB, Maxtor Shared Storage II 500GB


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Thu Jun 22, 2006 12:29 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Well done. I was looking at going over to udev just to see what the benifits would be. I have had some issues with my stock HG as I get a kernnel 'opps' (bad news this) from cat /proc/tty/driver/serial. I had changed over to a ioctl(fd,TIOCGSERIAL) ping but that is unreliable too. May have another bash to check.

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Fri Jun 23, 2006 6:09 am 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
@sylver: Does the timed shutdown function okay on the kuro or have you not tried it?

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Fri Jun 23, 2006 8:29 am 
Offline
Developer

Joined: Mon Oct 03, 2005 11:32 pm
Posts: 399
Location: France
udev is usefull for dynamic devices creation when you plug a new device (for example you plug your usb webcam and it will create /dev/video0 automatically and when removed, /dev/video0 will disapear) !

The shutdown function works well on my kurobox as it is (i just compiled/installed/removed kuroevtd/reboot and worked perfectly :up: )

I tryed with or without udev and it works well in both cases for me !

If you need a beta-tester on the kurobox platform, i'm your man :p

_________________
Kurobox Pro 500GB (for dev) / Freelink / 2.6.26-rc4 kernel, QNAP TS-409 Pro 1TB, Maxtor Shared Storage II 500GB


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Fri Jun 23, 2006 1:23 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Great, thanx. Will be posting soon. Just testing the extended sleep function.

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Sat Jun 24, 2006 2:24 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
The stock and freelink processes all seem to be polluted with pokes out to the avr. I have been lookking at shutdown issues with my HG box and have found issues with shutdown, reboot, halt, poweroff, poweron most of which were introduced by my 'hacked' freelink install. Some of this also appears on the stock software and also on my LS1. Why are so many processes and scripts all trying to do the same thing. Little wonder people are experiencing problems following upgrades. No to remove all this rubbish and use basic GPL shutdown, halt and reboot processes. I will have a dig and see what happens!

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Sun Jun 25, 2006 5:46 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Write, now fixed the code. Locates the required UART (not via /proc but the proper way) and tested on my HG (which has a funny setup) and works okay. Extended sleep mode has been tested okay (2 days) and am now checking this out on the HG too. Shutdown problems have been found and solved (bad stopping of the daemon) and sort of fixed issues with shutdown/poweron/poweroff/halt by moving to the latest sysVinit - checked works with stock process too. Added debug log event (for admin only). @sylver: are you still up for testing?

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Sun Jun 25, 2006 9:59 pm 
Offline
Developer

Joined: Mon Oct 03, 2005 11:32 pm
Posts: 399
Location: France
Nice :up:
I'm ready for sure :lol:
just send me stuff at snatcher93 at rocketmail dot com ;)

_________________
Kurobox Pro 500GB (for dev) / Freelink / 2.6.26-rc4 kernel, QNAP TS-409 Pro 1TB, Maxtor Shared Storage II 500GB


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Mon Jun 26, 2006 10:07 am 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Will do, thanx.

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Mon Jun 26, 2006 6:52 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
@sylver: check your inbox, just been sent.

_________________
LS used as PVR and streaming source


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Tue Jun 27, 2006 10:28 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
When is the new version expected to be released?


Top
   
 Post subject: Re: avr_evtd [kuroevtd]
PostPosted: Tue Jun 27, 2006 10:31 am 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
Very soon. I have been testing this for three weeks on three different Linkstaions and with the help of Sylver, now on a Kuro box too. Will let you know. I have finished updating the man page (that was a big job) and have some debug messages to remove too. Will keep you posted.

_________________
LS used as PVR and streaming source


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 165 posts ]  Go to page 1 2 3 4 511 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited