Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Tue Jul 17, 2018 6:10 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Wed Oct 02, 2013 10:27 pm 
Total Newbie

Joined: Wed Oct 02, 2013 9:43 pm
Posts: 4
Hi all,

I have a LS-XHL 2TB. Recently my harddrive died so I bought a new one. Figuring I might as well get an upgrade, I bought a WD 3TB Red, since I read on this forum that this should work.

I followed the guide in German by oxygen8 http://forum.nas-hilfe.de/buffalo-technology-nas-anleitungen/anleitung-tftp-und-firmware-flashen-mit-bildern-t903.html. I have problems connecting to the LS under Win7x64, so I boot from a minimal WinXP CD. Booting using Uboot over TFTP works fine.

But I'm having troubles with installing the firmware. I've tried at least 20 times now. Describing the exact problem is difficult because the precise error keeps changing. Every now and then I seem to get a bit further, only to run into another problem. Then when I retry I get the similar error as what I had before. The whole thing seems completely random to me.

The most important error message when I click update is that the LS is not responding and that I should check whether the LS and PC are on the same subnet (they are--I set the IP address of my PC to When I somehow manage to get past this problem I often get the message that the formatting has failed. Once I got to the point that partitions were created (I checked) and the firmware was written but then the firmware did not get unpacked.

A major annoyance is that the IP address of the LS as listed in the LSupdater window keeps changing. Usually it starts with but after an error it usually resets to a different address. Changing the IP address of the PC one on the same subnet as the new adress does not work. The only thing that helps is rebooting the LS using TFTP, possibly several times, until the address is again I wonder if this might also be the cause of the problems with the flashing.

I'm at a loss. I figure an easier way would be to connect using an USB-IDE converter and copy an image of an existing disk. But unfortunatly I can't find such images online. The old disk is completely dead so not possible to clone that one.

Any suggestions would be highly appreciated. Upon request I can provide more information.


PostPosted: Thu Oct 03, 2013 6:39 am 

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
There are known problems with firmware recovery and big disks.
There are several posts in our forum as well as in Buffalo's.
You need to flash the firmware twice (yeah, sounds silly, but it
is a Buffalo box).
The first time, you specify within the debug settings of the LS
Updater to create the partitions. The second time, you specify
to NOT partition.
The first time will fail, the second time should succeed.
At least this is the solution, you can find in this forum.

Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)

PostPosted: Thu Oct 03, 2013 9:27 pm 
Total Newbie

Joined: Wed Oct 02, 2013 9:43 pm
Posts: 4
Thanks for your reply. I made some progress.

The task became a LOT easier by connecting to the LS over a router rather than directly. With the direct connection the IP address of the LS was constantly changing, forcing me to modify the address of the PC, and/or reboot the LS. Also, it seems that the address was changing during the firmware installation (if that is possible), which may have been the main source of the difficulties described in my original post.
When connecting over a router I didn't even need to do the flashing twice.

Anyway, I managed to install the firmware but strangly, the LS is still not booting on its own. After switching on I get the E06 error. Booting using TFTP works fine, and afterward the LS is working properly. I can access the share and web interface and use telnet.

Any thoughts? I'm a Linux noob. Are is there some way over telnet to see why it's not booting and fix it?


PostPosted: Sat Oct 12, 2013 9:16 am 
Total Newbie

Joined: Wed Oct 02, 2013 9:43 pm
Posts: 4
I solved it. The problem was that I installed a FW mod by Shonk, which had no data for the boot partition. Solution was to download the stock FW and update the boot part only.
I've posted some of my experiences in this thread: viewtopic.php?f=69&t=22645&start=30

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited