Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Nov 19, 2017 4:08 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 73 posts ]  Go to page Previous 1 2 3 4 5
Author Message
PostPosted: Tue Jan 31, 2012 11:50 am 
Offline
Newbie

Joined: Mon Jan 30, 2012 6:40 pm
Posts: 10
Ah excellent, thank you.
I had seen the second of those pages you listed, but not the first (even after some hours of looking). Even for someone with some experience of Linkstation Pros such as myself, it was not obvious to me that LS-VL = LS-CHL with respect to this problem.

using -ip always gave a warning, and nowhere did I see that it was actually required.

Perhaps a note in the wiki saying that "this also works with 1.56" would also help those people searching the wiki for help using firmware version numbers?


Top
   
PostPosted: Wed Feb 01, 2012 9:12 pm 
Offline
Newbie

Joined: Mon Jan 30, 2012 6:40 pm
Posts: 10
I can confirm that this technique
http://buffalo.nas-central.org/wiki/Ope ... ware_LS-VL
works with my LS-CHL2.0-V2 standard firmware 1.56

Hint: if the ssh deamon sshd doesn't seem to be starting, it could be because
your /root/.ssh/authorized_keys file does in fact need dos2unix doing to it, even
if you wrote it originally using unix style LF line endings.

Happy.

Philip


Top
   
PostPosted: Tue Mar 06, 2012 12:51 am 
Offline
Total Newbie

Joined: Mon Mar 05, 2012 10:06 pm
Posts: 2
I can verify this wors on the LS-XL too! :up:

oxygen8 wrote:
The guide is not suitable for LS-CHLV2.

Further use:

Code:
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw Youradminpassword -c "echo 'UsePAM no' >>/etc/sshd_config"
java -jar acp_commander.jar -t NAS_IP -ip NAS_IP -pw Youradminpassword -c "/usr/local/sbin/sshd"


modify sshd.sh
Delete Lines:
Code:
if [ "${SUPPORT_SFTP}" = "0" ] ; then
     echo "Not support sftp on this model." > /dev/console
     exit 0
fi

_________________
If it ain't broken, break it.
If it's broken, fix it.
Remember: No Guts, No Glory


Top
   
PostPosted: Fri Jun 22, 2012 6:54 pm 
Offline
Total Newbie

Joined: Fri Jun 22, 2012 6:49 pm
Posts: 1
Just wanted to say that I have just tried all 5 steps from the very first post in this thread on my new Bufallo CloudStation Duo CS-WX with firmware 1.13 build 2.35 and it worked flawlessly! Thank you tenchinho! :up:


Top
   
PostPosted: Tue Jul 17, 2012 5:44 am 
Offline
Total Newbie

Joined: Tue Jul 17, 2012 5:34 am
Posts: 1
Hello,

I've been trying to replicate your success on the LS-XL with the 1.55 firmware. I can modify the sshd_config file, but I haven't had any success getting access via ssh. I connect via ssh and try to login as root via ssh using a password which works to login as root in the web browser. However, it doesn't accept the password and I get a Permission Denied error.

Here is my sshd_config file read using cat. Is something wrong or missing? I've made it as permissive as I can think to do so. It appears to have the settings you've specified.

*Removed comments
# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin
*Removed comments
#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh_host_rsa_key
#HostKey /etc/ssh_host_dsa_key
HostKey /etc/apache/server.key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rh

***Can't see this middle part of the file***

#AuthorizedKeysFile .ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCreds yes

# Set this to 'yes' to enable PAM authentication (via challenge-response)
# and session processing. Depending on your PAM configuration, this may
# bypass the setting of 'PasswordAuthentication'
UsePAM no

#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
PermitUserEnvironment yes
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path
# override default of no subsystems
Subsystem sftp /usr/local/libexec/sftp-server
UsePAM no
UsePAM no
UsePAM no
UsePAM no


Top
   
PostPosted: Sun Aug 26, 2012 8:46 pm 
Offline
Total Newbie

Joined: Sun Aug 26, 2012 8:32 pm
Posts: 1
I can now confirm that keene's solution also works on Buffalo LinkStation Pro Duo LS-WVL with firmware V. 1.56.

Thank you, keene, for your help! :up:


Regards

Martin


Top
   
PostPosted: Mon Aug 27, 2012 2:56 am 
Offline
Newbie

Joined: Fri Jul 08, 2011 12:12 pm
Posts: 5
mroempp wrote:
I can now confirm that keene's solution also works on Buffalo LinkStation Pro Duo LS-WVL with firmware V. 1.56.

Thank you, keene, for your help! :up:


Regards

Martin


LS/WVL Firmware 1.60 has been released in July 5 while 1.61 beta is also available since August 21.
I am more interest to know if the same procedure is working with above 2 releases too.

Thanks and Regards,
JayCee


Top
   
PostPosted: Mon Oct 22, 2012 6:25 am 
Offline
Total Newbie

Joined: Mon Oct 22, 2012 6:18 am
Posts: 1
Hello,

the same procedure is working with Buffalo LS-XL Firmware 1.60.
Except the start of the ssh deamon.

Code:
java -jar acp_commander.jar -t 192.168.0.10 -ip 192.168.0.10 -pw adminpasswordhere -c "/usr/local/sbin/sshd"


This was the right command to start the ssh deamon.


Top
   
PostPosted: Sat Dec 15, 2012 9:47 am 
Offline
Total Newbie

Joined: Sat Dec 15, 2012 9:39 am
Posts: 4
Morning!!

It works fine, but I have a question. when I restart my LS-XL (I have 1.63 Firmware) ssh port it´s closed, so it´s necessary to run

java -jar acp_commander.jar -t 192.168.0.10 -ip 192.168.0.10 -pw adminpasswordhere -c "/usr/local/sbin/sshd"

again. You know it´s possible to include /usr/local/sbin/sshd in to /etc/init.d/ or something similar????? I´m not sure about this, because when I´have ready ssh, if I execute /usr/local/sbin/sshd NAS return message "disabling protocol version 1. Could not load host key"


Thanks


Top
   
PostPosted: Sat Dec 15, 2012 10:02 am 
Offline
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
Try the howto for LS-XL.
http://forum.nas-hilfe.de/buffalo-techn ... tml#p10191


Top
   
PostPosted: Sat Dec 15, 2012 10:32 am 
Offline
Total Newbie

Joined: Sat Dec 15, 2012 9:39 am
Posts: 4
Yehaaaaaaaa!!!!!!


It´s works fine!!!!!!!

Thank you for the link, it´s in German but Sr. Google translator have been it´s job.

Finally the steps to configure ssh-server in LS-XL with 1.63 Firmware are:

java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "ls /"
java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "(echo newrootpass;echo newrootpass)|passwd"
java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "sed -i 's/UsePAM yes/UsePAM no/g' /etc/sshd_config"
java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/sshd_config"
java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "/etc/init.d/sshd.sh restart"
java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "sed -i '15,19d' /etc/init.d/sshd.sh"
java -jar acp_commander.jar -t <nas_ip> -ip <nas_ip> -pw <Usr_Admin_Password> -c "/usr/local/sbin/sshd"

After all of this, when you do ssh root@<nas_ip>, you can connect to nas with newrootpass.
If you want change it you can type passwd and enter, then type de new root password.

thank you again


Top
   
PostPosted: Wed Jan 02, 2013 1:11 pm 
Offline
Total Newbie

Joined: Sat Dec 15, 2012 9:39 am
Posts: 4
Hello, and happy new year!!!!

I´m back with no good news, I don´t know why, but since last week when my LS-XL reboots, I can´t connect via ssh, it´s necessary to send this commands:

java -jar acp_commander.jar -t <ip_nas> -ip <ip_nas> -pw <password> -c "sed -i '15,19d' /etc/init.d/sshd.sh"
java -jar acp_commander.jar -t <ip_nas> -ip <ip_nas> -pw <password> -c "/usr/local/sbin/sshd"


If someone can give me some help!!!!, I´m a Linux basic user, I´m starting with it and it´s so big for me at the moment.

Thanks


Top
   
PostPosted: Wed Aug 27, 2014 5:56 pm 
Offline
Total Newbie

Joined: Wed Aug 27, 2014 5:52 pm
Posts: 1
keene wrote:
java -jar C:\Users\Admin\Desktop\acp_commander.jar -t YOURIP -ip YOURIP -pw pass123 -c "(echo pass234;echo pass234)|passwd"
java -jar C:\Users\Admin\Desktop\acp_commander.jar -t YOURIP -ip YOURIP -pw pass123 -c "sed -i 's/UsePAM yes/UsePAM no/g' /etc/sshd_config"
java -jar C:\Users\Admin\Desktop\acp_commander.jar -t YOURIP -ip YOURIP -pw pass123 -c "sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/sshd_config"
java -jar C:\Users\Admin\Desktop\acp_commander.jar -t YOURIP -ip YOURIP -pw pass123 -c "/etc/init.d/sshd.sh restart"

Thanks a lot! Finally ssh root access after searching so much before... This made my day! :up:

And even works on LS-WXL with firmware version 1.65! :D


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 73 posts ]  Go to page Previous 1 2 3 4 5

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited