Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 8:23 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sat Feb 21, 2015 8:24 pm 
Offline
Newbie

Joined: Thu Feb 19, 2015 3:49 am
Posts: 7
Good day

So i have finally made some progress with my quest to install SABnzbd to my NAS Buffalo linkstation Pro-Quad. I seem to be making babysteps however here is where i am at. I believe i have installed sabnzbd - however when i execute this command:
Quote:
python2.5 SABnzbd.py -f SABnzbd.ini -d


No confirmation message was received.

So i went to check the sabnzbd log and this is what it said:

Quote:
2015-02-21 13:03:16,821::INFO::[SABnzbd:973] --------------------------------
2015-02-21 13:03:16,823::INFO::[SABnzbd:974] SABnzbd.py-0.5.6 (rev=2503)
2015-02-21 13:03:16,824::INFO::[SABnzbd:984] Platform = posix
2015-02-21 13:03:16,826::INFO::[SABnzbd:985] Python-version = 2.5.6 (r256:88840, Feb 14 2012, 06:13:37)
[GCC 3.4.4 (release) (CodeSourcery ARM 2005q3-2)]
2015-02-21 13:03:17,081::INFO::[misc:308] cache_dir directory: /opt/share/SABnzbd/cache does not exist, try to create it
2015-02-21 13:03:17,088::INFO::[__init__:674] /opt/share/SABnzbd/cache/bookmarks.sab missing
2015-02-21 13:03:17,090::INFO::[__init__:674] /opt/share/SABnzbd/cache/rss_data.sab missing
2015-02-21 13:03:17,094::INFO::[__init__:674] /opt/share/SABnzbd/cache/bytes9.sab missing
2015-02-21 13:03:17,096::INFO::[__init__:674] /opt/share/SABnzbd/cache/queue9.sab missing
2015-02-21 13:03:17,098::INFO::[postproc:139] Loading postproc queue
2015-02-21 13:03:17,100::INFO::[__init__:674] /opt/share/SABnzbd/cache/postproc1.sab missing
2015-02-21 13:03:17,106::INFO::[__init__:674] /opt/share/SABnzbd/cache/watched_data.sab missing
2015-02-21 13:03:17,110::INFO::[downloader:334] Resuming
2015-02-21 13:03:17,234::INFO::[__init__:251] All processes started
2015-02-21 13:03:17,236::INFO::[SABnzbd:269] Web dir is /opt/share/SABnzbd/interfaces/smpl
2015-02-21 13:03:17,672::INFO::[SABnzbd:1038] Starting SABnzbd.py-0.5.6
2015-02-21 13:03:17,724::INFO::[dirscanner:375] Dirscanner starting up
2015-02-21 13:03:17,744::INFO::[urlgrabber:103] URLGrabber starting up
2015-02-21 13:03:17,753::INFO::[SABnzbd:390] _yenc module... found!
2015-02-21 13:03:17,755::INFO::[SABnzbd:398] par2 binary... found (/opt/bin/par2)
2015-02-21 13:03:17,757::WARNING::[SABnzbd:408] unrar binary... NOT found
2015-02-21 13:03:17,759::INFO::[SABnzbd:411] unzip binary... found (/usr/bin/unzip)
2015-02-21 13:03:17,761::INFO::[SABnzbd:417] nice binary... found (/bin/nice)
2015-02-21 13:03:17,762::INFO::[SABnzbd:423] ionice binary... NOT found!
2015-02-21 13:03:17,764::INFO::[SABnzbd:428] pyOpenSSL... NOT found - try apt-get install python-pyopenssl (SSL is optional)
2015-02-21 13:03:17,772::INFO::[SABnzbd:1136] Starting web-interface on localhost:8080
2015-02-21 13:03:17,776::INFO::[_cplogging:55] [21/Feb/2015:13:03:17] ENGINE Bus STARTING
2015-02-21 13:03:17,813::INFO::[_cplogging:55] [21/Feb/2015:13:03:17] ENGINE Started monitor thread '_TimeoutMonitor'.
2015-02-21 13:03:17,945::INFO::[_cplogging:55] [21/Feb/2015:13:03:17] ENGINE Serving on localhost:8080
2015-02-21 13:03:17,947::INFO::[_cplogging:55] [21/Feb/2015:13:03:17] ENGINE Bus STARTED
2015-02-21 13:03:32,104::INFO::[rss:376] Running scheduled RSS scan
2015-02-21 13:30:17,103::INFO::[rss:376] Running scheduled RSS scan


Not sure what all this means but nothing appears on the web interface :8080

Can anyone help?


Top
   
PostPosted: Sat Feb 21, 2015 10:17 pm 
Offline
Newbie

Joined: Thu Feb 19, 2015 3:49 am
Posts: 7
A bit of progress - i finally managed to get SABnzbd working however it appears every time i reboot my Buffalo all my pkgs disappear.

Does anyone know why these packages are not being permanently installed? Otherwise i have to pray that the electricity never goes off.


Top
   
PostPosted: Sat Feb 21, 2015 11:08 pm 
Online
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
disk1 vs array1

Which is your data partision?
Which optware did you use?


Top
   
PostPosted: Sun Feb 22, 2015 2:37 pm 
Offline
Newbie

Joined: Thu Feb 19, 2015 3:49 am
Posts: 7
Well i upgraded the firmware to 1.69 via this:

http://www.tomatosoft.hu/gadgets/

As for the optware itself - i ploughed through using lspro_bootstrap_1.2-7_arm.xsh

As for the partition: RAID 0

As i may have mentioned earlier or in other posts - i am not versed in linux - so i have been trying to mundle through with what i have read online.


Top
   
PostPosted: Sun Feb 22, 2015 2:52 pm 
Online
Moderator

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2691
This is the right optware for Kirkwood with Array1

Code:
rm -rf /mnt/disk1/.optware
rm -rf /mnt/array1/.optware
cd /tmp
wget http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/teraprov2-bootstrap_1.2-7_arm.xsh
sh ./teraprov2-bootstrap_1.2-7_arm.xsh
echo 'src cs08q1 http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/' >/opt/etc/ipkg.conf
echo 'src cs08q1 http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/stable/' >/opt/etc/ipkg/cross-feed.conf
ipkg update


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited