Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Aug 20, 2018 3:12 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu Aug 02, 2012 2:05 pm 
Offline
Newbie

Joined: Sun Sep 18, 2011 4:40 pm
Posts: 47
A few more questions for the group (which will probably be answerd by Kenatonline, since he seems to be the resident genius).

After opening my box to NFS, I had a few problems getting things to work correctly.

Right now I've got SFTP working after creating a new sshd_config file, but FTP still doesn't work--despite the fact that all the requisite keys are there.

For FTP, I get "Disabling Protocol 1, could not load host key". Which is weird, because the host key is where it's supposed to be, it's been regenerated, etc. However, trying to connect results in a connection refused. I don't really use FTP, but I'd like to have it working anyway, so if anyone can help, I'd appreciate it.

*Also* ;) Regarding sftp, my .optware and share folders are visible in SFTP. I'd like to be able to keep those hidden, so can someone tell me where to adjust the settings for that? Obviously, they don't show up in the Linkstation web interface, so I can't 'mark' them there.


Top
   
PostPosted: Sun Aug 19, 2012 1:14 pm 
Offline
Regular Member

Joined: Sun May 06, 2012 1:45 am
Posts: 186
AntiKris wrote:
Right now I've got SFTP working after creating a new sshd_config file, but FTP still doesn't work--despite the fact that all the requisite keys are there.

For FTP, I get "Disabling Protocol 1, could not load host key". Which is weird, because the host key is where it's supposed to be, it's been regenerated, etc. However, trying to connect results in a connection refused. I don't really use FTP, but I'd like to have it working anyway, so if anyone can help, I'd appreciate it.

I'm sure that you have worked out by now that the ftp service is nothing to do with sshd. sftp and ftp are two completely different things.

The "Disabling Protocol 1, could not load host key" is telling you that sshd will being using rsa protocol version 2, not version 1.

The ftp service in stock firmware uses proftpd invoked from /etc/init.d/ftpd.sh


Top
   
PostPosted: Mon Aug 20, 2012 2:45 pm 
Offline
Newbie

Joined: Sun Sep 18, 2011 4:40 pm
Posts: 47
Thanks, Colin. That was informative. This gets me a little closer, as when I try to manually start ftpd.sh, I get the message "ftp is OFF". Not just 'off', mind you, but definitively, authoritatively 'OFF'. Any clue how to turn it back ON?

Lol, and yes, I'm aware that sftp and ftp were completely different, I was just wondering if the config file was related. :lol:


Top
   
PostPosted: Mon Aug 20, 2012 3:39 pm 
Offline
Regular Member

Joined: Sun May 06, 2012 1:45 am
Posts: 186
Look for the line in /etc/melco/info. Should be:
Code:
ftp=on
N.B. All in lower case.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited