Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Aug 19, 2018 5:08 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Wed Aug 01, 2012 1:02 am 
Offline
Newbie

Joined: Wed Aug 01, 2012 12:49 am
Posts: 8
compleatly new to this, so forgive me for asking something that has probably been answered
I've searched through and gotten all sorts of mixed answers about weather this can be done or not so i figured id register and ask in the hope of getting a clear answer

Hardware available:
TV: Samsung UA40C6900VF
LS Quad
PS3

It looks fairly clear that the PS3 media player cant do it, but the TV can play MKV files when they are plugged in directly to the tv. Is there any way i can watch the mkv files from the nas without converting them on my computer into a different format?


Top
   
PostPosted: Wed Aug 01, 2012 5:48 am 
Offline
Newbie

Joined: Wed Feb 29, 2012 8:39 pm
Posts: 6
Hello,

here is my working step by step howto for Version 1.0.24 (works for 1.0.25):
http://downloads.sourceforge.net/projec ... src.tar.gz


0)
ipkg update
ipkg upgrade
ipkg install gcc make libexif libjpeg libid3tag flac libvorbis sqlite ffmpeg autoconf automake cvs perl gettext coreutils


1)
edit
/etc/ld.so.conf

add at the end
/opt/lib

2)
edit genconfig.sh
change all /usr/ to /opt/ (20 times)
[ ! -e "/opt/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
[ ! -e "/opt/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
[ ! -e "/opt/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
[ ! -e "/opt/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
[ ! -e "/opt/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
[ ! -e "/opt/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
[ ! -e "/opt/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
[ ! -e "/opt/include/ffmpeg/avutil.h" -a \
! -e "/opt/include/libavutil/avutil.h" -a \
! -e "/opt/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
[ ! -e "/opt/include/ffmpeg/avformat.h" -a \
! -e "/opt/include/libavformat/avformat.h" -a \
! -e "/opt/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
[ ! -e "/opt/include/ffmpeg/avcodec.h" -a \
! -e "/opt/include/libavcodec/avcodec.h" -a \


3)
edit makefile
change all /usr/ to /opt/ (8 times)

and
add
-L/opt/lib \
at these lines
-I/opt/include/ffmpeg \
-I/opt/include/libavutil -I/opt/include/libavcodec -I/opt/include/libavformat \
-I/opt/include/ffmpeg/libavutil -I/opt/include/ffmpeg/libavcodec -I/opt/include/ffmpeg/libavformat -L/opt/lib \


add:
LDFLAGS = -Wl,-R/opt/lib

remove -lpthread
from this line
LIBS = -lpthread -lexif -ljpeg -lsqlite3 -lavformat -lavutil -lavcodec -lid3tag -lFLAC -logg -lvorbis
to
LIBS = -lexif -ljpeg -lsqlite3 -lavformat -lavutil -lavcodec -lid3tag -lFLAC -logg -lvorbis

4)
change
/opt/share/automake-1.11/Automake/Config.pm
near line 32
our $perl_threads = 1;
... to
our $perl_threads = 0;

5)
replace the defect libpthreads from gcc with the correct from the system
mv /opt/arm-none-linux-gnueabi/lib/libpthread-2.5.so /opt/arm-none-linux-gnueabi/lib/libpthread-2.5.so.orig
ln -s /lib/libpthread-2.5.so /opt/arm-none-linux-gnueabi/lib/libpthread-2.5.so

6)
./genconfig.sh
make
make install

7)
edit /etc/minidlna.conf
to your needs
like
media_dir=/mnt/disk1/myStuff
db_dir=/usr/var/cache/minidlna


8)
start
/usr/sbin/minidlna -f /etc/minidlna.conf


9)
stop Twonky via webinterface


10) if libs are missing or not found you get an error message when starting minidlna
try this
ldd /usr/sbin/minidlna
find / -name <<missing lib>>
cp <<found lib>> /place/where/the/other/libs/are


Top
   
PostPosted: Wed Aug 01, 2012 6:58 am 
Offline
Newbie

Joined: Wed Aug 01, 2012 12:49 am
Posts: 8
thanks... i think...
as i said im new to this, and by "this" i mean the nas.
i think what you are saying is i need to install something on the device, but i have no idea how this is done. Also it looks like i have the LS-QVL so is that info still valid or does this thread need to be moved?

Yes im a noob at this :oops:


Top
   
PostPosted: Wed Aug 01, 2012 7:58 am 
Offline
Newbie

Joined: Wed Feb 29, 2012 8:39 pm
Posts: 6
hi,

the manual is for the ls-chl, and i think this doesnt matter.
first you need root access
then you have to install ipkg
then follow my post.

if you dont know what i mean, search this forum or dont touch your system


Top
   
PostPosted: Wed Aug 01, 2012 8:33 am 
Offline
Moderator

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
dcarbonetti wrote:
...
Yes im a noob at this :oops:

Maybe, it's the time to change this? ;)

Read about "open firmware" in this forum.
Then about "optware".
Remember that your CPU is a Kirkwood based.
If you know enough about opening the firmware
(means: root access) and optware (means: ipkg
as a package manager and the matching feed
for your CPU), you are prepared to follow the guide.

_________________
Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)


Top
   
PostPosted: Wed Aug 01, 2012 11:47 pm 
Offline
Regular Member

Joined: Sun May 06, 2012 1:45 am
Posts: 186
I'm not sure what you mean by "It looks fairly clear that the PS3 media player cant do it", but have you actually tried using the DLNA server built into your NAS? What result did you see on your TV?

Try updating the firmware on your NAS to the latest version (1.60) if you haven't already done so.


Top
   
PostPosted: Mon Aug 06, 2012 8:06 am 
Offline
Newbie

Joined: Wed Aug 01, 2012 12:49 am
Posts: 8
thanks folks. i updated to 1.6 and the new media server works perfectly for mkv's (other than a couple of times where it just dropped out and went to the file listing)


Top
   
PostPosted: Sun Aug 26, 2012 7:30 pm 
Offline
Total Newbie

Joined: Sun Aug 26, 2012 7:27 pm
Posts: 2
I've updated to 1.6 and still won't play the Audio. Do I need to change any settings on Twonky?>???


Could it be the TV?


Top
   
PostPosted: Wed Sep 05, 2012 6:38 am 
Offline
Newbie

Joined: Wed Sep 05, 2012 5:47 am
Posts: 8
The problem may, in fact, be that MKVs just don't really seem to stream as well as MP4s.
(After a month of lurking here I registered just to share this)

I know that this is an unpopular view, but in my experience, it's true.

This is how I test this, I take the same audio and video streams, and mux them into a MP4 container and a MKV container, then play them back from the server to your playback device and observe the results.

As an example, I have several devices that play locally stored MKVs well, yet they play them when streamed.

These problem files I run through a simple transcoding program with a nice batch mode, but to REMUX ONLY, Not Re-Encode, the video and audio streams.
(I should could probably write a shell script using mkvextract and ffmpeg to this, maybe when I finally get around to getting a login on my LS-WXL)

RE-Muxing does not cause a loss in quality, essentially it takes the data(streams) from one file format(container) and put them in another format(container) with-out altering the data, As a bonus re-muxing is pretty quick, takes little CPU power, and is mostly I/O dependent.

Re-Encoding is where you take the stream, render it, and then encode the result with a different codec, and since most material is in a lossey codec, you lose quality when this happens, and decoding/encoding takes time.

MKV is a nice idea, but it causes problems on embedded devices, MP4 seems better supported.

[EDIT] AC3 is another bugaboo, Dolby wants a license for commercial use of the AC3 codec, most embedded devices (and Windows8 and most phones) forgo AC3 support, transcoding the AC3 stream into AAC is the only option for those devices. [/edit]


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 9 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited