Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 8:06 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 63 posts ]  Go to page Previous 1 2 3 4 5 Next
Author Message
PostPosted: Sat Aug 10, 2013 7:04 pm 
Offline
Regular Member

Joined: Sun May 06, 2012 1:45 am
Posts: 186
stackoverflow wrote:
Would anyone know how to edit the ini file so that it can search for media outside of share folder? Eg in my case mnt/array1/

Change the following line in /mnt/array1/share/twonky/twonkydb/twonkyserver.ini
Code:
contentbase=/mnt/array1/share
to
Code:
contentbase=/mnt/array1


Top
   
PostPosted: Sat Aug 10, 2013 7:50 pm 
Offline
Total Newbie

Joined: Sat Aug 03, 2013 7:03 am
Posts: 4
ColinTaylor wrote:
stackoverflow wrote:
Would anyone know how to edit the ini file so that it can search for media outside of share folder? Eg in my case mnt/array1/

Change the following line in /mnt/array1/share/twonky/twonkydb/twonkyserver.ini
Code:
contentbase=/mnt/array1/share
to
Code:
contentbase=/mnt/array1


Thanks V much. Just what I was looking for. Spot on. :up:


Top
   
PostPosted: Sun Dec 22, 2013 9:21 am 
Offline
Newbie

Joined: Wed Apr 27, 2011 9:22 pm
Posts: 36
Hi

New version 7.2.6-2, working flawless as well with first page guide.

http://www.twonkyforum.com/downloads/7.2.6-2/twonky-kirkwood-7.2.6-2.zip


Top
   
PostPosted: Tue Dec 31, 2013 5:51 am 
Offline
Total Newbie
User avatar

Joined: Tue Dec 31, 2013 5:31 am
Posts: 3
Location: Germany
I am not a UNIX expert but I realized that twonky.sh always returned an error when trying to stop Twonky
Quote:
killall: bad signal name 's'
Because SIGTERM is the default signal for killall running on my HS-DHGL I think the previous line in the script
killall -s TERM ${DAEMON} can be safely replaced with the following simple instruction for stopping Twonky Mediaserver:
Code:
killall ${DAEMON}

At least this change seems to work for the stock 2.10 firmware installed on my LS.


Top
   
PostPosted: Wed Jan 08, 2014 1:52 am 
Offline
Regular Member

Joined: Sun May 06, 2012 1:45 am
Posts: 186
Hi Sniegov & Celeborn,

Thanks for the info.

I've made some very minor changes to the dropbox files we download to reflect 7.2.6-2. They're not really essential but here are the (non-raid) instructions anyway.

Code:
Disable the DNLA server in Buffalo web interface [Extensions/Media Server] if not already done

# /etc/init.d/twonky.sh stop
# mv /etc/init.d/twonky.sh /etc/init.d/twonky.sh.old

# rm -fr /mnt/disk1/twonky              # Only required if there is an existing installation here
# mkdir /mnt/disk1/twonky
# mkdir /mnt/disk1/twonky/twonkydb

# cd /mnt/disk1/twonky
# wget http://www.twonkyforum.com/downloads/7.2.6-2/twonky-kirkwood-7.2.6-2.zip
# unzip twonky-kirkwood-7.2.6-2.zip
# rm twonky-kirkwood-7.2.6-2.zip

# mv twonkyserver-default.ini twonkyserver-default.ini.old
# wget http://dl.dropboxusercontent.com/u/49494657/Twonky/7.2.6/twonkyserver-default.ini

# cd /etc/init.d
# wget http://dl.dropboxusercontent.com/u/49494657/Twonky/7.2.6/twonky.sh
# chmod 755 twonky.sh

# /etc/init.d/twonky.sh start
These instructions assume your media files are located somewhere under /mnt/disk1/share. If this is not the case you must change the contentbase= line in twonkyserver-default.ini before running twonky for the first time.

I've not had a chance to test this new version.


Last edited by ColinTaylor on Sun Jan 12, 2014 3:58 pm, edited 5 times in total.

Top
   
PostPosted: Wed Jan 08, 2014 6:51 am 
Offline
Total Newbie
User avatar

Joined: Tue Dec 31, 2013 5:31 am
Posts: 3
Location: Germany
ColinTaylor wrote:
I've not had a chance to test this new version.

I did a quick check and it does not work.
As said I am not an expert at all, therefore I cannot provide much valuable input.
It seems that some pre-defined variables in the new script have different or no values compared to the old script.
My installation is located at /mnt/disk1/share/twonky and below has been taken from the previous script
Code:
WORKDIR="/mnt/disk1/share/twonky"
APPDATA="/mnt/disk1/share/twonky/twonkydb" # Default is /var/twonky/TwonkyServer
LOGSDIR=$APPDATA # Default is /tmp
PIDFILE=/var/run/mediaserver.pid
I already tried to adjust WORKDIR1 in the new script but other errors will occur.
Sorry for that.


Top
   
PostPosted: Wed Jan 08, 2014 1:57 pm 
Offline
Regular Member

Joined: Sun May 06, 2012 1:45 am
Posts: 186
Hi Celeborn,

Thanks for the feedback. There was a typo in twonkyserver-default.ini which I've now corrected. :oops:

I'm not sure whether that was your problem, also the instructions above are for new installs into /mnt/disk1/twonky. I've tweaked the instructions to make that a bit clearer.

*Sorry, this is a different location than that on page 1*


Top
   
PostPosted: Thu Jan 09, 2014 6:44 am 
Offline
Total Newbie
User avatar

Joined: Tue Dec 31, 2013 5:31 am
Posts: 3
Location: Germany
Hi Colin,
I did a new install as described and everthing works nicely now :D
Thanks for your work!


Top
   
PostPosted: Thu Jan 23, 2014 10:35 pm 
Offline
Newbie

Joined: Sun Jun 17, 2012 1:32 pm
Posts: 13
ColinTaylor wrote:
Hi fhab123,

It looks like firmware 2.10 uses a different method of starting and stopping services.

You need to add a line to the end of /etc/init.d/rcS with this command:
Code:
# echo "exec_sh twonky.sh" >> /etc/init.d/rcS

And another line to /etc/init.d/shutdown_proc.sh
Code:
# echo "/etc/init.d/twonky.sh stop" >> /etc/init.d/shutdown_proc.sh


Simply cat'ing the new line to the end of /etc/init.d/rcS didnt work for me, because for some reason the final line in that file previously was "exit 0", so the script never got to the automatic twonky start line! Editing it in before the exit command worked.

Thanks for the 7.2.6 updates - Seems to be working fine now :D


Top
   
PostPosted: Mon May 12, 2014 10:51 am 
Offline
Newbie

Joined: Tue Jul 16, 2013 4:10 pm
Posts: 6
My linkstation live is running fine with twonky 7.0.9 installed. However, I just performed an edit of my audio files meta data with the software mp3tag (mainly clean up artist and genre to make it more consistent) but twonky does not seem to have updated its database with this modification. So when I browse through the twonky library with my tablet or phone I still see the old metadata.

Should I perform a rebuild of the database? If yes, can you please tell me which command to use because I cannot see this feature from the twonky web admin interface. Otherwise do you have any other suggestion?

Thank you in advance for your feedback,
Francois


Top
   
PostPosted: Tue Jun 03, 2014 11:24 pm 
Offline
Newbie

Joined: Mon Oct 22, 2012 8:08 am
Posts: 11
Twonky Server 7.3-RC4 is out: http://www.twonkyforum.com/downloads/7.3-RC4/twonky-kirkwood-7.3-RC4.zip

Below are all of the revisions available: http://www.twonkyforum.com/viewtopic.php?f=2&t=9424

I got version 7.3-RC4 to work and start. The media scanner is going through my directories, but it never adds any files to the database. Anybody have any suggestions?

Additionally when using Twonky 7.2.6-2 or 7.2.8, my library (video, music, or pictures at the top of the web interface) does not show any of the files in my database - it just shows a header with "My Library". With these 7.2.x versions, however, the media scanner finds files, loads the database, and the layout is viewable via DLNA clients - just not the web interface. Anybody have any suggestions?


Top
   
PostPosted: Wed Jun 04, 2014 10:03 pm 
Offline
Total Newbie

Joined: Sat Oct 12, 2013 5:54 pm
Posts: 1
I had similar same behaviour with 7.3. Interface looks good, but no files being added to the library, not on DLNA clients either.
Tried trace logging and it's reading the files correctly, but couldn't see why they weren't being loaded.

Is there anywhere to report our issues?

Went back to 7.2.8 and working fine again.


Top
   
PostPosted: Fri Jun 06, 2014 5:46 am 
Offline
Newbie

Joined: Mon Oct 22, 2012 8:08 am
Posts: 11
The only version I can get to work for remote access web streaming,through not enabling the remoteUI, but rather port forwarding the same local twonky port 9050 on my router, is Twonky Special 7.0.11 (http://www.twonkyforum.com/downloads/7.0.11-special/twonky-kirkwood-special-7.0.11.zip)

I also changed my config.js file in /mnt/disk1/twonky/resources/webconfig/config.js to this file: http://www.twonkyforum.com/download/file.php?id=848
The full instructions are here (relative links enable): http://www.twonkyforum.com/viewtopic.php?f=2&t=10627#p40577

Other tweaks: http://www.twonkyforum.com/viewtopic.php?f=2&t=10627


Top
   
PostPosted: Mon Feb 23, 2015 8:35 pm 
Offline
Newbie

Joined: Wed Apr 27, 2011 9:22 pm
Posts: 36
Hi

New version shows up (8.0.2): http://www.twonkyforum.com/downloads/8.0.2/

I tried to get it work and it's starting even but I have no access to config page.
Anyone have same issue?

If someone need assistance with old files for 7.2.8:
Default installation: /mnt/disk1/share/twonky
Code:
wget http://37.247.56.30/Twonky/twonky.sh
wget http://37.247.56.30/Twonky/twonkyserver-default.ini


Top
   
PostPosted: Tue Feb 24, 2015 10:42 am 
Offline
Newbie

Joined: Wed Apr 27, 2011 9:22 pm
Posts: 36
Twonky 8.0.2 web page is starting now - just tested 1 day but it's ok I think.

Code:
# #### Only for non-ride ####

Always do backup: # mv /mnt/disk1/share/twonky /mnt/disk1/share/twonky_old

# #### Installation folder /mnt/disk1/share/twonky
/etc/init.d/twonky.sh stop
mv /etc/init.d/twonky.sh /etc/init.d/twonky.sh.old
chmod -x /etc/init.d/twonky.sh.old
mkdir /mnt/disk1/share/twonky
mkdir /mnt/disk1/share/twonky/twonkydb
wget http://www.twonkyforum.com/downloads/8.0.2/twonky-kirkwood-8.0.2.zip
unzip twonky-kirkwood-8.0.2.zip
rm twonky-kirkwood-special-8.0.2.zip
chmod 755 twonkys* twonkyproxy twonkywebdav cgi-bin/* plugins/*
mv twonkyserver-default.ini twonkyserver-default.ini.old
wget http://37.247.56.30/Twonky/twonkyserver-default.ini
cd /etc/init.d
wget http://37.247.56.30/Twonky/twonky.sh
chmod +x twonky.sh
/etc/init.d/twonky.sh start


Server with files is working form 7:00am to 1:00am GMT+1 everyday


Last edited by Sniegov on Wed Mar 04, 2015 12:48 am, edited 1 time in total.

Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 63 posts ]  Go to page Previous 1 2 3 4 5 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited