Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Apr 22, 2018 11:50 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 16 posts ]  Go to page Previous 1 2
Author Message
PostPosted: Wed Dec 21, 2016 5:48 pm 
Offline
Newbie

Joined: Sun Dec 18, 2016 8:12 pm
Posts: 9
oxygen8 wrote:
this looks good
try it with the clones or with one clone


Booted up my PC with Knoppix and Disk2 attached.
Ran cat /proc/partitions and cat /proc/mdstat and they looked good, it automatically recognized the raid1 with only one out of 2 drives:

Code:
knoppix@Microknoppix:~$ cat /proc/mdstat 
Personalities : [raid1]
md10 : inactive sda5[1](S)
      1000436 blocks super 1.2
       
md1 : inactive sda2[1](S)
      4999168 blocks super 1.2
       
md2 : active raid1 sda6[1]
      2914874232 blocks super 1.2 [2/1] [_U]
     
md0 : inactive sda1[1](S)
      1000384 blocks
       
unused devices: <none>


So, all I did was create /mnt/array1 and mounted /dev/md2 to /mnt/array1, it successfully mounted and I'm able to read all of my data:

Code:
knoppix@Microknoppix:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
rootfs          3.9G   48K  3.9G   1% /
/dev/sr0        4.4G  4.4G     0 100% /mnt-system
tmpfs           6.3G  2.5M  6.3G   1% /ramdisk
/dev/cloop      9.6G  9.6G     0 100% /KNOPPIX
/dev/cloop1    1010M 1010M     0 100% /KNOPPIX1
unionfs         6.3G  2.5M  6.3G   1% /UNIONFS
tmpfs            20M  3.3M   17M  17% /run
tmpfs            10M  4.0K   10M   1% /UNIONFS/var/lock
tmpfs           100M  100K  100M   1% /UNIONFS/var/log
tmpfs           2.0G   24K  2.0G   1% /tmp
udev             20M     0   20M   0% /dev
tmpfs           2.0G     0  2.0G   0% /dev/shm
tmpfs           799M  4.0K  799M   1% /run/user/1000
/dev/md2        2.8T  820G  2.0T  30% /mnt/array1



I attached an external hdd and mounted it and I am backing up the important files to it from the mounted drive first, then I'll clone the HDD and attempt to adjust the /etc/melco/diskinfo file on the NAS after putting Disk2 back in.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 16 posts ]  Go to page Previous 1 2

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited