Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat Aug 18, 2018 11:59 am

All times are UTC+01:00

Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Oct 19, 2013 10:52 am 
Total Newbie

Joined: Sat Oct 19, 2013 10:51 am
Posts: 3
After reading through the wiki + forums more, I have found out that you cannot install freelink on the quad.

However, I did find all the guides on installing debian squeeze / wheezy on the quad instead. I have followed about 4 of these now, but cannot get it to work. Here's a quick summary of what I have tried:

The quad is running shonks 1.65mod1a firmware, this works fine.
I can turn on ssh, and connect to the quad without problem.
I have built the debian debootstrap (using 1.52, 1.53 and 1.35 - current rootfs is using 1.53).
I have done all the config within the rootfs as per pastebin method, wiki method and various forum posts.
All of these steps seem to go well.

I have tried the empty initrd from tyche/urasim.
I have tried building an initrd as per the guides above. I also tried the wiki raidboot one, and the scripts on the forum (I forget the link, but they are DEBIAN WHEEZY INSTALLATION GUIDE FOR LS-WVL BY sebi85 v2.0 (2013)).
I have tried pointing it to 901,902,921,806.
I have tried installing them by putting them in /boot/ as .updated, as they are, and even using LSUpdater.
In all cases, it either continues to boot the standard buffalo environment, or hits a boot loop until I wipe the drive / LSUpdater->Repartition / start again.

Please, can anyone help me out before I completely lose my sanity!

Details here:

root@Nas:/# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid6] [raid5] [raid4]
md1 : active raid1 sda2[0]
      4999156 blocks super 1.2 [4/1] [U___]

md10 : active raid1 sda5[0]
      1000436 blocks super 1.2 [4/1] [U___]

md21 : active raid1 sda6[0]
      961749880 blocks super 1.2 [2/1] [U_]

md0 : active raid1 sda1[0]
      1000384 blocks [4/1] [U___]

unused devices: <none>

root@Nas:/# cat /proc/partitions
major minor  #blocks  name

  31        0        512 mtdblock0
  31        1      16384 mtdblock1
  31        2     499712 mtdblock2
  31        3       8192 mtdblock3
   8        0  976762584 sda
   8        1    1000448 sda1
   8        2    5000192 sda2
   8        3       1024 sda3
   8        4       1024 sda4
   8        5    1000448 sda5
   8        6  961751040 sda6
   9        0    1000384 md0
   9       21  961749880 md21
   9       10    1000436 md10
   9        1    4999156 md1

root@Nas:/# uname -a
Linux Nas 3.3.4-88f6281 #1 Thu May 16 13:46:55 JST 2013 armv5tel unknown

mdadm.conf (/root/wheezy/etc/mdadm/mdadm.conf)
ARRAY /dev/md0 UUID=c41b81ca:e3e7a5db:c12a62a1:54a6023d
ARRAY /dev/md/1 metadata=1.2 UUID=ba2c77a5:f01fb50c:fff7bc26:eb7aef84 name=LS-QVL-EM8CE:1
ARRAY /dev/md/10 metadata=1.2 UUID=01ffbb29:7b382475:69a6deb5:92cdcf19 name=LS-QVL-EM8CE:10
ARRAY /dev/md/21 metadata=1.2 UUID=81aae3e7:16c08ebb:50b79fb1:f3eaf9d4 name=LS-QVL-EM8CE:21

mdadm.conf (/etc/mdadm.conf)
ARRAY /dev/md0 UUID=a60470a8:2c75efca:c12a62a1:54a6023d
ARRAY /dev/md/1 metadata=1.2 UUID=229b5da6:b1d889fa:d4bac1c3:e309ae46 name=LS-QVL-EM8CE:1
ARRAY /dev/md/10 metadata=1.2 UUID=d4970fdb:017bf5cd:f26697ec:ff0561c0 name=LS-QVL-EM8CE:10
ARRAY /dev/md/21 metadata=1.2 UUID=6388269b:583a480f:286708d6:080ac5e7 name=LS-QVL-EM8CE:21

root@Nas:/etc# fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1               1      121602   976762583+ ee EFI GPT

root@Nas:/etc# parted
GNU Parted 1.8.8
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
Model: SAMSUNG HD103UJ (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name     Flags
 1      1049kB  1026MB  1024MB  ext3         primary
 2      1026MB  6146MB  5120MB               primary
 3      6146MB  6147MB  1049kB               primary
 4      6147MB  6148MB  1049kB               primary
 5      6148MB  7172MB  1024MB               primary
 6      7172MB  992GB   985GB                primary

Ideally, I do not want to use a raid. Currently I only have 1 disk, but I plan to add more.

Any more details required, please let me know!

Thanks in advance!

PostPosted: Wed Oct 30, 2013 10:32 am 
Total Newbie

Joined: Sat Oct 19, 2013 10:51 am
Posts: 3
Edited original post - did more reading and found it's not possible to run freelink, but can't get debian to work either!

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited