Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Aug 17, 2018 9:28 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sat Oct 23, 2010 7:11 am 
Offline
Newbie

Joined: Wed Oct 07, 2009 12:00 am
Posts: 48
Since the general topic was getting a little long, here is a new topic for people who are looking for this specific solution.

The wiki has been updated with instructions for installing Debian version 5.0.6 (Lenny) on a Buffalo Linkstation Mini (model LS-WSxxxxGL/R1) with the backported Linux kernel (version 2.6.32-23)...
http://buffalo.nas-central.org/wiki/Install_Debian_5.0_(Lenny)_On_Buffalo_Linkstation_Mini

Enjoy!


Top
   
PostPosted: Mon Nov 15, 2010 11:59 am 
Offline
Regular Member
User avatar

Joined: Mon Oct 08, 2007 6:34 am
Posts: 334
Thank you! :up:

_________________
KuroHG - UBoot 1.2, foonas-em & Debian Wheezy - 3.4 Kernel
Kurobox Pro - Dave's Lenny-armel
LS-WVL - opened
LS-XHL - Squeeze Bootstrap
LS-VL - Squeeze Bootstrap


Top
   
PostPosted: Sun Nov 28, 2010 7:43 am 
Offline
Newbie

Joined: Wed Oct 07, 2009 12:00 am
Posts: 48
Kernel updated to support fail2ban package (by adding support for netfilter, iptables, and multiport modules)

Latest kernel is here...
http://downloads.buffalo.nas-central.org/Users/rpinchbeck/lsmini/debian/5.0/kernel-2.6.32-27-debian-lsmini.tar.gz

Wiki updated accordingly...
http://buffalo.nas-central.org/wiki/Install_Debian_5.0_(Lenny)_On_Buffalo_Linkstation_Mini


Top
   
PostPosted: Sun Dec 12, 2010 3:49 am 
Offline
Newbie

Joined: Sat Oct 24, 2009 1:46 pm
Posts: 48
Hi,
I built my own the kernel for LS Mini (2.6.34) and it booted fine (I can access SSH) and everything is fine so far.

But the LS Mini's LEDs are blinking all the time, do we have micro_evtd for LS Mini so it can control the LED of Mini (at least it should stops once it's has done with booting)?? I tried the micro_evtd 3.3.3.6 from Debian repo but micro_evtd said that the machine is not supported.

Thanks.....


Top
   
PostPosted: Sun Dec 12, 2010 8:03 am 
Offline
Moderator

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Try
Quote:
blstools

You can find the source at:
http://sourceforge.net/projects/blstools
Maybe it is working with the Mini as well?

_________________
Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)


Top
   
PostPosted: Sun Dec 12, 2010 9:05 am 
Offline
Newbie

Joined: Sat Oct 24, 2009 1:46 pm
Posts: 48
kenatonline wrote:
Try
Quote:
blstools

You can find the source at:
http://sourceforge.net/projects/blstools
Maybe it is working with the Mini as well?


Hi,
Thanks for that. However, seems that it can not work with Mini (blstools is designed for stock fw with new kernel? And Kirkwood-based hardware? LS Mini is Orion, identical to LS Live/Pro in term of CPU platform)

This is result that I got from the serial access after adding blstools:

Code:
/etc/rc2.d/S99lsmonitor: line 122: /proc/buffalo/gpio/led/power_blink: No such file or directory
/etc/rc2.d/S99lsmonitor: line 123: /proc/buffalo/gpio/led/power: No such file or directory
/etc/rc2.d/S99lsmonitor: line 127: /proc/buffalo/booting: No such file or directory
cat: /proc/buffalo/gpio/switch/power: No such file or directory
cat: /proc/buffalo/gpio/switch/auto_power: No such file or directory
/etc/rc2.d/S99lsmonitor: line 102: /proc/buffalo/gpio/fan/control: No such file or directory
INIT: Sending processes the TERM signal

/etc/rc0.d/K00lsmonitor: line 113: kill: (1486) - No such process
/etc/rc0.d/K00lsmonitor: line 143: /proc/buffalo/booting: No such file or directory
/etc/rc0.d/K00lsmonitor: line 146: /proc/buffalo/gpio/led/power: No such file or directory
/etc/rc0.d/K00lsmonitor: line 147: /proc/buffalo/gpio/led/power_blink: No such file or directory


And the LS Mini reboots itself endlessly..

Any helps?


Top
   
PostPosted: Sun Dec 12, 2010 11:18 am 
Offline
Moderator

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Sorry, but that's beyond me.

_________________
Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)


Top
   
PostPosted: Wed Apr 13, 2011 7:37 am 
Offline
Regular Member
User avatar

Joined: Fri Jul 25, 2008 3:23 pm
Posts: 160
Location: Kobe, Japan
NASNAS wrote:
But the LS Mini's LEDs are blinking all the time, do we have micro_evtd

No, we don't as there is not need for micro_evtd.
LEDs are controlled by files in /sys/class/leds/

BTW are you using older or newer model?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 8 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited