Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Aug 17, 2018 12:47 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Tue Jul 06, 2010 10:08 am 
Total Newbie

Joined: Mon Jul 05, 2010 8:46 pm
Posts: 3

Is there anything different in Hardware on the LS-WSX1.0TL/R1 and the LS-WSGL?

I have successfuly installed Debian on a LS-WSGL (LS-Mini) and now ordered another LS-Mini and got a LS-WSX (again LS-Mini) but all efforts to get debian running (or gentoo) are not working. So I think there is a hardware change in the LS-WSX. Can anyone verify that?


Can anyone tell me how to get a Linux running on that box?


PostPosted: Sat Jul 10, 2010 6:30 am 

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2734
LS-WSXL has Kirkwood-CPU. Firmware is different to LS-WSGL.

PostPosted: Fri Feb 18, 2011 7:56 pm 

Joined: Wed Feb 16, 2011 11:15 am
Posts: 12

I share your problem!

First, I tried to install Gentoo/Genlink by following this article (http://buffalo.nas-central.org/wiki/LS_Mini:_Install_Gentoo) but the tarball wars damaged. :-(

Later, I tried the article (http://buffalo.nas-central.org/wiki/Deb ... _on_LS-WXL) twice .. but it doesn't work, too. :-/ The setup of the boot image works without problems ... but the mini doesn't reboot ... pray don't work :-(

However, the article (http://buffalo.nas-central.org/wiki/Rev ... k_Firmware) shows how to revert your ls mini to stock firmaware.

Is there anyone who is able to explain how to get debian working on the ls mini (LS-WSX1.0TL/R1)? doesn't matter what way - via disassembling or not.

I got following hardware and HDD/RAID settings:

root@Nas:/proc# cat cpuinfo
Processor       : Feroceon 88FR131 rev 1 (v5l)
BogoMIPS        : 598.01
Features        : swp half thumb fastmult edsp
CPU implementer : 0x56
CPU architecture: 5TE
CPU variant     : 0x2
CPU part        : 0x131
CPU revision    : 1
Hardware        : Feroceon-KW
Revision        : 0000
Serial          : 0000000000000000

root@Nas:/proc# cat soc_type
MV88F6281 Rev 2
L2 Enabled
L2 ECC Disabled
L2 Prefetch Disabled
Write Allocate Disabled
CPU Streaming Disabled

root@Nas:/proc# fdisk -l
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1               1       60802   488386583+ ee EFI GPT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sdb1               1       60802   488386583+ ee EFI GPT

root@Nas:/proc# cat mdstat
Personalities : [linear] [raid0] [raid1] [raid6] [raid5] [raid4]
md2 : active raid1 sdb6[0] sda6[1]
      473467590 blocks super 1.2 [2/2] [UU]

md10 : active raid1 sda5[0] sdb5[1]
      999872 blocks [2/2] [UU]

md1 : active raid1 sda2[0] sdb2[1]
      4999936 blocks [2/2] [UU]

md0 : active raid1 sda1[0] sdb1[1]
      999872 blocks [2/2] [UU]

unused devices: <none>

maybe it helps

PostPosted: Mon Feb 21, 2011 9:19 pm 

Joined: Wed Feb 16, 2011 11:15 am
Posts: 12
i did it! :biglol: reboot = disconnect disk and reboot

ok, additional to the wiki article (http://buffalo.nas-central.org/wiki/Debian_Lenny_on_LS-WXL) my experiences:
follow the article from beginning to "Install rootfs in temporary partition".
on this point do not reboot with both hdd's connected!

work around - if your linkstation do not proper reboot (like my case):
    - put off and disassembly your linkstaion (see: http://buffalo.nas-central.org/wiki/Disassemble_the_LS_MINI, HINT: use a Swiss army knife instead of a screwdriver)
    - disconnect e.g. disk 2 (sdb)
    - boot and wait a minute, NOTE: the blinking LED doesn't indicate the booting process or something, because the new system don't know about LEDs or buttons since blstools is installed
    - after waiting: connect to the linkstation via ssh
    - move on with "Install rootfs in /dev/md1" at the article
    - now put off the linkstation
    - connect disk 2 (sdb) and put it on again (the linkstation should boot without a problem)

if the boot and login works, add the sdb to the raid arrays:
1. copy the partition table from sda to sdb
dd if=/dev/sda of=/dev/sdb count=1 bs=512

2. read the new partition table of sdb
sfdisk -R /dev/sdb

3. add the sdb partitions to the raid arrays
mdadm /dev/md0 -a /dev/sdb1
mdadm /dev/md1 -a /dev/sdb2
mdadm /dev/md2 -a /dev/sdb6
mdadm /dev/md10 -a /dev/sdb5

--- done --
have fun!

PostPosted: Sat Dec 01, 2012 9:37 pm 
Total Newbie

Joined: Sat Dec 01, 2012 9:34 pm
Posts: 4

After aply all itens on this manual (http://buffalo.nas-central.org/wiki/Ins ... 0_(Squeeze)_On_Buffalo_Linkstation_Mini) my linkstation is rebooting all time?

What can i do?

I try 2 process:

a) copy images (telnet)
b) Using LSUpdater

I got 2 files: hddrootfs.buffalo.updated and initrd.buffalo

Helpme please..
Thank you!

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited