Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Aug 20, 2018 9:25 am

All times are UTC+01:00

Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Nov 14, 2017 10:15 pm 
Total Newbie

Joined: Tue Nov 14, 2017 7:52 pm
Posts: 2
I'm hoping someone can point me in the right direction here.

I have an LS-WTGL (v3 with the two USB ports) that, after a long period of inactivity, somehow wiped the entire set of partitions. It had gone in to EM mode and, with lots of perseverance, I managed to reinstall with the stock firmware (3.10) via TFTP and one of the original disks. I have since then taken that disk out and tried to install Debian Stretch on the other original disk.

Here's where it gets weird. I wiped the disk, repartitioned and tried the Net Console install, again via TFTP, from:

http://ftp.debian.org/debian/dists/stre ... o/ls-wtgl/

This all installs on the disk, and all looks well. I forgot to change the NVRAM settings then, and it failed to boot - unsurprisingly. However, if I extracted the uImage.buffalo, and initrd.buffalo I could TFTP boot from those and the rest of the Debian installation would load from the disk - so the disk itself is working. Since then I have rebooted in to the stock OS, and altered the NVRAM settings. The tail end of fw_printenv output is:

bootcmd=ide reset; ext2load ide 1:1 0x00100000 /$(kernel); ext2load ide 1:1 0x00800000 /$(initrd); setenv bootargs $(bootargs_base) $(bootargs_root) $(bootargs_func) $(bootargs_debug) $(buffalo_ver); bootm 0x00100000 0x00800000
def_tftp=tftp 0x00100000 $(kernel); tftp 0x00800000 $(initrd); setenv bootargs $(bootargs_base) $(bootargs_root) $(buffalo_ver) tftpboot=yes; bootm 0x00100000 0x00800000
bootargs_root=root=/dev/sda2 rw panic=5

I believe the bootargs_root variable is set to what it ought to be. Even with this setting the box still won't boot from the disk, but will via TFTP. The same uImage.buffalo and initrd.image. I'm rather flummoxed now.

Any advice? Anything I've forgotten to do?


PostPosted: Thu Nov 16, 2017 11:10 am 
Total Newbie

Joined: Tue Nov 14, 2017 7:52 pm
Posts: 2
I found the problem to this last night - 256 byte inodes! Searching around, trying to get a handle on it, I stumbled across some references to U-Boot not handling anything other than 128 byte inodes. A quick check of my stock OS drive, and my Debian drive and the former was 128 and the latter 256. I re-mkfs'd the /boot partition today, with 128 byte inodes, and it works properly :-)

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited