Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat May 26, 2018 1:11 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Jun 18, 2011 10:03 pm 
Offline
Newbie

Joined: Sat Jun 18, 2011 6:46 pm
Posts: 6
Hi Folks,
I've had my little Linkstation box since 2006, hence perhaps this technology is now treated
as "ancient" here (apologies to any offended readers! :-), but I'm still fond of the device and
wish to perpetuate its use.
I want to bring the box up to date, since it will probably become my new web server (I've changed
ISPs and the new one doesn't donate web space at all).

Although I'm not averse to new ideas, I can now see the merit in sticking with version "numbers"
when labelling things: all this "sarge", "lenny" and "etch" is too cute to be useful in my opinion.

Anyways, when I run uname -a on my box I gets:
Linux LinkStation 2.4.20_mvl31-ppc_linkstation #1 Thu, 09 Feb 2006 11:56:26 +0900 ppc GNU/Linux

I'd like to upgrade to the latest and greatest version of Debian. A simple "cat /etc/debian_version"
reveals the box to be on "3.1".

I came here to this site to see how to upgrade my linkstation. The first hurdle seems to be box identification: there
are lots of different labels whizzing around and it makes life a little tricky and confusing. This is more of an observation
than a complaint (it wouldn't be right to complain if you are asking for help :-) )

Andre has helped me in the past, so I was keen to follow his advice on performing an update.
Something to do with "webinstaller_kernel.sh".
So I downloaded that to the present box, and ran it.
The script trundled along with lots of disconcerting "Continued download failed" outputs, but eventually it
stumbled (I guess) firstly at:
"--> modules retrieved.
--> Getting Debian extras... ./webinstaller-kernelinst.sh: line 245: [: 3.1: integer expression expected
Reading Package Lists... Error!
"

[on reflection, the comparison of the real number "3.1" against the value "5" in the script is unlikely to
succeed, hence I copied the script to a new file and then edited it to force the value to be "3" and let the script run on.]

Running this patched script, I got a Fatal error output:

FATAL: Can't install Debian's module-init-tools, or lm-sensors (Tera only)
--> You need to take care of that yourself:
/usr/local/sbin/fix_moduleinittools.sh
apt-get --reinstall install wget diff module-init-tools
apt-get --reinstall install lm-sensors # Tera only
--> Then re-run the webinstaller.

Yep, happy to take care of things myself, so I ran "/usr/local/sbin/fix_moduleinittools.sh". Or at least
I tried to. No such script. I even did a "find" from root for this file - nope. I then came back to nas-central
to have a look see. Nope. A quick squint at "http://hvkls.dyndns.org/downloads/" doesn't reveal the file
either. Google is less than useful here too.
So I'd like to upgrade my box, but I'm stuck.

I wonder if a dodgy /etc/apt/sources.list file's contents could be part of my problem: here's what I've
got (after much reading of suggestions what to set this to):
"

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free
deb http://debian.netcologne.de/debian/ squeeze main contrib non-free
deb-src http://debian.netcologne.de/debian/ squeeze main contrib non-free


deb http://mirrors.kernel.org/debian/ stable main
deb-src http://mirrors.kernel.org/debian/ stable main

deb http://security.debian.org/ stable/updates main
"

Sometimes I wonder whether I'm witnessing the birth of a new religion with Linux: it
seems that only the high priests get to understand the incantations they emit! ;-)

So I'm sending this post off to the forum for advice. A quick check on the traffic here and
I might not get heard, so in the meantime I am planning on following the instructions
at http://buffalo.nas-central.org/wiki/Fre ... nux_Server

The box's hard disk is about 80% full of stuff, but I've copied the important bits to another
machine and hence I'd happily take a "nuke the damn thing and start again" approach.
I've already managed to flash the firmware back to a Buffalo version (which is useless, hence I
re-flashed it back to Freelink I think about ten minutes later).
I've tried so many permutations (monkeys-and-typewriters style) that I have no idea what crap
I've got on the box: I just want to wipe the decks and start again.

Advice please if you would be so kind; thankyou in advance.

Regards

Mungo


Top
   
PostPosted: Sun Aug 14, 2011 3:12 am 
Offline
Moderator
User avatar

Joined: Thu Apr 06, 2006 1:33 pm
Posts: 1082
Location: United States of America
You can install Debian squeeze if you want.

1st. Install a header and level shifter for serial console access.

http://buffalo.nas-central.org/wiki/Add ... inkstation

2nd. Use this to help you Install Uboot

http://buffalo.nas-central.org/wiki/U-boot_bootloader
http://downloads.buffalo.nas-central.or ... ecompiled/

3rd. Run and then flash Foonas-EM to the device

http://www.foonas.org/index.php/Foonas-em:Install-lsppc

4th. Use Foonas-EM to partition your hard drive

5th. Install Stonie's Debian squeeze tarball to your hard drive

viewtopic.php?f=9&t=22703

You'll then have a Linkstation HG
with Uboot as a bootloader, Foonas EM as a recovery console, and Debian squeeze on the Hard drive.

_________________
-Ramuk

LinkStation HG *250 Uboot - Foonas-EM - Freelink
Kuro HG *750 Uboot - Foonas-EM - Debian Squeeze
Kuro HD *60 Uboot - Foonas-EM - Debian Squeeze (For Sale)
KuroPro *2TB Debian Lenny Armel- Kernel 2.6.26
KuroPro *1TB Debian Lenny Armel- Kernel 2.6.25.6


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited