Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Nov 17, 2017 8:25 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Thu Apr 15, 2010 4:33 am 
Offline
Total Newbie

Joined: Thu Apr 15, 2010 4:17 am
Posts: 2
Does anybody know the magic sequence of steps to get a working Squeeze installation on Kurobox HG?

I began with a blank hard drive and stock firmware yesterday. After scouring the forums I have finally got u-boot, foonas and the Lenny tarball installed and working perfectly. (Thank you all for putting all this information online.)

But, I'm greedy and want Squeeze, not Lenny. I decided to give it a whirl and updated my apt source to squeeze and did a dist-upgrade. It didn't quite work.

- install-info wouldn't update. I fixed this by deleting the contents of /etc/environment.

- udev won't update because "udev requires that support for the CONFIG_SYSFS_DEPRECATED feature is disabled in the running kernel", which is the 2.6.28 from the Lenny tarball. I investigated andre's webinstaller to see if something newer would be installed, but it looks like it wants to install 2.6.25.

Has anyone successfully installed Squeeze? How'd you do it? Any ideas on how I might make some progress?

Thanks!

[Sidenote: My ultimate goal is to have gcc 4.4 on my system. I do crypto research on various architectures, and to make things as equal as possible, I try to have the latest gcc on all machines.]


Top
   
PostPosted: Thu Apr 15, 2010 4:52 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
well, you'd have to roll the kernel without that feature enabled.

this is a little problematic for the upgrade from Lenny to Squeeze, and I"m curious to see how they handle it - Lenny won't run withvery well without that feature enabled, and Squeeze won't run with it enabled. (If I understand correctly).

I have been running Lenny for a year now, stably on my ARM9 LSPro, but some things like netatalk seem better from the testing/Squeeze side. I'm interested in putting together a tarball for Squeeze for both PPC boxes and my LSPro... no time right now, but I will prolly try to roll it this summer, if no one else does first.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Thu Apr 15, 2010 5:23 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Is that what you want?

# CONFIG_SYSFS_DEPRECATED_V2 is not set
CONFIG_SYSFS=y

Or is it you want both turned off?


Top
   
PostPosted: Thu Apr 15, 2010 5:27 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
hi andre,

what you have posted there looks like what I've read (or what I understood) that Squeeze's udev 150 requires.

I haven't actually debootstrapped it and tried to boot w/ a kernel, but maybe its worth an hour or two one of these coming weekends.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Thu Apr 15, 2010 9:42 pm 
Offline
Total Newbie

Joined: Thu Apr 15, 2010 4:17 am
Posts: 2
I forgot to report one thing yesterday: I had installed udev into my Lenny installation before upgrading to Squeeze, and I now realize that this was shooting myself in the foot. I just now reinstalled Lenny and upgraded to Squeeze without significant problems, this time without installing udev. Squeeze with the supplied Lenny tarball kernel and without udev seems to work just fine.

The only minor hiccups during the upgrade were (for anyone else interested in upgrading):

- Installation of install-info consults /etc/environment and reports an error trying to iterate over the contents of LC_CTYPE, which is defined as an empty string in /etc/environment. Squeeze's /etc/environment is an empty file, so I erased the contents of /etc/environment and installation continued okay.

- The upgrade couldn't migrate to dependency-based boot system because K95avr_evtd, S25libdevmapper1.02, libdevmapper1.02, apservd, ls_servd, ppc_uartd, avr_evtd_gentoo, and avr_evtd are all missing LSB tags and overrides. The system does, however, work alright without the migration.

Other than that, all seems well.


Last edited by krovetz on Fri Apr 16, 2010 4:49 pm, edited 1 time in total.

Top
   
PostPosted: Fri Apr 16, 2010 2:21 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
thanks, krovetz, that's useful... I may try this soon.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Fri Jan 21, 2011 7:27 am 
Offline
Regular Member
User avatar

Joined: Mon Oct 08, 2007 6:34 am
Posts: 334
Guys thanks for posting this information!

I have upgraded Dave's Lenny Rootfs to squeeze using these tips. I have also built a new 2.6.37 kernel to go with it. Everything is working nicely.
I do get a warning about oom_adj when booting with the new kernel:
Code:
sshd (1316): /proc/1316/oom_adj is deprecated, please use /proc/1316/oom_score_adj instead.

Due to it being depreciated in 2.6.36 but as far as I can tell it’s not a problem in the short term at least git.kernel.org

Now for a question: Do you guys know what we need to do to move to the new dependency based boot?
I have been doing a bit of reading on the Debian Wiki but I’m unsure of what I need to do in the case context of the Kuro\linkstation?

Cheers,
Stonie.

_________________
KuroHG - UBoot 1.2, foonas-em & Debian Wheezy - 3.4 Kernel
Kurobox Pro - Dave's Lenny-armel
LS-WVL - opened
LS-XHL - Squeeze Bootstrap
LS-VL - Squeeze Bootstrap


Top
   
PostPosted: Tue Jan 25, 2011 11:48 pm 
Offline
Regular Member
User avatar

Joined: Mon Oct 08, 2007 6:34 am
Posts: 334
Guys I have posted my Squeeze tarball here: viewtopic.php?f=9&t=22703&p=141066#p141066

Cheers,
Stonie.

_________________
KuroHG - UBoot 1.2, foonas-em & Debian Wheezy - 3.4 Kernel
Kurobox Pro - Dave's Lenny-armel
LS-WVL - opened
LS-XHL - Squeeze Bootstrap
LS-VL - Squeeze Bootstrap


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 8 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited