Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 10:37 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sat Jan 30, 2010 2:21 pm 
Offline
Newbie

Joined: Sun Nov 01, 2009 11:56 pm
Posts: 16
Hi

I installed UBoot, foonas-em and Debian Lenny a while ago.
Today I have tried rebooting the box and it will now not boot.

Can any one help?

Quote:
U-Boot 1.2.0 (Apr 10 2007 - 19:13:32) LinkStation HG / KuroBox HG
stdin : nc
stdout: nc
stderr: nc
IDE: Bus 0: ...OK
Device 0: Model: Maxtor 6Y080P0 Firm: YAR41BW0 Ser#: Y3KBVTWE
Type: Hard Disk
Capacity: 78167.2 MB = 76.3 GB (160086528 x 512)
Boot in 06 seconds ('s' to stop)...s

=> printenv
printenv
bootargs=root=/dev/sda1 netconsole=6666@192.168.11.15bootcmd=run bootcmd1
nfsboot=bootp;run nfsargs;bootm
bootdelay=10
baudrate=57600
autoload=no
stdin=nc
stdout=nc
stderr=nc
ipaddr=192.168.11.150
netmask=255.255.255.0
serverip=192.168.11.149
ncip=192.168.11.149
netretry=no
nc=setenv stdin nc;setenv stdout nc;setenv stderr nc
ser=setenv stdin serial;setenv stdout serial;setenv stderr serldaddr=800000
hdpart=0:1
hdload=echo Loading ${hdpart}:${hdfile};ext2load ide ${hdpart}boothd=setenv bootargs root=/dev/sda1 netconsole=6666@192.168.hdboot=run hdload boothd
flboot=setenv bootargs root=/dev/hda1;bootm ffc00000
emboot=setenv bootargs root=/dev/ram0;bootm ffc00000
nfsargs=setenv bootargs root=/dev/nfs rw nfsroot=${serverbootretry=30
bootcmd3=run emboot
writeng=protect off fff70000 fff7ffff;era fff70000 fff7ffff;mwwriteok=protect off fff70000 fff7ffff;era fff70000 fff7ffff;mwubpart=0:1
ubfile=share/u-boot/u-boot-hg.flash.bin
ubload=echo Loading ${ubpart}:${ubfile};ext2load ide ${ubpart}ubsaddr=fff00000
ubeaddr=fff2ffff
ubflash=protect off ${ubsaddr} ${ubeaddr};era ${ubsaddr} ${ubeupgrade=run ubload ubflash
ethact=RTL8169#0
filesize=953
foofl1=cp.b FFC00000 800000 2FFFFF;cp.b fff80000 AFFFFF 7E887
foofl2=setenv bootargs root=/dev/ram0 rw;bootm ${ldaddr} - FFFfooflboot=run foofl1 foofl2
bootcmd1=run hdboot;run fooflboot
bootcmd2=run fooflboot
hdfile=boot/uImage

Environment size: 1852/65532 bytes


running run hdboot gives

Quote:
=> run hdboot
run hdboot
Loading 0:1:boot/uImage

2310126 bytes read

2387 bytes read
## Booting image at 00800000 ...
Image Name: Linux-2.6.28.8
Image Type: PowerPC Linux Kernel Image (gzip compressed)
Data Size: 2310062 Bytes = 2.2 MB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
Uncompressing Kernel Image ... OK
Booting using flat device tree at 0x7f0000
Using Buffalo Linkstation machine description
Linux version 2.6.28.8 (davygravy@bitbaker-i686) (gcc version 4.2.4) #1 Sun Mar 22 00:01:55 CDT 2009
console [udbg0] enabled
Adding PCI host bridge /soc10x/pci@fec00000
PCI host bridge /soc10x/pci@fec00000 (primary) ranges:
IO 0x00000000fe000000..0x00000000febfffff -> 0x0000000000000000
MEM 0x0000000080000000..0x00000000efffffff -> 0x0000000080000000
BUFFALO Network Attached Storage Series
(C) 2002-2005 BUFFALO INC.
Zone PFN ranges:
DMA 0x00000000 -> 0x00008000
Normal 0x00008000 -> 0x00008000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
0: 0x00000000 -> 0x00008000
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 32512
Kernel command line: root=/dev/sda1 netconsole=6666@192.168.11.150/,@192.168.11.149/ rtc-rs5c372.probe=0,0x32
Unknown boot option `rtc-rs5c372.probe=0,0x32': ignoring
mpic: Setting up MPIC " EPIC " version 1.2 at 80040000, max 1 CPUs
mpic: ISU size: 4, shift: 2, mask: 3
mpic: Initializing for 12 sources
PID hash table entries: 512 (order: 9, 2048 bytes)
clocksource: timebase mult[7afe256] shift[22] registered
Console: colour dummy device 80x25
console handover: boot [udbg0] -> real [tty0]
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Memory: 124996k/131072k available (4456k kernel code, 5920k reserved, 164k data, 110k bss, 188k init)
Calibrating delay loop... 64.92 BogoMIPS (lpj=324608)
Mount-cache hash table entries: 512
net_namespace: 700 bytes
NET: Registered protocol family 16
ata1.00: ATA-7: Maxtor 6Y080P0, YAR41BW0, max UDMA/133
ata1.00: 160086528 sectors, multi 0: LBA
ata1.00: configured for UDMA/133
scsi 0:0:0:0: Direct-Access ATA Maxtor 6Y080P0 YAR4 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 160086528 512-byte hardware sectors: (81.9 GB/76.3 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 160086528 512-byte hardware sectors: (81.9 GB/76.3 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1 sda2 sda3
sd 0:0:0:0: [sda] Attached SCSI disk
sd 0:0:0:0: Attached scsi generic sg0 type 0
physmap platform flash device: 00400000 at ffc00000
physmap-flash.0: Found 1 x16 devices at 0x0 in 8-bit bank
Amd/Fujitsu Extended Query Table at 0x0040
physmap-flash.0: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
cmdlinepart partition parsing not available
RedBoot partition parsing not available
Using physmap partition information
Creating 6 MTD partitions on "physmap-flash.0":
0x00000000-0x00300000 : "mtd_firmimg"
0x00300000-0x00370000 : "mtd_bootcode"
0x00370000-0x00380000 : "mtd_status"
0x00380000-0x00400000 : "mtd_conf"
0x00000000-0x00400000 : "mtd_allflash"
0x00310000-0x00400000 : "mtd_data"
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci_hcd 0000:00:0e.2: EHCI Host Controller
ehci_hcd 0000:00:0e.2: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:0e.2: irq 18, io mem 0xbfffcf00
ehci_hcd 0000:00:0e.2: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 5 ports detected
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: EHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.28.8 ehci_hcd
usb usb1: SerialNumber: 0000:00:0e.2
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ohci_hcd 0000:00:0e.0: OHCI Host Controller
ohci_hcd 0000:00:0e.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:0e.0: irq 18, io mem 0xbfffe000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: OHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.28.8 ohci_hcd
usb usb2: SerialNumber: 0000:00:0e.0
ohci_hcd 0000:00:0e.1: OHCI Host Controller
ohci_hcd 0000:00:0e.1: new USB bus registered, assigned bus number 3
ohci_hcd 0000:00:0e.1: irq 18, io mem 0xbfffd000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: OHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.28.8 ohci_hcd
usb usb3: SerialNumber: 0000:00:0e.1
mice: PS/2 mouse device common for all mice
i2c /dev entries driver
rtc-rs5c372 0-0032: rs5c372a found, 24hr, driver version 0.6
rtc-rs5c372 0-0032: rtc core: registered rtc-rs5c372 as rtc0
TCP cubic registered
NET: Registered protocol family 10
NET: Registered protocol family 17
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
rtc-rs5c372 0-0032: setting system clock to 2010-01-30 13:06:34 UTC (1264856794)
linkstation: disarming the AVR watchdog:
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting. Commit interval 5 seconds
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 188k init
Adding 248996k swap on /dev/sda2. Priority:-1 extents:1 across:248996k
EXT3 FS on sda1, internal journal
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
device-mapper: ioctl: 4.14.0-ioctl (2008-04-23) initialised: dm-devel@redhat.com


Then nothing happens. I've waited ages.
I can however, boot into foonas-em OK if I select that option.
I'm really stuck. Any pointers.
Thanks


Top
   
PostPosted: Sun Jan 31, 2010 3:55 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
try booting into foonas-em and running fsck on your drives first ...

do in understand that it _was_ booting correctly/normally before?

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
   
PostPosted: Fri Jul 30, 2010 10:05 pm 
Offline
Newbie

Joined: Sun Nov 01, 2009 11:56 pm
Posts: 16
I should have posted this a whilst ago, but its how here for mine and others future info.

I worked out the problem.
I had added an external HDD to the KuroBox and had an entry in the fstab.
comment out the fstab entry and the KuroBox boots fine. Odd but it works.

Any body know what is going on?
James


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited