Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Aug 16, 2018 8:44 am

All times are UTC+01:00

Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Dec 30, 2011 7:23 am 

Joined: Thu Dec 29, 2011 8:25 pm
Posts: 11
Hello Forum Members,

I have the above referenced Terastation. I lost a hard drive and tried to replace it with a SATA drive (using an adaptor). Long story short, it didn't work. I eventually found the identical Western Digital drive and installed that. The good news is that the Terastation is back up and running, the bad news is that I can't get the unit to complete RAID check if it is in the RAID 5 mode. When I try, the RAID check will restart after partially completing or will lock up (four flashing disk status lights, power light only, no network response).

I can set up two RAID 1 arrays and the check will complete if I do them one at a time. If I try to set up both arrays at the same time, the Terastation behaves as above.

I have tried various firmware with the same results. Any ideas what may be causing this? I have checked all four drives with the WD diagnostic software and they check out as "ok".

Any idea as to what might be causing this? Suggestions as to how to correct this?

Any input is appreciated.

PostPosted: Mon Jan 02, 2012 4:15 am 

Joined: Thu Dec 29, 2011 8:25 pm
Posts: 11
Update 1/1/2012:

I installed itimpi's version 2.10 telnet enabled firmware. (BTW, thanks!). What I see is that during process [RAID5d], cpu usage is right about 59%. When I set up a RAID 1 array, process [RAID1d] runs at about .1%.

Any ideas as to why this is? Could ~59% cpu usage cause the raid check to not complete?

If so, could I insert a line of code to limit cpu usage for this process?

As before, any suggestions are appreciated.

PostPosted: Wed Jan 04, 2012 2:23 am 

Joined: Thu Dec 29, 2011 8:25 pm
Posts: 11
Update 1/3/2012:

While fooling around with telnet, I preformed a "kill -9 415 PID". In my case, PID is [Raid5syncd]. Almost immediately the disk check stopped and disk status went to normal. So far, the TS seems stable.

A couple of basic questions. (Disclaimer: I am not a programmer and I know very little about Linux).

1) Does the Raid processes reside in the actual kernel?

2) Does anyone know where I can download said kernel?

3) Can I install just that part of the kernel that controls Raid?

3) Any chance that might fix what ever is buggered up that keeps the raid check from completing?

Before I get inundated with calls to "look it up on Google", been there, done that, got the tee shirt. I think I am on the cusp of solving an issue that has been driving me and countless others crazy. If this works, I will happily post the steps I took to resolve.


Jan 18, 2012 Update.

So I finally got the Terastation (HD-1.0TGL/R5) back into RAID 5. As far as I can tell, this is what worked.

1) Flashed to 2.16 firmware w/ telnet.

2) Deleted "old" array that never finished "Checking RAID". Note: during this checking raid, process raid5d would run at ~60% cpu usage, process raid5syncd would run at ~8% cpu usage.

3) Went to "Maintenance" tab and selected Initialization, than selected restore defaults.

4) Powered down Terastation by switch in back of unit.

5) Held down INT button for 30 seconds with no power. Hit power button, continued holding INT button for an additional 30 seconds.

6) At this point, unit was booted with all four disk access lights flashing red, diagnostic light was flashing slowly and the power light was flashing slowly.

7) Configured a RAID 5 array. Telneted into the Terastation and saw that process raid5d was running at ~ 43% cpu usage and process raid5syncd was running at ~36% cpu usage.

8) Opened the web ui, noticed that it said that the array was not formatted.

9) Allowed RAID sync to complete (something like 10-11 hours).

10) went in the web ui, selected Disk management, disk format. Formatted the array to XFS.

11) All has been well for the past 48 hours.

Not sure why this worked. Seems to be a combination of restarting the Terastation (clearing temp files maybe?) and no format during disk check . All I know is so far it worked.

Good luck all,

PostPosted: Tue Apr 17, 2012 6:44 pm 
Total Newbie

Joined: Tue Apr 17, 2012 6:23 pm
Posts: 2
Hi Garrman,

I've been struggling with the same box for a week now. At first I thought I had success...

After six years of faultless running, Drive 1 died. Of course, these are all IDE drives, and they are scarcer than hen's teeth in the styx in Panama... So I put an Ultra IDE to SATA adapter in, and the first time I powered it up (Buffalo first, SATA external enclosure and its supply), Drive 1 showed as disconnected. Power down. Power up the external SATA first, 10 seconds, then the Buffalo, and all is well. The Web interface let me Configure Drive 1 (which it saw correctly as a Seagate 500GB, compared to the 3 WDs that were in there too). It reinitialized the RAID5 array, and for about 12 hours, all was happy.

Powered down, went to sleep.

Next day, powered up the SATA, 10 seconds, powered up the Buffalo, and after about a minute of Christmas tree including the Drive 1 Red flashing and Diag Red flashing lites, it went in to power off. This repeated itself several times.

Finally, unplugged the IDE to SATA interface card from the Terastation motherboard, rebooted, and I'm running my 3 drive non-raid-protected storage. It's been running fine that way (well, walking sort of okay?) since...

Any insight or advice, other than... spend some more money??

BTW, it's running Firmware version 1.12... perhaps upgrading it to the current 2.03 from 2007?

One more question: with the box ripped open, where is the serial console that I can tap in to and let me watch what's going on directly? Any ideas? I don't really want to hack open that UPS connector -- just yet...


PostPosted: Tue Feb 12, 2013 11:56 am 
Total Newbie

Joined: Tue Feb 12, 2013 11:37 am
Posts: 1
One drive failed. Replaced original WD2500BB with new WD2500AAJB (BTW - not old stock, seems to have been manufactured this year). Se jumper as on old disk.
Powered on, red light still on for that disk so gone into Terastation utility. I was expecting to need to format the disk but in the format dialogue NO disks are listed (the other 3 are working OK). Went into the RAID Config. showing 4 disks, added tick beside the new drive and click "Restructure" - I then get the alert "Data stored will be deleted" - Is this a rubbish message and it just means the new disk will be wiped or does it mean we lose the array contents?

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited