Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Jun 25, 2018 6:51 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 38 posts ]  Go to page Previous 1 2 3 Next
Author Message
 Post subject: Re: kill Backupprocess
PostPosted: Mon Jan 15, 2007 6:49 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
aber du kannst die LS pingen, auf shares zugreifen usw?
welche IP hat die box?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 5:41 am 
Offline
Newbie
User avatar

Joined: Thu Dec 14, 2006 4:36 pm
Posts: 41
ja ich kann ohne Probleme auf die Box (192.168.0.1 fix) zugreifen. Ich konnte auch die anderen Updates durchführen, nur wenn ich im Debug-Modus alles ausser rootfs rausnehme, dann dauert das Update ca. 2 Minuten und anschließend kommt die oben genannte Fehlermeldung.


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 8:20 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
hast du einen router ins internet?
gateway?

bei deinem pc mein ich.

die meldung die du bekommen hast hatte noch niemand.

ist sicher eine komische idee, aber kannst du mal die IP auf eine andere ändern? nur zum testen?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 8:34 am 
Offline
Newbie
User avatar

Joined: Thu Dec 14, 2006 4:36 pm
Posts: 41
wenn ich daheim bin, dann deaktiviere ich auf dem Router den DHCP-Server und ändere die IP-Adresse auf der LSPro.


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 8:44 am 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
Komisch... Die Fehlermeldung muss aber nicht unbedingt bedeuten, dass das Update wirklich fehlschlägt. Ev. wartet der Updater auf eine Rückmeldung, die ausbleibt. Buffalo hat den Updateprozess nicht ganz sauber programmiert. ;)

Versuchen wirs mit mindbenders Verdacht - ein Fehler im Webinterface. (Das Ganze zum Nachvollziehen, weil ich die Skripte gerade nur überfliege und vielleicht etwas wichtiges "durchrutscht" und ich gerade nicht an meine LS rankomme):

Das Skript das im Webinterface die Backup-Fehlermeldung erzeugt ist /www/cgi-bin/html/en/backup_task_list.pl, die Meldung wird erzeugt, wenn in der Liste mit den Backupprozessen ein Entrag "run" existiert. Das Skript wiederum holt sich die Infos aus /www/cgi-bin/module/BufBackupInfo.pm. Dort wiederum werden /etc/melco/backup1 bis /etc/melco/backup8 gelesen.

Schau Dir mal /etc/melco/backup1 und zum Vergleich /etc/melco/backup2 (falls letzteres existiert) an:
Code:
vi /etc/melco/backup1
Vermutlich steht da irgendwas von "run". Dann kannst Du den Backupprozess von Hand löschen.
Eventuell hilft auch einfach /etc/melco/backup2 nach /etc/melco/backup1 zu kopieren oder die Datei ganz zu löschen. Aber vorher unbedingt den Inhalt ansehen oder noch besser sichern!

--------------
Puzzled... But the error message from the updater doesn't necessarily mean that the update process failed. Maybe the updater waits for some response that is not generated in debug mode. Buffalo isn't coding very carefully (ask jonli and lb_worm) ;) .

Lets try it with mindbenders idea - that something's wrong in the webinterface. Everything to follow, as I only read over the scripts and have no box here to verify:

The script in the webinterface throwing the backup error msg is /www/cgi-bin/html/en/backup_task_list.pl. The message is created when the list with the backup processes has an entry "run". This script gets its info from /www/cgi-bin/module/BufBackupInfo.pm. That in turn reads /etc/melco/backup1 to /etc/melco/backup8.

So have a look at /etc/melco/backup1 and compare it with e.g. /etc/melco/backup2 (if it exists at all):
Code:
vi /etc/melco/backup1
Guess there is a line with the status "run". You should be able to delete the job manually.
Maybe it helps to copy /etc/melco/backup2 to /etc/melco/backup1 or to delete /etc/melco/backup1 at all. But be sure to have a look at the file as it is now or even better to back it up!

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 9:26 am 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
Ich bin gerade noch über ein Skript gestolpert, das Dir helfen könnte. Scheinbar muss es mit der "backup task number" als parameter aufgerufen werden. In Deinem Fall also:
Just found a script that might help you. Seems that you have to call it with the backup task number as parameter. In your case:
Code:
 
/usr/local/bin/backup_done.sh 1

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 9:38 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
have you tried to clear the job after clicking on the job and hitting the "clear job" button? it only worked here after i removed the destination for backup....

----------
obviously the /etc/melco/backupX-files are the settings for the backup that you can set via the webinterface:

i just configured a backup job, without, all files are empty.

this is how it looks like:
Code:
status=done 
type=not_run
start_time=
week=
overwrite=
crypt=
compress=
mirror=
logfile=
force=
folder=/mnt/disk1/share/test<>LS-PRO@/mnt/usbdisk1



in /etc/melco/timer_status it depends what happens:
Code:
type=backup 
backup1=invalid
backup2=off
backup3=off
backup4=off
backup5=off
backup6=off
backup7=off
backup8=off
sleep_start=0:00
sleep_finish=12:00
idle_time=



i chose "Not scheduled" as i do not have USB-HDD connected currently....thats why there is this "backup1=invalid"

this might be another possibility.

if you really want to get rid of the backup job i think it would be enough to copy backup2 to backup1 (which means completely wiping the content of the file) and editing /etc/melco/timer_status to "backup1=off"

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 10:54 am 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
@mindbender: I guess that you can not alter a "running" job. In the screenshot the edit symbols are missing for the first one.

Georg wrote:
/usr/local/bin/backup_done.sh 1

... that only sends a notification mail about the just performed backup task

Backup is done in /usr/local/bin/rsbackup.pl. It has a sub called "change_status". sub backup_main calls it to set the status to "run". So if the script dies before it sets the status back to "done" ...

Edit /etc/melco/backup1. I guess you'll find the entry "status=run", change that to "status=done".
----
coyote, versuch mal den Eintrag "status=run" in /etc/melco/backup1 auf "status=done" zu ändern. Damit behältst Du auch die Einstellungen für den Backup task. Wenn das nicht hilft: mindbenders posting

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Tue Jan 16, 2007 5:29 pm 
Offline
Newbie
User avatar

Joined: Thu Dec 14, 2006 4:36 pm
Posts: 41
Georg wrote:
Schau Dir mal /etc/melco/backup1 und zum Vergleich /etc/melco/backup2 (falls letzteres existiert) an:

vi /etc/melco/backup1
Vermutlich steht da irgendwas von "run". Dann kannst Du den Backupprozess von Hand löschen.
Eventuell hilft auch einfach /etc/melco/backup2 nach /etc/melco/backup1 zu kopieren
_______________________________________________________________________

So have a look at /etc/melco/backup1 and compare it with e.g. /etc/melco/backup2 (if it exists at all):

vi /etc/melco/backup1
Guess there is a line with the status "run". You should be able to delete the job manually.
Maybe it helps to copy /etc/melco/backup2 to /etc/melco/backup1



so das wars :up: so hat es funktioniert, ich danke allen, die sich die Mühe gemacht haben mir zu helfen, einfach ein tolles Forum mit gutem Expertenwissen.
Werde öffters hier vorbeischaen.
Macht weiter so.

ps: Wie würdet Ihr das Backup auf eine USB-HDD gestalten? siehe auch http://buffalo.nas-central.org/forums/index.php?action=vthread&forum=14&topic=2125


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Fri Jan 26, 2007 9:19 pm 
Offline
Newbie

Joined: Fri Jan 26, 2007 9:07 pm
Posts: 33
Location: Denmark
I have the same issue, with a hung backup job, still processing after system restart and shutdown. For now I have given up killing it, as I haven't yet delved into the wonderlands of hacking my new linkstation. But I sure will at some point. Seems fun...

I have tried formatting the external USB drive (which is the backup target) and un-sharing it. Nothing seems to kill the backup process. It is not possible to edit the job while it is running.

I tried copying large files (at appr. 16 gigs a piece) on to a FAT32 volume. Which I obviously shouldn't have. Any ideas how to get around this, on this standard issue box of mine?


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Fri Jan 26, 2007 10:55 pm 
Offline
Newbie

Joined: Fri Jan 26, 2007 9:07 pm
Posts: 33
Location: Denmark
And now I've fiddled around with USB drive settings (ie. un-assigned the drive) and rebooted the Linkstation Pro. But then, all of a sudden, the USB drive, which of course is shared, behaves as I expect it would during a backup procedure. It's not possible to write to the share. So now both the drive/share and the backup process are locked. Can I in any way solve this through the web interface? By other means than resetting to factory defaults?

Any advice for a newbie?

(The drive is in production right now, so does resetting to factory defaults imply deletion of stored data?)


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Sat Jan 27, 2007 11:38 am 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
No, I don't think you've got any chance to stop a backup that is in the status "run" via the webinterface.

You can only do that via telnet/ssh. If you don't want to make any changes to your firmware the only possibility I see at the moment is via the acp_commander and issue the appropriate command via it's -c option. If it is the first (1) backup task that causes trouble the command would read (one line!):
Code:
java -jar acp_commander -t linkstation -c "sed 's/status=run/status=done/' < /etc/melco/backup1  > /etc/melco/backup1"

For other backup tasks you'd have to exchange the two appearances of "backup1" to backup2, backup3 etc.

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Mon Jan 29, 2007 4:37 pm 
Offline
Newbie

Joined: Fri Jan 26, 2007 9:07 pm
Posts: 33
Location: Denmark
Thanks for the reply!

I'll try this command out. But it sounds like a real good idea to install new firmware at some point.


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Mon Jan 29, 2007 4:52 pm 
Offline
Newbie

Joined: Fri Jan 26, 2007 9:07 pm
Posts: 33
Location: Denmark
It's me again :?

I've tried the acp_commander. But I get an error when I run it. I have posted the command and output below:

java -jar "c:\Documents and Settings\soren\Skrivebord\acp_commander.jar" -t 192.168.1.111 -c "sed '/status=run/status=done/' < /etc/melco/backup1"

ACP_commander out of the nas-central.org project.
Used to send ACP-commands to Buffalo linkstation(R) LS-PRO.

Using random connID value = 9C8F769AC360
Using target: 192.168.1.111/192.168.1.111
ERROR: Exception: IO (Receive timed out) [Section: ACP_AUTHENT]

It's run from a WinXP box over a PPTP connection to the network where the Linkstation is located.

Any ideas greatly appreciated!


Top
   
 Post subject: Re: kill Backupprocess
PostPosted: Mon Jan 29, 2007 5:47 pm 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
mesterS you have to make sure that UDP packets can reach the port 22936 and can be sent back. You either have to do it "locally" (suggested) or configure your PPTP-connection accordingly.

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 38 posts ]  Go to page Previous 1 2 3 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited