Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Aug 17, 2018 3:51 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 23 posts ]  Go to page Previous 1 2
Author Message
PostPosted: Thu Mar 10, 2011 10:03 pm 
Total Newbie

Joined: Thu Mar 10, 2011 9:31 pm
Posts: 1
Hello Board,

I'm new to this board and this is my first post. In fact, I only registered to say thank you for this thread! So thanks to everyone for contributing helpful information.

Here is my experience with upgrading hard drives:
I recently acquired a used LinkStation Pro Duo LS-WTGL7BE from a co-worker of mine. It was the RAID version with two 500GB hard drives of type Hitachi Deskstar HDP725050GLA360 in there. But, since I am space-greedy, I decided to upgrade the hard drives to 2TB each.

I bought two Western Digital WD20EARS drives (http://www.amazon.com/Western-Digital-I ... 619&sr=8-1). I took the instructions posted by Jan on Sun Oct 25, 2009 6:58 pm (third post from the top) and followed them to a T. I used the PartedMagic live CD (version 5.10) and used GParted and Ghost 4 Linux. Everything worked perfectly.

One extra information for anyone trying to do this too:
When starting from a fresh LinkStation (i.e. without any data on it), it is sufficient to just clone the first hard drive of your RAID LinkStation. You don't have to clone both hard drives from your RAID, hence saving some time. I cloned the first drive (it took about 2 hours to complete start to finish), plugged in the new, clonded 2TB drive in slot 1, installed the unformated 2TB drive in slot 2 and the LinkStation booted up without any problems. Using the web menu, I was able to format the second hard drive and configure a RAID.
Now, bear in mind that if you have data on your existing LinkStation that you want to preserve during the upgrade, you will need to clone both drives. Then again, I am not even sure if growing the partitions on your new drives will render your data useless anyways... theoretically it shouldn't, but I never tried that.

So, again, thanks to everyone for this thread!



PostPosted: Mon Jul 11, 2011 7:01 pm 
Total Newbie

Joined: Mon Jul 11, 2011 6:47 pm
Posts: 1
Hi. I follow the procedures of first message to upgrade. Thanks witchmaster and everyone in this thread.

I would like to add some notes to the steps based on Ubuntu 11.04.

1. My upgrade used Ubuntu 11.04. It is a LS-PRO v1 and the new harddisk is WD15EADS.
5. In left menu, click application button (magnifying glass). In "Search Application" at top, type "terminal". Click terminal icon.
6. In application, upper right corner, click "All application"->System, select "GParted Partition Editor".
7. In left menu, click "Ubuntu Software Center" button. With "Ubuntu Software Center" as active Window, move mouse to top bar of **screen**, select Edit->Software sources and check Community-maintained Open Source software (universe). Click close. It will start download.
10. In my case, the new harddisk showed as /dev/sda.
12. If there is key icon locking the /dev/sda4, right click "linux-swap" partition and select "Swapoff". This removes the key icons and unlocks the partition. Proceed to expand sda4.
13. My case it failed to proceed with a "Stop" sign at step 2 in Details report. Probably Gparted found the xfs partition not in a correct state to start.

I solved it by:
Back to terminal
run "sudo mkdir /media/sda6"
run "sudo mount /dev/sda6 /media/sda6"
Back to Gparted
right click /dev/sda6
Select umount
Click Resize/Move and expand sda6 again.

15. The LS-PRO failed to be ping in first boot. Then I shutdown it and boot again. It worked finally.

N.T. In step 7, The system needs to access Internet. I used utp cable. If you use wireless, try click power button at upper left corner of screen, select "System settings"->"network connections"->wireless, add. Set SSID & passphrase.


PostPosted: Fri Nov 04, 2011 2:26 am 

Joined: Fri Jul 08, 2011 12:12 pm
Posts: 5
Need help from capable hands on HDD replacement.

I have a LS-WVL device with a Seagate 1tb HDD installed (with firmware 1.41) running and the system has been smoothly running in the last 6 months with the latest firmware 1.54 since September.
Now that I want to upgrade my HDD with a Hitachi 2TB HDD.
I have followed both the Ubuntu (version 11.04) and Parted Magic (version 6.7) route with the old Seagate 1TB HDD attached to the notebook thru usb.
My aim to to see if the original HDD can be recognized before the clone and resize.
When either Ubuntu or Parted magic is booted up properly, I first will normally execute [sudo] modprobe xfs to ensure xfs file system support is there.
I will then run "Gparted' against the original 1tb HDD attached and "Gparted" reported from both routes are as below:
1. the device ID of the attached HDD is sdb
2. the attached HDD is initialized with GPT (instead of MBR)
3. there are a total of 6 partitions
4. file system of partition sdb1 is EXT3
5. file system of all other partitions = unknown
Ubuntu disk utility reported as in below:
1. The attached HDD is initialized as GPT
2. sdb1, Sdb2, sdb5 = Raid Componenet (size = 1gb)
3. sdb3 and sdb4 = unknown (size = 1.0mb)
3. Sdb6 = Raid component and it should be the partition holds data (size = 985gb)

Just assume if both old and new HDD are connected to a PC thru SATA controller, my questions are:
1. Can content of old HDD be cloned to the new HDD by ddrescue or G4L?
- my guess is possible
2. Can Gparted handled GPT (or need other utility)?
- I am not sure
3. Can Gparted handled the resize (or need other utility)?
- I am not sure

I am quite familiar with Windows but is a Linux nut.
Hence, appreciate your explanation relating to Linus in simple technical term with detail instructions.


PostPosted: Wed Dec 14, 2011 6:03 pm 

Joined: Fri Jul 08, 2011 12:12 pm
Posts: 5
Finally got time to perform the outstanding LS-WVL disk upgrade.

Below are the highlights:
1. Gparted is not able to recognize partitions (format unknown) on the original disk created with LS-WVL and firmware V1.41 except the first EXT3 partition
2. G4L is able to duplicate all partitions from the smaller disk onto the new disk even it cannot determine format of partitions to be copied.
3. Gparted has the same trouble with the newly cloned disk (just like 1 in above).
As a result of Gparted is not able to determine format of the partition, it will not have option (grey out) for user to select Resize/Move. Furthermore, even Gparted allows user to select "delete" on partitions it cannot determine the format, it will failed to "delete" that partition during the "apply" stage.
4. Ignoring all problems in above but putting the cloned drive (without resuize) in place of the original in LS-WVL and BOOT, you will see continuous blinking BLUE and it can only be stop[ed by pulling the power cable/cord.

With above findings, seems to me upgrading disk by clone and extend partition size is not a viable solution for LS-WVL under firmware v1.54 but a full re-install is required and it is as in below:
1. Backup all data (best is onto a PC)
2. Delete all partitions of targeted disks until there's only one big unallocated partition on disk
- you may connect the disks to an XP/W7 environment and use control panel/system administration/disk management yo delete all partitions until a BIG unallocated partition
3. install the empty disks into the LS-WVL
4. Power ON (not AUTO) LS-WVL and wait for solid BLUE and solid RED
5. Press FUNCTION switch (at the back) and release immediately
6. Blinking RED will come up immediately and it will last for quite some time (a few minutes)
7. Finally, it will reboot by itself
8. Wait for a solid BLUE
9. Now you have a new and reinitialized environment ready for data restoration and configuration
- default ID = admin/password

Your comments please.


PostPosted: Mon Jan 06, 2014 3:39 pm 
Total Newbie

Joined: Mon Jan 06, 2014 3:35 pm
Posts: 1
Hi All. Great Forum and first time post.

I have a bit of a conundrum in that I've been running my LS Pro for 2 years and the hard drive has died, and I mean completely died. Totally unreadable and unusable.

Is there any other way of getting it going again with a new drive without having the ability to clone bits from the old drive?

Thanks in advance!

PostPosted: Tue Jan 07, 2014 7:44 am 

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Look for "TFTP" in this forum.
That is the way to set up a brand new disk (the disk
shall NOT have partitions and shall NOT be formatted).
Be aware, that Orion based boxes are limited in the
number of compatible disks nowadays.
Do NOT take a disk with 4096k sectors or more than
2 TB.

Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)

PostPosted: Mon Apr 03, 2017 4:50 pm 
Total Newbie

Joined: Mon Apr 03, 2017 4:14 am
Posts: 1
How can I know if my NAS is orion base or not?
I want to upgrade the existing 1TB disks to new 4TB disks?

My model number is: LinkStation-LS-WVL593
Firmware version: 1.71
Product: LinkStation Pro Duo (LS-WV) - LS-WV2.0TL/R1

What is the biggest disk that I can put in this unit? (2TB, 3TB, 4TB, 6TB)

PostPosted: Mon Apr 03, 2017 6:08 pm 

Joined: Mon Apr 26, 2010 10:24 am
Posts: 2734
LS-WVL is a Kirkwood nas.

Array max size 16TB

maximum disk size 16TB

example LS-WVL with 8TB Seagate

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 23 posts ]  Go to page Previous 1 2

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 25 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited