Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 11:20 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 72 posts ]  Go to page 1 2 3 4 5 Next
Author Message
 Post subject: Genlink broken?
PostPosted: Thu Sep 04, 2008 7:56 am 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
I 've spent about a week now trying to install Genlink on my LS Pro ARM9, based on the existing wiki
I 'm not going to elaborate what problems I 've encountered so far (quite a few), but I managed after overcoming lots of obstacles to get to the point where Layman got installed. Yes, I managed to do that from source, masking/unmasking numerous packages, changing make.conf, urls, etc...
One of the biggest problems now is that glibc is at version 2.6 in mainstream Gentoo whereas Genlink is only at 2.3 at install. This implies that about 50% of my emerges fail.
Reading from other posts, glibc should be updated with overlay.
Now that I 've got as far that overlay works, I got the very cold error: "svn: Target path does not exist", which means: http://linkstationwiki.svn.sourceforge. ... ntoo_arm9/ has disappeared and apparently nobody bothered.
Can anyone tell me if it 's still possible to get a Genlink installed on my LS PRO?
If someone has a running and up-to-date Genlink on his LS PRO I'm willing to accept a tarball dump of his system.
I 'm stopping my endeavour here and if no fixes are made I ill have to be obliged to switch to FreeLink (hope that still works!). But I would prefer a Gentoo flavour... ;)


Last edited by harakiri on Fri Sep 05, 2008 6:33 am, edited 1 time in total.

Top
   
 Post subject: Re: Genlink broken?
PostPosted: Thu Sep 04, 2008 6:05 pm 
Offline
Moderator
User avatar

Joined: Thu Apr 06, 2006 1:33 pm
Posts: 1082
Location: United States of America
You hit on the issue. It just is not being maintained at the moment, well for some time. Zoolook made this up some time ago (more than a year now) and it kind of withered a bit. I would suggest Debian at the moment. There is much development in the creation of a Lenny armel distro.
viewtopic.php?f=18&t=5736&p=72241&#p72241

_________________
-Ramuk

LinkStation HG *250 Uboot - Foonas-EM - Freelink
Kuro HG *750 Uboot - Foonas-EM - Debian Squeeze
Kuro HD *60 Uboot - Foonas-EM - Debian Squeeze (For Sale)
KuroPro *2TB Debian Lenny Armel- Kernel 2.6.26
KuroPro *1TB Debian Lenny Armel- Kernel 2.6.25.6


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 05, 2008 6:33 am 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
Thanks for that info.
It might be a good idea to post on the Wiki that Genlink is crippled for now.
Hope Genlink will get revived some day, I 'm more of a Gentoo fan.
I 'll try my luck with the latest Lenny then :)


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 05, 2008 8:59 am 
Offline
Developer
User avatar

Joined: Wed Nov 29, 2006 11:27 am
Posts: 95
Location: Germany
Hello,

sorry for the inconvenience about that old Genlink being in fact broken (yes, you're right, I'll update the wiki entry with the warning that it's currently not usable). It just happened that several links do not work anymore and such, and I did not have the time to update (not even to really frequent the forums), and also, I have to get my upload account back working again (tried once with mindbender, but I must have done something wrong, will try to sort this out on the irc channel).
Back to Gentoo, well, as I said, I'm very short on spare time at home (yay, we got a baby :D ) but nevertheless, my own Gentoo on the LSpro is pretty up to date, only the new Orion-kernel has some issues with JFS, which show up when accessing those JFS partitions from my LAN via NFS (my Linkstation is also my central LAN portage repository for all the other Gentoo boxes in the house). Also, the LSpro disk is near to full, so in fact I could generate sort of a stage3 Genlink image, but it is very difficult for me to try it out myself until the installation procedure works flawlessly. So if there are people willing to try it out for me (as I don't have an extra NAS or spare USB disk), I will package it up, adapt the wiki article (but at first, not on the wiki itself, I guess) to my best knowledge to install it in a very similar way without trying it all out myself and maybe we'll manage to get it working. Until the orion kernel works well with JFS, we can use the jonli447/lb_worm kernel (2.6.22). If all that woirks, we might proceed further with customizing some initrd (maybe make use of Foonas-EM) and such...

Volunteers to that?

Cheers,
Lucian


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 05, 2008 9:27 am 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
So that means that you would get a minimal Gentoo but with up-to-date libraries/binaries and which emerges against current generic Gentoo branches (like the 2007)?
I 'm gain for that!
If you provide also a good /boot with kernel, initrd and all other required files, I 'll get it up and running. Should you be short on webspace, I could provide it also.
Should I get it up and running, I 'll post a nice procedure here then.


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 05, 2008 9:13 pm 
Offline
Developer
User avatar

Joined: Wed Nov 29, 2006 11:27 am
Posts: 95
Location: Germany
harakiri wrote:
So that means that you would get a minimal Gentoo but with up-to-date libraries/binaries and which emerges against current generic Gentoo branches (like the 2007)?
I 'm gain for that!
If it's the profile you're referring to, my current Genlink (and probably tarpman's too) has /etc/make.profile pointing to the one in our orion5x overlay which again has /usr/portage/profiles/default/linux/arm/2008.0/server as parent.

This is the list of the packages that would be currently re-emerged in the @system set (basically a stage3):
Code:
GenLSPro ~ # emerge -e @system -pv
WARNING: repository at /mnt/xtra/gentoo/portage_overlays/layman/directfb is missing a repo_name entry
WARNING: repository at /mnt/xtra/gentoo/portage_overlays/local/my_overlay+patches is missing a repo_name entry

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/portage-2.2_rc8  USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl" 0 kB
[ebuild   R   ] sys-libs/zlib-1.2.3-r1  0 kB [?=>0]
[ebuild   R   ] virtual/libintl-0  0 kB [?=>0]
[ebuild   R   ] virtual/libiconv-0  0 kB [?=>0]
[ebuild   R   ] dev-libs/expat-2.0.1  0 kB [?=>0]
[ebuild   R   ] sys-devel/gnuconfig-20080123  0 kB
[ebuild   R   ] app-arch/lzma-utils-4.32.6  USE="-nocxx" 0 kB
[ebuild   R   ] sys-devel/gcc-config-1.4.0-r4  0 kB
[ebuild   R   ] sys-apps/tcp-wrappers-7.6-r8  USE="ipv6" 98 kB [?=>0]
[ebuild   R   ] dev-util/pkgconfig-0.23  USE="(-hardened)" 0 kB
[ebuild   R   ] app-misc/pax-utils-0.1.17  USE="-caps" 0 kB
[ebuild   R   ] app-arch/bzip2-1.0.5  USE="-static" 0 kB
[ebuild   R   ] sys-libs/timezone-data-2008c  USE="nls" 0 kB
[ebuild   R   ] app-admin/python-updater-0.2  3 kB [?=>0]
[ebuild   R   ] sys-devel/autoconf-wrapper-4-r3  0 kB [?=>0]
[ebuild   R   ] sys-devel/automake-wrapper-3-r1  0 kB [?=>0]
[ebuild   R   ] sys-apps/sandbox-1.2.18.1-r2  0 kB [?=>0]
[ebuild   R   ] sys-devel/patch-2.5.9-r1  USE="(-build%) -static" 198 kB [?=>0]
[ebuild   R   ] app-admin/showconsole-1.08  0 kB [?=>0]
[ebuild   R   ] net-misc/dhcpcd-4.0.1  USE="-compat -zeroconf" 0 kB
[ebuild   R   ] app-arch/cpio-2.9-r1  USE="nls" 0 kB [?=>0]
[ebuild   R   ] sys-apps/micro_evtd-3.3.3-r8  USE="-terastation" 0 kB [1]
[ebuild   R   ] sys-kernel/linux-headers-2.6.26  0 kB
[ebuild   R   ] dev-libs/libpcre-7.4  USE="-doc unicode" 765 kB
[ebuild   R   ] media-libs/libpng-1.2.26-r1  489 kB
[ebuild   R   ] sys-apps/sysvinit-2.86-r10  USE="(-ibm) (-selinux) -static" 0 kB
[ebuild   R   ] net-misc/iputils-20071127  USE="-doc ipv6 -static" 0 kB
[ebuild   R   ] virtual/init-0  0 kB [?=>0]
[ebuild   R   ] sys-apps/baselayout-2.0.0  USE="-build" 0 kB
[ebuild   R   ] sys-auth/pambase-20080318  USE="-consolekit cracklib -debug -gnome-keyring -mktemp -passwdqc (-selinux)" 3 kB
[ebuild   R   ] sys-devel/binutils-config-1.9-r4  0 kB [?=>0]
[ebuild   R   ] app-i18n/man-pages-ro-0.2  0 kB [?=>0]
[ebuild   R   ] app-i18n/man-pages-de-0.5-r1  0 kB
[ebuild   R   ] dev-lang/perl-5.8.8-r4  USE="berkdb -build -debug -doc gdbm -ithreads -perlsuid" 0 kB
[ebuild   R   ] perl-core/Test-Harness-2.64  0 kB [?=>0]
[ebuild   R   ] perl-core/PodParser-1.35  0 kB [?=>0]
[ebuild   R   ] sys-devel/gettext-0.17  USE="acl -doc -emacs nls -nocxx openmp" 0 kB
[ebuild   R   ] sys-apps/sed-4.1.5-r1  USE="nls -static" 0 kB
[ebuild   R   ] sys-devel/binutils-2.18-r3  USE="-multislot -multitarget nls -test -vanilla" 17 kB
[ebuild   R   ] sys-devel/m4-1.4.11  USE="-examples nls" 0 kB
[ebuild   R   ] dev-libs/popt-1.10.7  USE="nls" 0 kB [?=>0]
[ebuild   R   ] sys-devel/flex-2.5.33-r3  USE="nls -static" 0 kB
[ebuild   R   ] sys-apps/findutils-4.3.13  USE="nls (-selinux) -static" 0 kB
[ebuild   R   ] dev-perl/Locale-gettext-1.05  8 kB [?=>0]
[ebuild   R   ] sys-apps/grep-2.5.1a-r1  USE="nls pcre -static" 0 kB [?=>0]
[ebuild   R   ] app-arch/gzip-1.3.12-r1  USE="nls -pic -static" 0 kB
[ebuild   R   ] sys-apps/kbd-1.13-r1  USE="nls" 0 kB
[ebuild     U ] sys-apps/net-tools-1.60_p20071202044231-r1 [1.60-r12] USE="nls -static" 180 kB [?=>0]
[ebuild   R   ] sys-apps/gawk-3.1.5-r5  USE="nls" 2,257 kB
[ebuild   R   ] app-arch/tar-1.19-r1  USE="nls -static" 1,839 kB
[ebuild   R   ] sys-devel/make-3.81  USE="nls -static" 0 kB [?=>0]
[ebuild   R   ] sys-apps/help2man-1.36.4  USE="nls" 0 kB [?=>0]
[ebuild   R   ] sys-devel/bison-2.3  USE="nls -static" 0 kB [?=>0]
[ebuild   R   ] sys-apps/module-init-tools-3.4  USE="-old-linux" 195 kB
[ebuild   R   ] sys-apps/man-1.6f-r1  USE="nls" 0 kB
[ebuild   R   ] sys-libs/ncurses-5.6-r2  USE="(-bootstrap%) (-build%) -debug -doc gpm -minimal -nocxx -profile -trace unicode" 0 kB
[ebuild   R   ] sys-apps/texinfo-4.11-r1  USE="nls -static" 0 kB
[ebuild   R   ] app-shells/bash-3.2_p39  USE="(-afs) -bashlogger -examples% nls -plugins -vanilla" 0 kB
[ebuild   R   ] sys-process/procps-3.2.7  USE="(-n32)" 0 kB [?=>0]
[ebuild   R   ] sys-apps/less-418  USE="unicode" 0 kB
[ebuild   R   ] sys-libs/gpm-1.20.1-r6  USE="(-selinux)" 0 kB
[ebuild   R   ] app-editors/nano-2.1.2-r1  USE="-debug -justify -minimal ncurses nls slang -spell unicode" 0 kB
[ebuild   R   ] sys-devel/autoconf-2.61-r1  USE="-emacs" 1,365 kB [?=>0]
[ebuild   R   ] sys-libs/readline-5.2_p12-r1  0 kB
[ebuild   R   ] app-admin/perl-cleaner-1.05  0 kB
[ebuild   R   ] virtual/editor-0  0 kB [?=>0]
[ebuild   R   ] sys-apps/which-2.19  0 kB
[ebuild   R   ] virtual/pager-0  0 kB
[ebuild   R   ] sys-devel/automake-1.10.1  0 kB
[ebuild   R   ] sys-devel/bc-1.06-r6  USE="readline -static" 273 kB [?=>0]
[ebuild   R   ] sys-libs/slang-2.1.3-r1  USE="-cjk pcre png readline" 0 kB
[ebuild   R   ] sys-devel/libtool-1.5.26  USE="-vanilla" 2,893 kB
[ebuild     U ] sys-libs/e2fsprogs-libs-1.41.1 [1.41.0] USE="nls" 477 kB
[ebuild   R   ] sys-libs/db-4.6.21_p3-r1  USE="-bootstrap -doc (-java) -nocxx -tcl -test" 0 kB
[ebuild     U ] sys-fs/e2fsprogs-1.41.1 [1.41.0] USE="nls" 4,251 kB
[ebuild   R   ] sys-apps/attr-2.4.39  USE="nls" 0 kB
[ebuild   R   ] sys-libs/db-4.5.20_p2-r1  USE="-bootstrap -doc (-java) -nocxx -tcl -test" 0 kB
[ebuild   R   ] sys-apps/groff-1.19.2-r1  USE="-X -cjk" 0 kB [?=>0]
[ebuild     U ] sys-fs/udev-127 [125-r2] USE="(-selinux)" 429 kB
[ebuild   R   ] sys-process/psmisc-22.5-r2  USE="-X ipv6 nls (-selinux)" 271 kB [?=>0]
[ebuild   R   ] sys-libs/gdbm-1.8.3-r3  USE="berkdb" 224 kB [?=>0]
[ebuild   R   ] sys-apps/acl-2.2.45  USE="(-nfs) nls" 0 kB
[ebuild   R   ] sys-apps/util-linux-2.13.1.1  USE="crypt -loop-aes nls -old-linux (-selinux) slang unicode" 0 kB
[ebuild   R   ] sys-fs/xfsprogs-2.9.7  USE="nls" 0 kB
[ebuild   R   ] sys-apps/coreutils-6.10-r1  USE="acl nls (-selinux) -static -vanilla -xattr" 0 kB
[ebuild   R   ] net-misc/rsync-3.0.2  USE="acl iconv ipv6 -static -xattr -xinetd" 0 kB
[ebuild   R   ] sys-devel/libperl-5.8.8-r1  USE="berkdb -debug gdbm -ithreads" 0 kB [?=>0]
[ebuild   R   ] sys-devel/gcc-4.2.4  USE="(-altivec) -bootstrap -build -doc -fortran -gcj -gtk (-hardened) -ip28 -ip32r10k -libffi -mudflap (-multilib) -multislot (-n32) (-n64) nls -nocxx -objc -objc++ -objc-gc openmp -test -vanilla" 0 kB
[ebuild   R   ] sys-libs/glibc-2.6.1  USE="-debug -gd -glibc-omitfp (-hardened) (-multilib) nls -profile (-selinux) -vanilla" 0 kB
[ebuild   R   ] sys-fs/jfsutils-1.1.12  USE="-static" 507 kB [?=>0]
[ebuild   R   ] app-admin/eselect-1.0.11-r1  USE="bash-completion -doc -vim-syntax" 0 kB
[ebuild   R   ] app-admin/eselect-news-20080320  0 kB
[ebuild   R   ] app-misc/ca-certificates-20070303-r1  0 kB [?=>0]
[ebuild   R   ] dev-libs/openssl-0.9.8h-r1  USE="-bindist -gmp -kerberos (-sse2) -test zlib" 0 kB
[ebuild   R   ] dev-lang/python-2.5.2-r7  USE="berkdb -bootstrap -build -doc -examples gdbm -ipv6 ncurses readline -sqlite ssl threads -tk -ucs2 -wininst" 0 kB
[ebuild   R   ] net-misc/wget-1.11.1  USE="-debug ipv6 nls -socks5 ssl -static" 0 kB
[ebuild   R   ] dev-libs/libxml2-2.6.30-r1  USE="-bootstrap% -build% -debug -doc ipv6 python readline -test" 4,616 kB
[ebuild   R   ] sys-libs/cracklib-2.8.12  USE="nls python" 0 kB
[ebuild   R   ] sys-apps/file-4.23  USE="python" 0 kB
[ebuild   R   ] sys-libs/pam-1.0.2  USE="(-audit) cracklib nls (-selinux) -test -vim-syntax" 0 kB
[ebuild   R   ] sys-apps/shadow-4.0.18.2  USE="cracklib nls -nousuid pam (-selinux) -skey" 0 kB
[ebuild   R   ] sys-apps/openrc-0.2.5  USE="-debug ncurses pam unicode" 0 kB
[ebuild   R   ] sys-apps/busybox-1.8.2  USE="-debug -make-symlinks pam -savedconfig (-selinux) -static" 0 kB
[ebuild   R   ] net-misc/openssh-4.7_p1-r6  USE="-X -X509 -chroot -hpn -kerberos -ldap -libedit pam (-selinux) -skey -smartcard -static tcpd" 0 kB
[ebuild     U ] sys-apps/man-pages-3.05 [2.80] USE="nls" LINGUAS="-cs -da de -es -fr -it -ja -nl -pl ro -ru -zh_CN" 0 kB
[ebuild  N    ] sys-apps/man-pages-posix-2003a  0 kB
[ebuild   R   ] sys-apps/diffutils-2.8.7-r3  USE="nls -rootfs -static" 0 kB [?=>2]

Total: 107 packages (5 upgrades, 1 new, 101 reinstalls), Size of downloads: 21,347 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage_overlays/layman/orion5x
 [2] /usr/portage_overlays/local/my_overlay+patches
 [?] indicates that the source repository could not be determined
GenLSPro ~ #

harakiri wrote:
If you provide also a good /boot with kernel, initrd and all other required files, I 'll get it up and running. Should you be short on webspace, I could provide it also.
Should I get it up and running, I 'll post a nice procedure here then.
Ok, I'll have to check at least in a chroot that what has to be installed after @system up to layman and maybe mc still works, and that all packages are compiled with the current gcc at least...


Last edited by Zoolook on Sat Sep 06, 2008 8:13 am, edited 1 time in total.

Top
   
 Post subject: Re: Genlink broken?
PostPosted: Sat Sep 06, 2008 1:49 am 
Offline
Newbie
User avatar

Joined: Sat Sep 29, 2007 1:50 am
Posts: 46
Location: Virginia, USA
If you need a 2nd tester, I could give it a shot. I was going to try lenny but ran into a roadblock, and I am also a gentoo fan. I will watch this topic.


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Sun Sep 07, 2008 6:13 am 
Offline
Total Newbie

Joined: Sun Sep 07, 2008 6:08 am
Posts: 1
I had been working on getting GenLink to work, and ran into a few issues. Mostly gcc and glibc issues with a segmentation fault or two for good measure............. Anywho, I was in the middle of building a cross chaintool for arm to get it working when I fould this thread. I would be willing to throw sometime behind getting GenLink working again.


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Sun Sep 07, 2008 1:40 pm 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
Ok, I 'm holding my breath and don 't switch to Freelink) for the new stage3 tarball. From there on existing overlays should work, yes?


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Mon Sep 08, 2008 5:57 am 
Offline
Regular Member
User avatar

Joined: Fri Jul 25, 2008 3:23 pm
Posts: 160
Location: Kobe, Japan
russK wrote:
If you need a 2nd tester, I could give it a shot.

I am in too, with Linkstation Mini.


Top
   
PostPosted: Fri Sep 12, 2008 12:28 am 
Offline
Developer
User avatar

Joined: Wed Nov 29, 2006 11:27 am
Posts: 95
Location: Germany
Hi there,
got my sftp access to the files area back, thanks to mindbender and I just uploaded GenLink-stage3.1_arm9-1.1_rc1-20080910 and a corresponding /boot (sda1) image.
Binary packages are still uploading (ETA about 6 hours), but you don't need them just to test if the image boots. I also updated the wiki article about arm9 Genlink, so please test if it's any good. If it boots at all, you might see that the default kernel in the /boot image is a 2.6.22 which I compiled from jonli447/lb_worm sources, but there is also a 2.6.26 Gentoo one in a subfolder which you could try (especially if you're not planning to use JFS partitions, don't know about XFS). Speaking about kernels, if you manage to boot and setup layman after booting Genlink (or just add the orion5x overlay with the help of this xml file in your desktop Gentoo), you may find the kernel ebuilds there useful, which support automatically patching the mach-type according to your NAS box.
LaitrKeiows wrote:
I am in too, with Linkstation Mini.
Added the linkstation_mini USE flag to those kernel ebuilds too, but if you have a kernel that boots already another distribution, just replace the one under /boot with yours, or cross-compile one from these ebuilds...

Good luck (to all of us ;) )
Lucian

PS: Going to sleep right now (01:30 AM here), so even if you see me on IRC, it's just the PC uploading the binpkgs...


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 12, 2008 2:47 pm 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
Thanks for the packages.
Unfortunately, it bricked my LS PRO :mrgreen:
It seems the newer kernel doesn 't like the initrd: I hear it booting but it ends in a long beep and I get no ping reply.
Getting it into EM mode didn 't work either (procedure with 3 poweroffs)
So I had to take out the harddisk and I restored the original files, just to see.
Then it booted again.
After that, I tried the alternative kernel 2.6.26. No booting either again.
Booting with the initrd that was supplied from your previous tarball didn 't work either.

I have to tell 2 things on the side here:
-My NVRam or bios or whatever you call the stuff that is not on disk is still stock original. I don 't know if I need to flash that.
-I also noticed that in EM mode with the original Genlink I 'm able to chroot to it, the newer Genlink tells me to go upgrade my kernel (kernel too old).
Zooloo, is the initrd.buffalo you supplied the one you actually use on yours?
BTW: I tried the initrd from the Lenny distro, didn 't work either.


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 12, 2008 4:27 pm 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
Correction on my last post: 2.6.25 boots. At least, EM-mode is fine. Will try booting through now. Can chroot also to new Genlink.


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 12, 2008 4:41 pm 
Offline
Newbie

Joined: Thu Sep 04, 2008 7:41 am
Posts: 20
However, letting it boot normally results in a long beep.
Taking out the disk again, removing rootfs_ok so to get him in EM does NOT get me in EM mode again.
I must say, /dev/sda6 is formatted XFS. Do those kernels support XFS still?


Top
   
 Post subject: Re: Genlink broken?
PostPosted: Fri Sep 12, 2008 6:43 pm 
Offline
Regular Member
User avatar

Joined: Fri Jul 25, 2008 3:23 pm
Posts: 160
Location: Kobe, Japan
harakiri wrote:
However, letting it boot normally results in a long beep.

Do you have a serial port attached?
This could greatly simplify debugging.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 72 posts ]  Go to page 1 2 3 4 5 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited