Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Aug 17, 2018 9:26 pm

All times are UTC+01:00

Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Fri Aug 22, 2014 3:49 pm 
Total Newbie

Joined: Thu Aug 21, 2014 9:04 pm
Posts: 4
I have a TeraStation Pro 2 with Firmware 1.35. I am trying to make some changes to features controlling Active Directory but I cannot get root access. I am using ACP_Commander and have telnet access to the box through the admin account, but nothing I do will blank or change the root password.

I used "java -jar acp_commander.jar -t <IP_ADDRESS> -o", but apparently the -o switch is no longer valid with FW 1.35. I tried using "java -jar acp_commander.jar -t <IP Address> -c "(echo <pass>;echo <pass>)|passwd"" but that did not work either. No matter what commands I use, or what I enter as a password, I get this:

TSPro2NAME login: root
Login incorrect
TSPro2NAME login:

Can someone lead me to a FW for the TS-HTGL that will work with acp_commander?

PostPosted: Sat Aug 23, 2014 6:34 am 

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Should be the "usual" problem, that "root" is not allowed to connect via telnet.
Did you tried "su -" when logged in via telnet as user "admin"?
Or did you try to connect via ssh instead of telnet?
There was a list of user names within a file on the box, which Buffalo uses to
prevent certain users (like "root") to connect directly. Unfortunately I forgot the
name. One just need to remove "root" from this list.

Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)

PostPosted: Thu Aug 28, 2014 2:47 am 
Total Newbie

Joined: Thu Aug 28, 2014 2:10 am
Posts: 1
I have the same device with FW 1.35 and I'm having the same problem. I used the GUI version of ACP_Commander, but even though it reports that the root password has been successfully changed, I still cannot log on. However, I reset the unit back to the factory config & I was then able to log on via SSh using PuTTY and the admin username & password. This gets me access to a command shell, but it's got limited permissions. I tried the "su -" command but it wasn't recognised. I also tried changing the root password, but it told me I need root access to do so. Anyone any thoughts on how I can get root access to this box?

BTW, the shell is GNU bash, version 2.05b.0(1)-release (arm-none-linux-gnueabi) If that's of any significance.

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited