Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Wed Jul 18, 2018 1:27 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Can't access LSPRO
PostPosted: Thu Sep 29, 2011 11:02 pm 
Offline
Newbie

Joined: Thu Sep 29, 2011 10:49 pm
Posts: 8
I have a 500GB v1 Linkstation Pro which has been running FreeLink Debian 4 for a few years. I decided I would upgrade the to Debian 6 and was following the wiki instructions to do so. I got down to the stage of running the Debian preparation script where I got the error message: Incompatible bootloader version detected. Please update to the latest firmware version.

Here is where I have got myself confused and things started to go wrong! I wanted to install new buffalo firmware to update the bootloader.

I tried to run LSupdater but it couldn't find the machine - I think this is right as it can't find a freelink box???

I was previously able to ssh to the unit on 192.168.1.150 but somewhere along the line after the box rebooted I could no longer do that. Oh I have also now removed the drive and repartioned everything although sda1 is left untouched.

I have however managed to ping it on 192.168.11.150 so is it now in EM mode??

I can't telnet to it (just disconnects without attempt to log in). I can ssh to it but it no longer accepts my root password.

I have tried running TFTPBoot and although it is listening nothing happens.

I am very grateful for any suggestions as to what to try next to get the box back up and running.

Thank you!


Top
   
 Post subject: Re: Can't access LSPRO
PostPosted: Fri Sep 30, 2011 6:13 am 
Offline
Moderator

Joined: Fri Jun 29, 2007 10:39 am
Posts: 2604
Did you followed this guide?
http://buffalo.nas-central.org/wiki/Install_Debian_on_the_Linkstation_Pro/Live

I can't remember if the old LS also need a either completely empty disk or a disk with
4 "correct" partitions (sda1/sda2/sda5/sda6) for TFTP to work.
Maybe worth a try?

_________________
Please do not use private mail (PN/M) to ask questions. Use the proper forum instead. (me)

If there is no verified backup of a dataset, the dataset, by definition, is unimportant. (c't 2012)

RAID (no matter which level) never ever substitutes a backup. (me)


Top
   
 Post subject: Re: Can't access LSPRO
PostPosted: Sat Oct 01, 2011 2:13 am 
Offline
Newbie

Joined: Thu Sep 29, 2011 10:49 pm
Posts: 8
Thanks for your reply. I can't say how I solved it but eventually after endless attempts at getting TFTP to work it finally did and I reflashed latest stock firmware, then freelink/debian 4 then debian 6 install so everything is working now.

For anyone novices like me who end up in a similar position where you aren't asked for a root password on install and are a bit puzzled why you can't su then either...
1) use sudo for all commands
or
2) use:
sudo passwd root
to enable your root user


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited