Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Apr 23, 2018 4:00 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 24 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Mon Feb 06, 2012 12:41 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Hallo Everybody,

at first, sorry for my english - iam a german native speaker... :-)

After a lot of time, i tried to re-flash my hd-h300lan (lg2).
i figure out a lot of problems, but now iam need still help...

across the guide on: http://buffalo.nas-central.org/wiki/Fre ... nux_Server iam fail on point 9 and after skip this, the next problem comes at point 10:

root@LINKSTATION:~# apt-get install samba smbfs STATION:~# apt-get install samba smbfs
Reading Package Lists... Done
Building Dependency Tree... Doneerl libmd5-perl apt-show-versions-3squeeze5) but it is not going to be installed
Some packages could not be installed. This may mean that you have3squeeze5) but i
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
samba: Depends: libwbclient0 (= 2:3.5.6~dfsg-3squeeze5) but it is not going to be installed
Depends: libattr1 (>= 2.4.41-1) but 2.4.16-1 is to be installed
Depends: libc6 (>= 2.6) but 2.3.2.ds1-22sarge6 is to be installed
Depends: libcap2 (>= 2.10) but it is not going to be installed
Depends: libcups2 (>= 1.4.0) but it is not going to be installed
Depends: libgssapi-krb5-2 (>= 1.8+dfsg) but it is not going to be installed
Depends: libk5crypto3 (>= 1.6.dfsg.2) but it is not going to be installed
Depends: libkrb5-3 (>= 1.8+dfsg) but it is not going to be installed
Depends: libldap-2.4-2 (>= 2.4.7) but it is not installable
Depends: libpopt0 (>= 1.16) but 1.7-5 is to be installed
Depends: libtalloc2 (>= 2.0.0) but it is not installable
Depends: libpam-runtime (>= 1.0.1-11) but 0.76-22 is to be installed
Depends: lsb-base (>= 3.2-13) but it is not going to be installed
Depends: update-inetd but it is not installable
smbfs: Depends: samba-common (= 3.0.14a-3sarge11) but 2:3.5.6~dfsg-3squeeze5 is to be installed
Depends: libkrb53 (>= 1.3.2) but it is not going to be installed
E: Broken packages

Can anybody help me?

Thanks, wim!


Top
   
PostPosted: Mon Feb 06, 2012 1:14 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
Hello wim

Can you check
Code:
cat /etc/apt/sources.list


I think you'll have references such as
"deb http://ftp.uk.debian.org/debian/ stable main contrib non-free"
Maybe not the same, but I think 'stable' is in yours?

That image you flashed was based on 'sarge' I believe (outdated) - http://www.debian.org/releases/

You would need:
Code:
apt-get update

Code:
apt-get dist-upgrade


But BEWARE, I believe on the LS2 you are going to require u-boot in order to use the latest stable Debian release:

Instead, maybe change all 'stable' refernces in /etc/apt/sources/list to 'Lenny' and then
Code:
apt-get update

Code:
apt-get dist-upgrade

You should probably do this anyway before jumping to Squeeze



----edit------

Actually, change to 'etch' before 'lenny'


Last edited by Bauldrick on Mon Feb 06, 2012 1:17 pm, edited 1 time in total.
error


Top
   
PostPosted: Mon Feb 06, 2012 1:18 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Oh Sorry, i forget to tell, that i have change the sources.list - file...

the reason was that the point 5 at http://buffalo.nas-central.org/wiki/Fre ... nux_Server non working...

with the last and current change it would be work (point 5)

# deb http://mirrors.kernel.org/debian/ stable main contrib non-free
# deb-src http://mirrors.kernel.org/debian/ stable main contrib non-free
# deb http://security.debian.org/ stable/updates main contrib non-free
# deb-src http://security.debian.org/ stable/updates main contrib non-free

# deb http://security.debian.org/ squeeze/updates main contrib non-free
# deb-src http://security.debian.org/ squeeze/updates main contrib non-free
# deb http://debian.netcologne.de/debian/ squeeze main contrib non-free
# deb-src http://debian.netcologne.de/debian/ squeeze main contrib non-free

deb http://archive.debian.org/debian/ sarge main contrib non-free
deb-src http://archive.debian.org/debian/ sarge main contrib non-free
deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free


wim


Top
   
PostPosted: Mon Feb 06, 2012 1:22 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
wim wrote:

deb http://archive.debian.org/debian/ sarge main contrib non-free
deb-src http://archive.debian.org/debian/ sarge main contrib non-free
deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free


wim


There it is ^^

sarge is not stable

You have Sarge installed as your system and have both sarge and squeeze in your source.list


--

ahhh, I remeber, you will need uboot and 2.6+ kernel


Top
   
PostPosted: Mon Feb 06, 2012 1:24 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
After doing the dist-upgrade, i have the same problems when i do this:

apt-get install samba smbfs

Errors:

root@LINKSTATION:~# apt-get install samba smbfs
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
samba: Depends: libwbclient0 (= 2:3.5.6~dfsg-3squeeze5) but it is not going to be installed
Depends: libattr1 (>= 2.4.41-1) but 2.4.16-1 is to be installed
Depends: libc6 (>= 2.6) but 2.3.2.ds1-22sarge6 is to be installed
Depends: libcap2 (>= 2.10) but it is not going to be installed
Depends: libcups2 (>= 1.4.0) but it is not going to be installed
Depends: libgssapi-krb5-2 (>= 1.8+dfsg) but it is not going to be installed
Depends: libk5crypto3 (>= 1.6.dfsg.2) but it is not going to be installed
Depends: libkrb5-3 (>= 1.8+dfsg) but it is not going to be installed
Depends: libldap-2.4-2 (>= 2.4.7) but it is not installable
Depends: libpopt0 (>= 1.16) but 1.7-5 is to be installed
Depends: libtalloc2 (>= 2.0.0) but it is not installable
Depends: libpam-runtime (>= 1.0.1-11) but 0.76-22 is to be installed
Depends: lsb-base (>= 3.2-13) but it is not going to be installed
Depends: update-inetd but it is not installable
smbfs: Depends: samba-common (= 3.0.14a-3sarge11) but 2:3.5.6~dfsg-3squeeze5 is to be installed
Depends: libkrb53 (>= 1.3.2) but it is not going to be installed
E: Broken packages

Is it still the sources.list - failure?

wim


Top
   
PostPosted: Mon Feb 06, 2012 1:25 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Bauldrick wrote:
wim wrote:

deb http://archive.debian.org/debian/ sarge main contrib non-free
deb-src http://archive.debian.org/debian/ sarge main contrib non-free
deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free


wim


There it is ^^

sarge is not stable

You have Sarge installed as your system and have both sarge and squeeze in your source.list


--

ahhh, I remeber, you will need uboot and 2.6+ kernel


Okay, and how do i write my sources.list exactly?


Top
   
PostPosted: Mon Feb 06, 2012 1:40 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
I'm not sure if etch is till available :oops: certainly not security updates, but try :

Code:
deb http://archive.debian.org/debian/ etch main contrib non-free
deb-src http://archive.debian.org/debian/ etch main contrib non-free
#deb http://security.debian.org/ etch/updates main contrib non-free
#deb-src http://security.debian.org/ etch/updates main contrib non-free


Then apt-get clean .... apt-get update....etc..

At first, note they are commented out.

You have the problem that you CANNOT upgrade to Lenny and further stable releases until you flash uboot and have it load a 2.6> kernel


Top
   
PostPosted: Mon Feb 06, 2012 2:10 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Okay, i have do following steps:

1) apt-get clean
2) apt-get update
3) apt-get dist-upgrade
4) apt-get update
5) apt-get upgrade

And now?


Top
   
PostPosted: Mon Feb 06, 2012 2:18 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
Did it upgrade with no errors?

Code:
cat /etc/debian_version


Does it say etch? Try installing samba again...

I have to say again that if you ever want your box up-to-date (running Lenny or higher), you will need uboot.


Top
   
PostPosted: Mon Feb 06, 2012 2:23 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
It say: 4.0

How can i get uboot?

apt-get install uboot?

sorry, it is a long time ago...

thx!


Top
   
PostPosted: Mon Feb 06, 2012 2:32 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
Read the readme 4-5 times, understand what is what etc...

http://downloads.buffalo.nas-central.or ... ecompiled/

after that, there are a few kernels to choose from if I recall


Top
   
PostPosted: Mon Feb 06, 2012 2:50 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Iam at Point 5

My gateway: 192.168.2.1

My Linkstation: 192.168.2.150

must i change the ips and if yes, what it means with the expression: "server"

and is the "another window" a second putty-session?

thx


Top
   
PostPosted: Mon Feb 06, 2012 3:35 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
Change to:

Your gateway 192.168.11.1
Your LinkStation 192.168.11.150
Your Server (PC) 192.168.11.149

you need 'netcat' to connect to uboot

step 5) netconsole = netcat (linux should have it 'nc', but you are using putty so I guess on windows, maybe do a google and find it)
step 6) 'another window' = use putty goto /mnt/hda/share and execute './u-boot-load.sh'


Top
   
PostPosted: Mon Feb 06, 2012 4:14 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Iam on Mac, so i have netcat...

i use the following command: nc -u -p 6666 -v 192.168.11.150 6666

i use this simultaneously with boot the linkstation...

my terminal shows: Connection to 192.168.11.150 6666 port [udp/*] succeeded!

and nothing happens...

what should i do?

thx!


Top
   
PostPosted: Mon Feb 06, 2012 4:20 pm 
Offline
Newbie

Joined: Mon Feb 06, 2012 12:30 pm
Posts: 13
Okay, iam one step closer... :-)

Code:
Connection to 192.168.11.150 6666 port [udp/*] succeeded!

U-Boot 1.1.4 LiSt V2 (mips) 1.0.1 (Sep 20 2007 - 00:40:49)
stdin :   nc
stdout:   nc
stderr:   nc
IDE:    Bus 0: OK Bus 1: OK
  Device 0: Model: SAMSUNG HD300LD  Firm: WK100-12 Ser#: 0S4A1JL0730385
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 286168.1 MB = 279.4 GB (586072368 x 512)
Boot in 06 seconds ('s' to stop)...s

=> run upgrade
run upgrade
Loading 0:3:share/u-boot/u-boot-v2-mips.flash.bin
Error (no IRQ) dev 0 blk 465034169: status 0x51
 ** ext2fs_devread() read error - last part

** Unable to read "share/u-boot/u-boot-v2-mips.flash.bin" from ide 0:3 **
=>



Whats wrong with "me"?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 24 posts ]  Go to page 1 2 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited