I've got a problem with my LS2 which I unfortunately can not describe in complete detail since I don't remember every step. It all started when I decided to check wether it might be possible to connect the LS to my XBOX. I did some research and found TwonkyServer so I thought to give it a try. Since I haven't played with the LS for quite some time I did an apt-get update and that's how the problems started. I wanted to install telnetd to use the Twonky install application but that didn't work.
One of the packages reported a problem with dpkg not supporting breaks?, so I changed the sources.list from stable to lenny and did an apt-get dist-upgrade.
Updating stopped somewhere in the middle when I was told that I needed kernel 2.6x for some dependencies. So after much ado and trying to find information on the internet I changed the sources.list back to stable and finally to oldstable. However I'm still getting errors which I can't resolve.
Some facts from my box...
root@LINKSTATION:/etc/apt# uname -a
Linux LINKSTATION 2.4.20_mipsel_linkstation #5 Fri Apr 28 10:00:18 JST 2006 mips GNU/Linux
apt-get upgrade gives
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
at: Depends: mail-transport-agent
mailx: Depends: exim4 but it is not installed or
E: Unmet dependencies. Try using -f.
apt-get -f install wants me to update the following packages:
The following extra packages will be installed:
bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light libc6 libdb4.6 libgcrypt11 libgnutls26 libpcre3 mailx
mail-reader eximon4 exim4-doc-html exim4-doc-info gnutls-bin openssl file libmail-spf-query-perl swaks locales glibc-doc rng-tools
The following NEW packages will be installed:
bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light libdb4.6 libgnutls26
The following packages will be upgraded:
libc6 libgcrypt11 libpcre3 mailx
4 upgraded, 7 newly installed, 0 to remove and 107 not upgraded.
Need to get 0B/8219kB of archives.
After unpacking 9032kB of additional disk space will be used.
Updating ends with the following messages:
Preparing to replace libc6 2.3.6.ds1-13etch7 (using .../libc6_2.7-18lenny7_mipsel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.
The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.7-18lenny7_mipsel.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
After having read some threads I think it's not possible to go back to a stable and updateable system - but I'm happy to learn something different.
So the main question is, can I re-flash the LS2 with Freelink or Openlink without risking my data on hda3 to start from scratch with telnet enabled and the Twonky installation? Would it be possible to re-flash and then do an update to a 2.6x kernel like described here
root@LINKSTATION:/etc/apt# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda1 365M 155M 192M 45% /
/dev/hda3 367G 231G 136G 63% /mnt/hda
thanks for helping me,