Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Wed Jan 17, 2018 3:44 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Wed Mar 09, 2011 12:37 am 
Offline
Newbie

Joined: Tue Aug 21, 2007 9:37 pm
Posts: 5
Hi,

I've got a problem with my LS2 which I unfortunately can not describe in complete detail since I don't remember every step. It all started when I decided to check wether it might be possible to connect the LS to my XBOX. I did some research and found TwonkyServer so I thought to give it a try. Since I haven't played with the LS for quite some time I did an apt-get update and that's how the problems started. I wanted to install telnetd to use the Twonky install application but that didn't work.

One of the packages reported a problem with dpkg not supporting breaks?, so I changed the sources.list from stable to lenny and did an apt-get dist-upgrade.

Updating stopped somewhere in the middle when I was told that I needed kernel 2.6x for some dependencies. So after much ado and trying to find information on the internet I changed the sources.list back to stable and finally to oldstable. However I'm still getting errors which I can't resolve.

Some facts from my box...

Code:
root@LINKSTATION:/etc/apt# uname -a
Linux LINKSTATION 2.4.20_mipsel_linkstation #5 Fri Apr 28 10:00:18 JST 2006 mips GNU/Linux


apt-get upgrade gives

Code:
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  at: Depends: mail-transport-agent
  mailx: Depends: exim4 but it is not installed or
                  mail-transport-agent
E: Unmet dependencies. Try using -f.


apt-get -f install wants me to update the following packages:

Code:
The following extra packages will be installed:
  bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light libc6 libdb4.6 libgcrypt11 libgnutls26 libpcre3 mailx
Suggested packages:
  mail-reader eximon4 exim4-doc-html exim4-doc-info gnutls-bin openssl file libmail-spf-query-perl swaks locales glibc-doc rng-tools
Recommended packages:
  psmisc
The following NEW packages will be installed:
  bsd-mailx exim4 exim4-base exim4-config exim4-daemon-light libdb4.6 libgnutls26
The following packages will be upgraded:
  libc6 libgcrypt11 libpcre3 mailx
4 upgraded, 7 newly installed, 0 to remove and 107 not upgraded.
Need to get 0B/8219kB of archives.
After unpacking 9032kB of additional disk space will be used.


Updating ends with the following messages:

Code:
Preparing to replace libc6 2.3.6.ds1-13etch7 (using .../libc6_2.7-18lenny7_mipsel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
  apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.7-18lenny7_mipsel.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.7-18lenny7_mipsel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


After having read some threads I think it's not possible to go back to a stable and updateable system - but I'm happy to learn something different.

So the main question is, can I re-flash the LS2 with Freelink or Openlink without risking my data on hda3 to start from scratch with telnet enabled and the Twonky installation? Would it be possible to re-flash and then do an update to a 2.6x kernel like described here?

Code:
root@LINKSTATION:/etc/apt# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1             365M  155M  192M  45% /
/dev/hda3             367G  231G  136G  63% /mnt/hda


thanks for helping me,
jktwo


Top
   
PostPosted: Fri Mar 11, 2011 9:03 pm 
Offline
Newbie

Joined: Tue Aug 21, 2007 9:37 pm
Posts: 5
No one with an answer or even a hint wether it is safe to revert back to a fresh installation / flash or not? I don't want to loose my data partition.

jktwo


Top
   
PostPosted: Fri Mar 11, 2011 11:01 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
You need u-boot - and 2.6 to continue

http://downloads.buffalo.nas-central.or ... ecompiled/


Top
   
PostPosted: Sun Mar 13, 2011 3:00 pm 
Offline
Newbie

Joined: Tue Aug 21, 2007 9:37 pm
Posts: 5
Thanks for the hint - but it is safe enough now to update a LS2 with 2.6? I remember from the old times before this forum moved to NAS-Central that flashing 2.6 had a high potential of bricking your LS? Are there still problems regarding the two different chipsets?

jktwo


Top
   
PostPosted: Sun Mar 13, 2011 6:16 pm 
Offline
Betatester
User avatar

Joined: Thu Jul 14, 2005 4:38 pm
Posts: 941
Location: England
Hi,

I don't remember the technical reasons, but v1 of LNI's uboot did have a problem with one of the 2 used, that was/is fixed in v2. There is also shihsungs uboot you could look at..

Bottom line is I suppose messing with flash can go wrong, but generally many success stories, and you'll only be flashing uboot - 2.6 kernel sits in /boot and is loaded from there.


Top
   
PostPosted: Sun Mar 27, 2011 9:27 pm 
Offline
Newbie

Joined: Tue Aug 21, 2007 9:37 pm
Posts: 5
Ok, I've downloaded the u-boot files but I'm stuck with

5. Set the address of your server to 192.168.11.149 and start the
netconsole with the boot address of the LinkStation, 192.168.11.150. The
netconsole is the default console even if the serial port is installed
and the jumper is "on"

is this address mandatory? My network uses a 10.10.24.x range. How do I start the netconsole? On the linkstation I can not find a binary of that name or do I have to start it on my local system which is a mac? I only have an ethernet connection to the linkstation will that work with netconsole?

jktwo


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited