Hi, I was upgrading to lenny with dist-upgrade and got the following oddity:
Preparing to replace libc6 2.3.6.ds1-13etch8 (using .../libc6_2.7-18_mipsel.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: POSIX threads library NPTL requires kernel version
2.6.8 or later. If you use a kernel 2.4, please upgrade it
before installing glibc.
The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add etch sources to your /etc/apt/sources.list and run:
apt-get install -t etch linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.7-18_mipsel.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Any idea how I can fix this and whether new kernels will work on my device?