Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sat Oct 25, 2014 2:51 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Wed Dec 19, 2007 6:01 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
Anyone know of an open source variant for nvram that comes on our ARM boxes? The current stock one requires libbuffalo_bin.so ...
so I'm looking for one that could be compiled from scratch without this requirement/dependency...

ideas?

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Last edited by davy_gravy on Tue Jan 01, 2008 4:18 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Wed Dec 19, 2007 6:12 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5330
apt-cache show powerpc-ibm-utils # etch
http://powerpc-utils.ozlabs.org/

(HTH)


Top
 Profile  
 
PostPosted: Wed Dec 19, 2007 1:44 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
thanks andre .... not sure if it is ppc only, or if it could be modified to run on ARM, but it's certainly worth a look :)

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
 Profile  
 
PostPosted: Tue Jan 01, 2008 4:17 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
the pertinent binary are in uboot-utils (in foonas/OE).
the commands are
Code:
fw_getenv
and
Code:
fw_setenv
...
woohoo!
Code:
 root@lsarm:/etc# fw_setenv bootcmd ext2load ide 1:1 0x00100000 /boot/uImage \; setenv bootargs console=ttyS0,115200 root=/dev/sda1 rw \; bootm 0x00100000

now allows my lspro to boot into foonas w/o the serial cable needed ...

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Protected by Anti-Spam ACP
Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group