Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Aug 20, 2018 7:27 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
 Post subject: PS1 prompt on openlink
PostPosted: Sun Nov 04, 2007 4:04 am 
Offline
Newbie

Joined: Sun Nov 04, 2007 3:57 am
Posts: 8
hi - i have installed openlink on an LS2 and can't seem to find where the prompt is configured. I have changed the bashrc and profile files but it doesn't work - I can see a definition of PS1, but it's not the one that's presented at login. Any help?

Also, I would like to be prompted for a password and get my pwd set to /home or /root on login as root. Currently it's just /. Can't find this either.

Thanks in advance anyone who can help a Linux beginner!


Top
   
PostPosted: Sun Nov 04, 2007 5:14 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
are loggin in via telnet?

this might be a reason i think. you should install the openssh server and connect via ssh...then i think it should behave as it should.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Sun Nov 04, 2007 8:29 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
You need to make changes to /etc/init.d/utelnetd, see the FAQ. This should do the trick:

1. Log on, DO NOT CLOSE THIS SHELL WINDOW
2. Run

test -e /etc/init.d/utelnetd && echo '#!/bin/sh
#/sbin/utelnetd -l /bin/bash &
/sbin/utelnetd -l /bin/login &
exit 0;
' > /etc/init.d/utelnetd && /etc/init.d/utelnetd stop && /etc/init.d/utelnetd start

3. DO NOT CLOSE THE EXISTING SHELL WINDOW YET
If everything worked without error, log on on/to a second shell as root. You should be prompted for your root password. IF you can log in (with username and password this time), you are fine. IF NOT, DO NOT CLOSE THE ORIGINAL SHELL and report back.


Top
   
PostPosted: Sun Nov 04, 2007 11:45 pm 
Offline
Newbie

Joined: Sun Nov 04, 2007 3:57 am
Posts: 8
thanks guys - problem sorted.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited