Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Aug 20, 2018 7:28 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Wed Aug 08, 2007 1:18 pm 
Offline
Newbie

Joined: Tue May 22, 2007 8:00 am
Posts: 34
Location: Solingen, Germany
Dear all,

I have installed Openlink and Wonkymedia on my LS2 (Mipsel) and had some problems with the SMB-access, so I installed NFS on the Linkstation (instruction from http://www.herz.in). Everything is working fine and very fast.

But I have a problem with the german umlauts. If I mount the shares on the Mac (using NFS Manager, because I'm to stupid to do it by hand) I haven't access to the files, which contains the german umlauts. The filename is cryptic and i.E. iTunes unable to Play the file.

Is there anybody, who can give me an hint, what to do, or how to mount it correctly ?

Thanks a lot,
Peter


Last edited by peternie on Fri Aug 24, 2007 12:56 pm, edited 1 time in total.

Top
   
PostPosted: Wed Aug 08, 2007 1:58 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
most likely this has to do with the charset used.

which one do you use?

you can change this via the webinterface. unfortunately unicode/UTF isn`t supported.

http://de.wikipedia.org/wiki/ISO_8859

try ISO_8859-1, ISO_8859-15

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Wed Aug 08, 2007 2:42 pm 
Offline
Newbie

Joined: Tue May 22, 2007 8:00 am
Posts: 34
Location: Solingen, Germany
Hi,

thanks for your tip, I can check it this evening, where can I find the Charset in the Webinterface on the LS2 ?

Would there be a problem with the other components (like SMB-using Windowsclients or Streamlingclients), which are working correct right now, if I change the charset ? I Think, this is only a problem with the NFS-access.

Thanks,
Peter


Top
   
PostPosted: Wed Aug 08, 2007 3:34 pm 
Offline
Newbie

Joined: Thu Aug 02, 2007 5:25 pm
Posts: 7
peternie wrote:
where can I find the Charset in the Webinterface on the LS2 ?


I am not sure about your other questions but the "Character Code" setting on the LS1 (I am assuming the LS2 is very similar web interface) is under "Basic Setup"->"Date and Time Setup" at the end of the "Time and Date Settings" even though this has almost nothing to do with time and date really. Since there are no unicode settings like UTF-8 available I recommend ISO8859-1 AKA Latin 1 as that should support German umlauts among other western European characters.


Top
   
PostPosted: Wed Aug 08, 2007 5:14 pm 
Offline
Newbie

Joined: Tue May 22, 2007 8:00 am
Posts: 34
Location: Solingen, Germany
sorry,

the setting is still on 8859-1 and i tried the -15 setting as well, but there is no change. I really think, that I have to do something on the mac while mounting the share via NFS....

any other ideas ?

Peter


Top
   
PostPosted: Wed Aug 08, 2007 5:56 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
No. My NFS (LS1, Debian etch NFS kernel server, en_US.UTF-8/Mac OS 10.4.10) works without any issue, FWIW. Don't mix NFS with anything else (SMB/CIFS)...


Top
   
PostPosted: Wed Aug 08, 2007 6:41 pm 
Offline
Newbie

Joined: Tue May 22, 2007 8:00 am
Posts: 34
Location: Solingen, Germany
Hi Andre,

you helped me last time with my smb-problem, didn't you (the morning restart thing of samba to enable the access from the mac).

can you explain me, how to disable the other stuff, I think, NFS is still the best solution for the linkstation using mac and windows-clients.

Peter


Top
   
PostPosted: Wed Aug 08, 2007 9:29 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
You're the person owing me a beer, aren't you? ;) Hope your feet didn't get too wet in that heavy rain lately.

chmod 0644 /etc/init.d/atalk
chmod 0644 /etc/init.d/smb
reboot


Top
   
PostPosted: Fri Aug 24, 2007 12:56 pm 
Offline
Newbie

Joined: Tue May 22, 2007 8:00 am
Posts: 34
Location: Solingen, Germany
to make this thread complete. It works.

The change to NFS is only relevant to new files, you write on the Share. If you use Samba and wants to switch to NFS you could get problems with german umlauts. Workaround is to copy all files with SMB to your local disk, diable SMB activate NFS (to make sure, you connect with NFS) and copy back the files with NFS, so your Umlauts are correct on the share.

Peter


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 9 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited