Buffalo NAS-Central Forums
http://forum.buffalo.nas-central.org/

Replace the hard disk && Reinstall the system too?
http://forum.buffalo.nas-central.org/viewtopic.php?f=3&t=20806
Page 4 of 4

Author:  Bauldrick [ Sun Aug 30, 2009 12:58 pm ]
Post subject:  Re: Replace the hard disk && Reinstall the system too?

1)
zlyzwy wrote:
1) it seems everytime I started the LS, I have to go to U-Boot and type these code:
Code:
ide reset
ext2ls ide 0:1 /
ext2load ide 0:1 82000000 /boot/vmlinuz-2.6.30.5
setenv bootargs 'root=/dev/sda1 rw netconsole=6666@192.168.11.150/,@192.168.11.149/'
save <=== there should save the evr, otherwise it won't renew the Flash...
bootm


I seem to remember haven't this sort of problem, had to change bootcmd, try something like:

Code:
set bootcmd4 ext2load ide 0:1 82000000 boot/vmlinuz\; set bootargs root=/dev/sda1 rw\; bootm 82000000

Code:
set bootcmd run bootcmd4

Code:
save; reset


Providing you have a link from vmlinuz-2.6.30.* to vmlinuz ^^^

2)
Yes you can change the address, davygravy wrote an article I think > HERE

3)
Yes you change it to pull updates from where suits you

4)
Have you run dpkg-reconfigure tzdata and do you have ntp installed?

Author:  zlyzwy [ Sun Aug 30, 2009 2:14 pm ]
Post subject:  Re: Replace the hard disk && Reinstall the system too?

Hi Bauldrick,

Thanks for your help!

Question #1
You new boot code can work for me .. I don't really know where is the problem but it works here. :up:

Question #2
Thanks for your tips. I was thinking I won't use U-boot so often. And mostly I would just use new Debian. I would like to know, if I only change the IP with Debian(/etc/network/interfaces&&/etc/resolv). Is that any problem? I think there should be no connection between U-boot and Debian? :?:
EDIT: I have just tried... It's OK... haha ... When I need U-Boot I can change the IP to the old one...:))

Qeustion #3
Thanks , I have tried the new source.. it's working well...

Question #4
I think I found the problem. I didn't start the NTP with startup...

Thanks again for your help!

Author:  zlyzwy [ Tue Sep 01, 2009 4:46 pm ]
Post subject:  Re: Replace the hard disk && Reinstall the system too?

Hi!

I am using the new system well in the past two days. and I began to install some softwares like pure-ftp and postfix.
but I found one strange thing. When I reboot/boot the LS. the "Disk full" will blink severl(7) times. Of course I didn't put much files in the LS now, only one pure-ftp only.
here is the space situation:
Code:
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1             4.7G  539M  3.9G  12% /
tmpfs                  30M     0   30M   0% /lib/init/rw
udev                   10M   60K   10M   1% /dev
tmpfs                  30M     0   30M   0% /dev/shm
/dev/sda3             143G  188M  136G   1% /home


It's not a big problem if it will only blink several times when booting. But I got a bit worry there is some other problem?

Thanks for any reply in advance!

Page 4 of 4 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/