Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Sun Nov 19, 2017 6:12 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 57 posts ]  Go to page Previous 1 2 3 4 Next
Author Message
PostPosted: Mon Aug 21, 2006 8:07 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
we should all write up a list in the wiki which commands are ok to be implemented by busybox and which are not.

i mean....then i know what i could do and what not. i used cpio the first time yesterday...at least for ppc i have most of the stuff either ready as a tarball or at least i have compiled it (coreutils usw)....i could make ipkg aware of the packages that are already installed..

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Aug 21, 2006 8:14 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
#!/bin/bash
export PATH="/usr/local/bin:$PATH"


Top
   
PostPosted: Mon Aug 21, 2006 8:25 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
andre wrote:
#!/bin/bash
export PATH="/usr/local/bin:$PATH"


And how will this work right after installing the cpio ipk?

Hint: It won't. But thanks for trying. Do you have a better idea?

What I'll do, is that I'll compile and provide a new busybox and cpio will depend on this busybox.


Top
   
PostPosted: Mon Aug 21, 2006 8:31 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
mindbender wrote:
we should all write up a list in the wiki which commands are ok to be implemented by busybox and which are not.


All are okay, but if the real thing gets installed, it should remove the busybox variant.


Top
   
PostPosted: Mon Aug 21, 2006 8:34 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
andre wrote:
And how will this work right after installing the cpio ipk?
Hint: It won't. But thanks for trying. Do you have a better idea?


You are welcome.


Top
   
PostPosted: Mon Aug 21, 2006 8:34 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
andre wrote:
Why in the world would you announce a shell script if you want to create ipkg feeds.


Pardon? The issue is, that the cpio ipk gets installed but "doesn't" work, as the busybox cpio is called when running "cpio". IMO simple things as this should "just work". As I said, that's not really possible following your too strict rules.

But if you know a workaround: I'd be interested to learn! I don't. That's why I'm going to compile and provide busybox 1.2.1 and will have it install to /bin, which will interfere with your rule.

Thanks,
Alexander


Top
   
PostPosted: Mon Aug 21, 2006 8:35 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
andre wrote:
Quoting: andre
And how will this work right after installing the cpio ipk?
Hint: It won't. But thanks for trying. Do you have a better idea?


You are welcome.


Thought so. But thanks for confirming this.


Top
   
PostPosted: Mon Aug 21, 2006 8:38 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
I don't think we're speaking the same language. Please don't mess up our standard OpenLink installations, unless you want to provide long-term support for your modified versions in this forum.


Top
   
PostPosted: Mon Aug 21, 2006 8:47 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
askwartemp wrote:
But if you know a workaround: I'd be interested to learn! I don't. That's why I'm going to compile and provide busybox 1.2.1 and will have it install to /bin, which will interfere with your rule.


if you do then make the package available that i can include it to openlink by default.

askwartemp wrote:
All are okay, but if the real thing gets installed, it should remove the busybox variant.

thats easy. just delete the relevant symlink. thats all.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Aug 21, 2006 8:56 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
mindbender wrote:
Quoting: askwartemp
But if you know a workaround: I'd be interested to learn! I don't. That's why I'm going to compile and provide busybox 1.2.1 and will have it install to /bin, which will interfere with your rule.


if you do then make the package available that i can include it to openlink by default.


Sure, no problem at all.

askwartemp wrote:
All are okay, but if the real thing gets installed, it should remove the busybox variant.

thats easy. just delete the relevant symlink. thats all.


I know. That's what I did and that is what andre is complaining about.


Top
   
PostPosted: Mon Aug 21, 2006 8:58 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
andre wrote:
I don't think we're speaking the same language.


Seems like. I'm trying to tell you, that I'm trying to make the package as easily usable as possible.

Quote:
Please don't mess up our standard OpenLink installations, unless you want to provide long-term support for your modified versions in this forum.


The sources are available.

Anyway: You still haven't shown a workaround or a viable solution. Will you provide one? Does it make sense to wait some more?

Shocked
Alexander


Top
   
PostPosted: Mon Aug 21, 2006 9:56 am 
Offline
Newbie

Joined: Sun Jul 23, 2006 6:21 pm
Posts: 51
Location: Germany
FYI: I now compiled cpio static and uploaded this package. It's of course larger, but there's no risk of a missing or malfunctioning library.


Top
   
PostPosted: Mon Aug 21, 2006 2:28 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
[quote="askwartemp":bb270]You still haven't shown a workaround or a viable solution. Will you provide one? Does it make sense to wait some more?[/quote:bb270]

Definitely not, sorry.


Top
   
PostPosted: Mon Aug 21, 2006 2:33 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
currently nobody is really maintaining OpenLink for the LS2 (mips). the reason for that is simply because i have no LS2...just a LS1...

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Aug 21, 2006 3:17 pm 
Offline
Newbie
User avatar

Joined: Thu Dec 29, 2005 4:40 pm
Posts: 46
Location: Germany
Hi,

i'm back from work and the thread has 28 replies WOW ;)

After i installed the new cpio everything works now.

Thanks again to askwartemp.

Now i will give samba _3.0.23b a try...

ohh just one more Question:

Filenames with German-Umlaute like

'äüöß'

which are OK in Windows-Explorer are scrambled if i look at them via telnet/mc.
Any Ideas?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 57 posts ]  Go to page Previous 1 2 3 4 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited