Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 6:34 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 57 posts ]  Go to page Previous 1 2 3 4
Author Message
PostPosted: Wed Sep 27, 2006 10:38 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
it is not a good idea to mix 2 package management systems....

if you are running freelink you should only use the apt-get system....

if you are running openlink use ipkg.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Wed Sep 27, 2006 10:43 pm 
Offline
Newbie

Joined: Tue Aug 29, 2006 12:36 pm
Posts: 46
I used the ipkg package management system with the openlink and still had this result.

Chris


Top
   
PostPosted: Wed Sep 27, 2006 10:54 pm 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
then this seems to be more a problem with the package from askwars feed....hmmm....what could the problem be?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Mon Apr 16, 2007 12:11 pm 
Offline
Total Newbie

Joined: Mon Apr 16, 2007 12:10 pm
Posts: 1
Same to here....

I am using OpenLink (without install Debian).

After: "ipkg install samba":

ls: relocation error: /lib/libpthread.so.0: symbol __libc_stack_end, version GLIBC_PRIVATE not defined in file ld.so.1 with link time reference

The only thing I could do is, re-install the openlink again.
And ofocz, all my setting gone ..... (ok ok, I forgot to backup /etc/....)


Top
   
PostPosted: Mon Apr 16, 2007 2:53 pm 
Offline
Developer
User avatar

Joined: Sun Dec 31, 2006 10:40 am
Posts: 434
Location: Scotland
If I remember rightly there was one of the packages that had a dodgy libpthread.so.0.

There's an old thread about this http://oldforum.linkstationwiki.net/index.php?action=vthread&forum=4&topic=407


Last edited by Kaiten on Sat Apr 28, 2007 2:04 pm, edited 1 time in total.

Top
   
PostPosted: Fri Apr 27, 2007 9:48 am 
Offline
Total Newbie

Joined: Fri Apr 27, 2007 9:41 am
Posts: 3
Hi..I'm new to this forum, but have a question.

I have a Linkstation LS2 with a Openlink firmware.

When I had Windows XP on my laptop everythin was working fine between the linkstation and the laptop. Now I got my upgrade DVD and upgraded to Vista.
Because of changes in Vista I can't get access to my shares on the Linkstation.
After doing some reading on the internet I understand it has something to do with the (dated) samba version on the linkstation.

So here I am, only having a Windows XP laptop, Vista laptop and almost zero knowledge of unix/linux.

Is it possible to do the Samba upgrade on the XP laptop? Can someone explain (step by step) how to do this?

Are there any other solutions to my problem?


Top
   
PostPosted: Fri Apr 27, 2007 10:27 am 
Offline
Moderator
User avatar

Joined: Tue Jul 26, 2005 5:22 pm
Posts: 1123
Location: United Kingdom
Have you tried going to http://www.buffalotech.com downloads area and applying the patch that Buffalo have posted for use with Vista? This patch changes the way that Vista authenticates against the LinkStation.

For some reason only some people who go to Vista appear to lose their shares. Not sure why that is.

Upgrading to Samba 3 is another possibility - but that is done on the LinkStation end, so it does not make any difference which PC you use to connect to the LinkStation. I would apply the Vista patch even if you intend to go down this route.


Top
   
PostPosted: Fri Apr 27, 2007 4:04 pm 
Offline
Total Newbie

Joined: Fri Apr 27, 2007 9:41 am
Posts: 3
Finally I found the Vista patch, but that patch isn't suitable for my HS-HL160.
I found it at de US part of the Buffalo site, at the Europe part I couldn't found it.

But as I said it doens't work :(

So the Samba 3 installation can be done from my XP laptop.....is there a installation readme available or something?


Top
   
PostPosted: Sat Apr 28, 2007 8:53 pm 
Offline
Site Admin
User avatar

Joined: Tue Jul 12, 2005 11:26 am
Posts: 3701
Location: JAPAN
What is your current samba version? smbd -V

_________________
LS used as PVR and streaming source


Top
   
PostPosted: Tue May 01, 2007 11:45 am 
Offline
Total Newbie

Joined: Fri Apr 27, 2007 9:41 am
Posts: 3
Hmmm can't get in at the moment (bad password/access denied.
But I think it's de Samba version that is in de last firmware 2.30 or in Openlink? Is that version 2.2?


Top
   
PostPosted: Thu May 24, 2007 12:24 am 
Offline
Newbie

Joined: Tue Jan 09, 2007 6:42 am
Posts: 39
Location: Adanac
askwartemp wrote:
BuffaloBerny wrote:
but after a reboot smb.conf is rewritten by the Webinterface.
How do i make these changes permanent?


Hm. You could write a good smb.conf and copy it to, let's say, /etc/samba/smb.conf.good. In /etc/init.d/bootmisc, add:
Code:
cp /etc/samba/smb.conf.good /etc/samba/smb.conf

And in /etc/init.d/reboot, you could add:
Code:
cp /etc/samba/smb.conf /etc/samba/smb.conf.good

With this, the settings from your smb.conf would persist a reboot.


just disable the smb.conf updates:

How to disable the automatic update of smb.conf, proftpd.conf, Applevolumes.default
http://buffalo.nas-central.org/index.php/Ho ... es.default


Top
   
PostPosted: Thu Aug 25, 2011 4:15 am 
Offline
Moderator
User avatar

Joined: Thu Apr 06, 2006 1:33 pm
Posts: 1082
Location: United States of America
BuffaloBerny wrote:
Hi,

on askwartemp's Webside http://alexander.skwar.name/~askwar/linkstation/packages/mipsel/
are three Samba 3.0 Installationfiles:
    samba-doc_3.0.23b-1askwar_mipsel.ipk
    samba-swat_3.0.23b-1askwar_mipsel.ipk
    samba_3.0.23b-1askwar_mipsel.ipk
Anyone installed this allready and are there any instructions/hints
to get it running without bricking the existing files on the LS2?

Please Help and Thanks...


Anyone know what happened to this package repository? Did we ever mirror this anywhere else?

_________________
-Ramuk

LinkStation HG *250 Uboot - Foonas-EM - Freelink
Kuro HG *750 Uboot - Foonas-EM - Debian Squeeze
Kuro HD *60 Uboot - Foonas-EM - Debian Squeeze (For Sale)
KuroPro *2TB Debian Lenny Armel- Kernel 2.6.26
KuroPro *1TB Debian Lenny Armel- Kernel 2.6.25.6


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 57 posts ]  Go to page Previous 1 2 3 4

All times are UTC+01:00


Who is online

Users browsing this forum: Bing [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited