Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Thu Nov 23, 2017 6:46 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 144 posts ]  Go to page Previous 16 7 8 9 10
Author Message
PostPosted: Tue Oct 10, 2006 8:44 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
the latest is 1.4.13...
http://lighttpd.net/download/

Code:
* fixed compilation of LOCK support in mod-webdav


question is if it locks the file completely or only from the webdav side?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Tue Oct 10, 2006 8:52 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
webdav only


Top
   
PostPosted: Tue Oct 10, 2006 8:53 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
better than nothing.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Tue Oct 10, 2006 8:57 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Huh? Ligthy is a web server!

I think I misunderstood you: If the webdav module is active, you'll get locks on the entire server.


Top
   
PostPosted: Tue Oct 10, 2006 9:18 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7703
Location: Austria, Vienna
then this could be the solution....isn`t it?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
   
PostPosted: Tue Oct 10, 2006 1:50 pm 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
andre wrote:
That's the point, isn't it. All my webdav files here are www-data: and [d]rw[x]------. Everything above this level must be handled by Apache or Samba, to my understanding.

Yes, to a point. I guess I should have been specific, the user that originally loads Samba does not need to be the same as the apache user. This would not solve anything. Samba users (the *nix users that actually access the shares) and apache being the same users would sove the issue. A big problem though, it's difficult to have apache spit out sever child daemons as different users, especially if there's several users.

andre wrote:
So you've got everything you need?

I've got a workaround for now with the permission issue. I also understand changing the default group for user httpd, it still didn't work for me. Apache would still only write as the group in httpd.conf. So if I want httpd to belong to group httpd and hdusers, and write files to the shares under "hdusers", but have apache run under group "httpd", still doesn't work. The only way I got things to work was to set Apache to run as group-hdusers in httpd.conf. This is definately not ideal, so I wouldn't call this issue completely fixed.

The locking issue, I am still looking into where samba's lock dir is and am goring to experiment with coding a few things from there. So, the locking issue, though to a huge problem, is also not fixed, rather not fixed at all yet.

Thanks

_________________
http://www.opifer.net


Top
   
PostPosted: Sun Oct 15, 2006 2:57 am 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
@Andre - I just bought a LS Pro. I will try setting up webdav on the LS Pro once I can figure out how to get both telnet access and can successfully compile progs on the LS Pro. After that, I'll try compiling kernels for the LS2. :)

_________________
http://www.opifer.net


Top
   
PostPosted: Sun Oct 15, 2006 7:11 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Both sounds good :)


Top
   
PostPosted: Fri May 22, 2009 9:33 pm 
Offline
Total Newbie

Joined: Wed May 20, 2009 12:34 am
Posts: 4
I have new LinkStation Live hoping that what they call "Web Access" will be some implementation of WebDAV which isn't the case unfortunately.
I've just learnt how to login to it trough SSH client.
Since last post in this tread was from 3 years ago I wonder if
there a quick simple way to enable/install webdav on Linkstations
Thanks


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 144 posts ]  Go to page Previous 16 7 8 9 10

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Limited