Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Mon Jun 18, 2018 12:56 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Sep 01, 2010 9:21 am 
Offline
Total Newbie

Joined: Wed Sep 01, 2010 9:00 am
Posts: 2
hi guys,
glad to find this forum :)

we are proud owner of an terastation pro v2 rackmount 4tb with stock firmware 1.33. as our admin recommended this device to us, we bought it, not knowing tha our osx clients will cause many problems on this device regarding to user rights on files and directories. we now need to gain telnet acces to repair the rights (e.g. 0777) on our data and modify the smb.conf (force create mask or so). after researching the web for a week by now, i wonder if our device is really able to enable telnet via acp_commander. i've been trying now for a while, but always get the same error on acp_commander:

Code:
A SocketTimeoutException usually indicates bad firewall settings.
Check especially for *UDP* port 22936 and make sure that the connection to your LS is working.
ERROR: Exception: SocketTimeoutException (Receive timed out) [ACP Send/Receive (Packet:8020 = ACP_Discover)]


i'm pretty sure there is no firewall in between (or i don't konw a hidden portblocker on osx??). i tried a portcheck via osx on the terastation and ist says the following:

Code:
„Portscan“ wurde gestartet …

Port Scanning host: 192.168.22.106

    Open TCP Port:    21           ftp
    Open TCP Port:    80           http
    Open TCP Port:    139          netbios-ssn
    Open TCP Port:    443          https
    Open TCP Port:    445          microsoft-ds
    Open TCP Port:    548          afpovertcp
    Open TCP Port:    873          rsync
    Open TCP Port:    8873         dxspider
    Open TCP Port:    22939
„Portscan“ wurde beendet …


i would be very happy if someone of you guys can give me advice wheter telnet is possible on the terastation pro v2 rackmount at all or what is wrong in my trying and how i can gain telnet access to this device.

if some data is missing for you to answer my question, i'm sorry. it's my first post in this specific thing. just tell me, what's missing!

edit:
when using the find command in acp_commander i get the following result, even if i can normally connect to my terastation via smb

Code:
Using random connID value = 0F54177D02FE
Using target:   broadcasthost/255.255.255.255
Sending ACP-Disover packet...
Found 0 linkstation(s).


thank you so much in advance if u can help me!

best regards from germany
andré


Top
   
PostPosted: Thu Sep 02, 2010 12:09 am 
Offline
Newbie

Joined: Thu May 28, 2009 11:29 pm
Posts: 8
You could try the

-b localIP

option. The readme (http://downloads.buffalo.nas-central.org/TOOLS/ALL_LS_KB_ARM9/ACP_COMMANDER/README) suggests that if acp_commander can't find your terastation.

You could also try the

-p port

option to connect on a different port. I notice from your note that acp_commander is using its default 22936 port, but note that that is UDP - your portscan is showing a different port 22939, but that's TCP anyway.


Top
   
PostPosted: Mon Sep 06, 2010 10:05 pm 
Offline
Developer

Joined: Wed Oct 25, 2006 6:05 pm
Posts: 613
Location: Germany
Hi andré,

Buffalo has modified its server application for improved security in the past. However I'd be surprised if they really had changed the port. Just to make sure rerun your portscan looking for the appropriate UDP-Port
Code:
nmap  -sU -p 22930-22940 <yourip>
I'd expect port 22936 to be open.
As long as the box doesn't answer the discovery packet the acp_commander cannot work. Does the buffalo firmware upgrade software see your box? Maybe it's worth to try a direct connection between your computer and the box. A standard network cable will be sufficient (as the box has a gigabit ethernet port).

If you finally get an answer from the box you'll also need to use the "-ip <newip>" option, as only in that case the acp_commander authenticates using the admin-password. Originally this wasn't necessary, but as mentioned above buffalo has beefed up security.

Cheers,
Georg

_________________
acp_commander users note: from ver. 0.4 on the correct ACP authentication method is used, avoiding possible side effects.
Download: http://sourceforge.net/project/showfile ... _id=167037


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited