Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Apr 20, 2018 10:51 pm

All times are UTC+01:00




Post new topic  Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Tue Jul 19, 2011 11:13 pm 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
I was running my LS1 with firmware 1.47 and using the printserver to print to my HP Laserjet 1200 from windows Xp. After I installed openlink 0.73b, I can't print anymore. I can see the printer and i can add it but i can't print anything.

Any ideas.


Top
   
PostPosted: Thu Jul 21, 2011 6:15 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
A different kernel may access the printer in a different place, like /dev/usb/lp0 vs. /dev/lp0 vs. Run the "dmesg" command to locate the printer. Also, a "ps aux|grep lp" would be helpful to help determining the configuration files to edit.


Top
   
PostPosted: Thu Jul 21, 2011 5:25 pm 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
I looked at dmesg and it listed the printer at usblp0, does that mean that the printer used is /dev/usb/lp0 or /dev/lp0. I did 'ps aux | grep lp' I only got the grep process nothing else. I checked the web interface and it shows that the print server is enabled. I still can't print. What am I missing?

Thank you


Top
   
PostPosted: Thu Jul 21, 2011 6:01 pm 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
I did more research and found out that lprng is not running by default. I started it manually using /etc/init.d/lprng start and I can print now using the Windows Print services for unix.

My question now is how to set it up so lprng runs at boot.

Thank you


Top
   
PostPosted: Thu Jul 21, 2011 6:15 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Create symbolic links.

for i in 2 3 4 5; do
[ -d /etc/rc.d/rc${i}.d ] && ln -s /etc/init.d/lprng /etc/rc.d/rc${i}.d/S20lprng || ln -s /etc/init.d/lprng /etc/rc${i}.d/S20lprng
done

for i in 0 1 6 ; do
[ -d /etc/rc.d/rc${i}.d ] && ln -s /etc/init.d/lprng /etc/rc.d/rc${i}.d/K20lprng || ln -s /etc/init.d/lprng /etc/rc${i}.d/K20lprng
done

chmod 0755 /etc/init.d/lprng


Top
   
PostPosted: Thu Jul 21, 2011 6:35 pm 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
I looked at my rc*.d and I see S60lprng and K60lprnd links. What is the difference between S20 and S60.

Thanks


Top
   
PostPosted: Thu Jul 21, 2011 8:57 pm 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
K60 is killed later than K20 (irrelevant here), S20 starts earlier than S60 (also more or less irrelevant). Anyway -- does it work now? If not, replace the existing symlinks with the new ones. The crucial point is probably the full path (/etc/init.d/ instead of ../init.d/).


Top
   
PostPosted: Fri Jul 22, 2011 12:34 am 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
I added all the symbolic links with the correct path and change the mod but it still does not work. What else is there to do.

Thank you


Top
   
PostPosted: Fri Jul 22, 2011 5:16 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Actually nowhere, this is the place. Unless the web interface disables something somewhere.

What are the contents and permissions of /etc/init.d/lprng? Please do an "ls -l" on one of the S??lprng symlinks, too.


Top
   
PostPosted: Fri Jul 22, 2011 7:04 am 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
I changed the permissions for /etc/init.d/lprng to 0755 as you mentioned and the symbolic links all have 777 permissions.

One thing I found out is that if I start it manually it works. i tried it where i disabled printing from the web interface, then i tried to start it manually and nothing happens.

Thank you for all your help.

Is there a log that I can look at that might give me a hint of what is going on.


Top
   
PostPosted: Fri Jul 22, 2011 10:56 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5332
Please do check if the symlinks point to /etc/init.d or not, and "cat /etc/init.d/lprng". The logs should be in "dmesg", or in /var/log/. Also, check if the usblp0 device has got the permissions 666.


Top
   
PostPosted: Fri Jul 22, 2011 6:57 pm 
Offline
Newbie

Joined: Tue Jul 19, 2011 6:24 pm
Posts: 12
Soved it.

I looked at the log file and noticed
1. if says that it started the lpd
2. I get an access denied error on /dev/null

So I changed permissions as follows chmod a+w /dev/null and it seems to work now.

Thank you for all your help


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 12 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Limited