Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Wed Oct 22, 2014 1:39 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Fri Nov 16, 2007 1:21 am 
Offline
Newbie

Joined: Fri Nov 16, 2007 1:19 am
Posts: 8
new ushare has been released. would love to get it compile for arm9 thanks :)

http://ushare.geexbox.org/

Code:
Latest release of uShare is 1.1.

ChangeLog:

    * Much more complete DLNA support through external libdlna.
    * Telnet Control interface.
    * Support for FLAC and HDMOV files.
    * FreeBSD 64bit and MacOSX build fix.


Top
 Profile  
 
PostPosted: Fri Nov 16, 2007 3:33 am 
Offline
Moderator
User avatar

Joined: Tue May 23, 2006 9:20 pm
Posts: 366
Location: Chicago USA
so does this need to be deleted?

_________________
1 LS-GL: (FreeLink - 2.6.22 kernel)- backup and media server...
As of June 11, 2010:
admin@LS320:~$ uptime
20:23:40 up 417 days, 20:09, 1 user, load average: 0.20, 0.21, 0.30

That's only because I had to move that time ago. Love this box and this community, wish I had more time to dedicate to it.


Top
 Profile  
 
PostPosted: Fri Nov 16, 2007 8:34 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7702
Location: Austria, Vienna
no, i told him to do so...he asked in IRC....its more or less is a reminder....

but you are right, normally i would think about deleting such threads :)

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
 Profile  
 
PostPosted: Fri Nov 16, 2007 9:37 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7702
Location: Austria, Vienna
hm. i just changed my mind. thats already a task for the optware feed.

http://ipkg.nslu2-linux.org/feeds/optwa ... ss/stable/

look there they have ushare 1.0.3 there...they will soon have ushare 1.1

so daver...follow this post:
viewtopic.php?f=19&t=4075&p=39162#p39162

at the end then execute:

Code:
ipkg update
ipkg install ushare


it will install ushare 1.0.3....but you can check if a new version is available + automatically install it via
Code:
ipkg update
ipkg upgrade

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
 Profile  
 
PostPosted: Mon Aug 11, 2008 10:29 am 
Offline
Newbie

Joined: Sat Aug 09, 2008 9:32 am
Posts: 5
Although ushare 1.1a is available via optware, I needed to make some modifications to it to get better support for Playstation 3.
Out of the package, uShare 1-1a and PS3 only worked with photos and MPEG1/2 streams.

I modified the uShare mimetypes to include some missing DLNA-flags and compiled it for the LinkStation Live stock firmware (2.10)
and now I can stream photos (JPG), MP3s, AVIs (Xvid, Divx), MPEG1/2s, Windows Media Video (WMV) and M2TS (AVC/MPEG-2
transport stream with AC3 or LPCM audio) to the PS3.

Those that are interested can pick up the uShare-1-1a binary package for the stock firmware from here :
http://www.kolumbus.fi/~d601194//linkstation/ushare-1.1a-custom+libupnp-1.6.6+libdlna-0.2.3-ffmpeg-libavutil-2008-08-03.tgz

Installation goes like for the uShare 1.0 as described in
http://buffalo.nas-central.org/index.php?title=Ushare_-_UPnP_Media_Server_for_Linux#Install.
Just untar the packge and run ldconfig. There is also a README in the package telling how the binary was actually made
plus some information how to get uShare to start automatically with Linkstation.

Here is the source code package with my modifications used in building the binary as required by GPL :
http://www.kolumbus.fi/~d601194//linkstation/ushare-1.1a-custom+libupnp-1.6.6+libdlna-0.2.3-ffmpeg-libavutil-2008-08-03_src.tgz

My home page space is rather limited, so I cannot promise I'll host the files forever.
Should somebody wish to upload those to some other server, feel free to do so
provided both source and binary packages are available for download from that other server.

I did notify the uShare development team about the needed changes, so they'd find they way into the official uShare source codes.
These are the modifications, based on information found using Google (searched for DLNA.ORG_PN) and trial & error testing,
so there is no guarantee these are 100% correct, but these worked for me :

ushare-1.1a# grep DLNA src/mime.c
{ "avi", UPNP_VIDEO, "http-get:*:video/divx:DLNA.ORG_PN=MPEG4_P2_MP4_SP_AAC;DLNA.ORG_OP=01;"},
{ "divx", UPNP_VIDEO, "http-get:*:video/divx:DLNA.ORG_PN=MPEG4_P2_MP4_SP_AAC;DLNA.ORG_OP=01;"},
{ "xvid", UPNP_VIDEO, "http-get:*:video/divx:DLNA.ORG_PN=MPEG4_P2_MP4_SP_AAC;DLNA.ORG_OP=01;"},
{ "wmv", UPNP_VIDEO, "http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVHIGH_PRO;DLNA.ORG_OP=01;"},
{ "m2ts", UPNP_VIDEO, "http-get:*:video/mp4:DLNA.ORG_PN=AVC_TS_BL_CIF15_AAC;DLNA.ORG_OP=01;"},
{ "mpg", UPNP_VIDEO, "http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS;DLNA.ORG_OP=01;"},
{ "mpg2", UPNP_VIDEO, "http-get:*:video/mpeg2:DLNA.ORG_PN=MPEG_PS;DLNA.ORG_OP=01;"},
{ "mp3", UPNP_AUDIO, "http-get:*:audio/mpeg:DLNA.ORG_PN=MP3;DLNA.ORG_OP=01;"},

These modifications could render uShare unusable with any other DLNA client than PS3,
but I only use the PS3, so I cannot test if this is the case.


Top
 Profile  
 
PostPosted: Wed Jan 07, 2009 11:00 pm 
Offline
Newbie

Joined: Fri Nov 21, 2008 1:07 am
Posts: 8
Successfully installed the ipkg ushare distribution to my LS-L320GL last night.
My xBox360 can see the share now which is exciting.
However, none of my video would play (possibility the codecs are not supported without transcoding) and all the video files showed up in the xBox "Music Folder".
I transferred a Picture file and some mp3's over to the NAS but then looked at the time and went to bed.
I will test it some more tonight to see if the picture and (actual) music files stream OK.

Any solutions for the video showing up as music?
(and for video codecs not supported?)

Edit..
I found this which seems to solve the music problem..
http://netou.co.uk/?p=28

and another potentially useful link
http://lifewithushare.blogspot.com/


Top
 Profile  
 
PostPosted: Thu Jan 08, 2009 12:01 am 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
Thanks for posting this...

Did you enable dlna in the configuration before compiling?

libdlna looks like it needs ffmpeg in order to compile...

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
 Profile  
 
PostPosted: Fri Jan 09, 2009 6:48 pm 
Offline
Newbie

Joined: Sat Aug 09, 2008 9:32 am
Posts: 5
Hi,

You're most welcome davy_gravy.

Yes, I did enable libdlna when compiling the uShare, and libdlna needed FFMPEG to compile.

However, there is a bug in the config file parsing of vanilla uShare-1.1 that makes it interpret a trailing white-space as a part of value and hence libdlna was never actually enabled by the config that was provided by my package. Virtually all the DLNA stuff came solely from the edits to mime-types that I made.

After learning that and finding out having libdlna truely enabled, makes the media library refresh last hours (for +20k files) instead of few seconds, I build new package without libdlna (and FFMPEG). I did have to include small part of libdlna directly into uShare to get PS3 identify uShare as DLNA media server, but that was rather simple to do.

Works fine with PS3 with the mime-type additions I made without libdlna.
Few of my friends that have other devices (like N95) are using MediaTomb from the ipkg feed as it works better for them.

Well, that's what they are telling me ;)

Here is a link to new binary package I made :
http://www.kolumbus.fi/~d601194//ushare ... .6_bin.tgz

Source code (I made some changes like I said, and corrected some errors I noticed):
http://www.kolumbus.fi/~d601194//ushare ... .6_src.tgz

The errors I fixed are more related to syslog messages, so nothing that important.

Currently the used DLNA flags are set like this as I finally took the time to read libdlna sources and track down the proper flags, instead of using those found by using Google.

root@NAS:/mnt/disk1/root/temp/ushare-1.1a# grep DLNA src/mime.c
{ "avi", UPNP_VIDEO, "http-get:*:video/divx:DLNA.ORG_PN=MPEG4_P2_TS_SP_MPEG1_L3;DLNA.ORG_OP=01;"},
{ "divx", UPNP_VIDEO, "http-get:*:video/divx:DLNA.ORG_PN=MPEG4_P2_TS_SP_MPEG1_L3;DLNA.ORG_OP=01;"},
{ "xvid", UPNP_VIDEO, "http-get:*:video/divx:DLNA.ORG_PN=MPEG4_P2_TS_SP_MPEG1_L3;DLNA.ORG_OP=01;"},
{ "wmv", UPNP_VIDEO, "http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVHIGH_PRO;DLNA.ORG_OP=01;"},
{ "m2ts", UPNP_VIDEO, "http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=AVC_TS_MP_HD_AC3;DLNA.ORG_OP=01;"},
{ "mpg", UPNP_VIDEO, "http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS;DLNA.ORG_OP=01;"},
{ "mpg2", UPNP_VIDEO, "http-get:*:video/mpeg2:DLNA.ORG_PN=MPEG_PS;DLNA.ORG_OP=01;"},
{ "mp3", UPNP_AUDIO, "http-get:*:audio/mpeg:DLNA.ORG_PN=MP3;DLNA.ORG_OP=01;"},


Top
 Profile  
 
PostPosted: Fri Jan 09, 2009 10:51 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
cool, thanks for providing the level of detail that you did...

I recently have tried Twonky, uShare, FUPPES and MediaTomb. I guess they each have their strength(s)...

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
 Profile  
 
PostPosted: Sat Jan 10, 2009 9:15 am 
Offline
Site Admin
User avatar

Joined: Sun Jul 17, 2005 4:34 pm
Posts: 5330
Thanks GaryTTirn!


Top
 Profile  
 
PostPosted: Sun Feb 15, 2009 7:02 pm 
Offline
Newbie

Joined: Sat Aug 09, 2008 9:32 am
Posts: 5
I made some new enhancements and packages. Since official development seems to stopped,
I dared name the new version uShare 1.2.

Artist, Album & Genre metadata is now read from mp3 files and at least PS3 can show it.
Navigating the shares using the the read data is not possible - yet...

Share refresh is now more user friendly, it shows the progress instead of empty web page until done.

Here is a link to new binary package I made :
http://www.kolumbus.fi/~d601194/ushare/ushare-1.2-custom+libupnp-1.6.6_bin.tgz

Source code :
http://www.kolumbus.fi/~d601194/ushare/ushare-1.2+libupnp-1.6.6_src.tgz


Top
 Profile  
 
PostPosted: Sun Feb 15, 2009 9:34 pm 
Offline
Site Admin
User avatar

Joined: Mon Aug 28, 2006 1:15 am
Posts: 2606
Cool. I will try building this and testing in on the two media player devices I have (Roku and XBMC).

Will let you know how it turns out.

_________________
LS1 (foonas, nfs, Tranmission & p910nd print server, Firefly for my Roku)
LS-HG500 (Lenny)
Various LS-Pros v1,v2 (unbricked w/ serial & jtag)
KuroPro, LS2 & KuroHG (foonas)
Working on davysweather.dyndns.org lately...

=> wooohooo!
wooohooo!
Unknown command 'wooohooo!' - try 'help'


Top
 Profile  
 
PostPosted: Mon Feb 16, 2009 4:41 pm 
Offline
Newbie

Joined: Sat Aug 09, 2008 9:32 am
Posts: 5
It works with XBMC, I'm also using it to test this beast.

Have fun...


Top
 Profile  
 
PostPosted: Fri Feb 27, 2009 3:25 pm 
Offline
Newbie

Joined: Wed Feb 25, 2009 5:45 pm
Posts: 15
esemce wrote:
Successfully installed the ipkg ushare distribution to my LS-L320GL last night.
My xBox360 can see the share now which is exciting.
However, none of my video would play (possibility the codecs are not supported without transcoding) and all the video files showed up in the xBox "Music Folder".
I transferred a Picture file and some mp3's over to the NAS but then looked at the time and went to bed.
I will test it some more tonight to see if the picture and (actual) music files stream OK.

Any solutions for the video showing up as music?
(and for video codecs not supported?)

Edit..
I found this which seems to solve the music problem..
http://netou.co.uk/?p=28


Did you get your LS-L320GL to stream movies to your xbox360? If so, could you tell me what you did? Thanks I greatly appreciate any help.


Top
 Profile  
 
PostPosted: Fri Mar 20, 2009 12:12 pm 
Offline
Newbie

Joined: Mon Mar 09, 2009 6:26 pm
Posts: 5
Hi folks,

I have a Buffalo Linkstation mini an a PS3. Unfortunately the onborad Mediaserver (Twonky) wont stream AVI to the Ps3. Will it be possible to install ushare on the Linkstation MINI, and do u have a noob-secure manual for it?

Thanks in advance


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Protected by Anti-Spam ACP
Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group