Buffalo NAS-Central Forums

Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz
Page 1 of 2

Author:  Dezi [ Sat Jul 19, 2008 12:42 pm ]
Post subject:  Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz


I have a LS Pro V1 and would like to flash the u-boot with this version: Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz . So currently this only available for developers and testers.

I would really like to test this and I need it to get the armel lenny working.

Could someone please give me access to this?



Author:  davy_gravy [ Sat Jul 19, 2008 12:56 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

Hi Dezi,

I'm guessing you may not have serial access. Is that correct?

We can work on that samba/filesharing problem too... was the samba problem on the same machine (an LSProV1) or is it on a different one? like V2

EDIT: Dezi, can you describe what state your LSproV1 is in currently? is it pretty much bricked? what access do you have? The netconsole UBoot can only be installed if you have either 1: a serial cable or 2: a booted Linux filesystem .

Author:  Dezi [ Sat Jul 19, 2008 1:11 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

Hi davy_gravy,

you are right, I don't have serial access but right now...I open the LSPro and connected the harddisk directly to my debian-desktop-machine.

After evenings of testing and missconfiguration now I have the following situation:

- A stock uboot (1.1.1) - so without netconsole access etc.
- Your lenny kernel on sda1
- The LSPro boots to EM using your kernel
- On sda2 (ext3 formated) your root-filesystem is installed
- I did all this directly editing/copying files from my desktop to the harddisk

-> But I must say....maybe I am wrong with this information. I think I lost the "overview".... :(

What I would like to have: A booting LSPro1 with your kernel + filesystem running. Could you please help me?!

Author:  davy_gravy [ Sat Jul 19, 2008 1:15 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

Dezi wrote:
Hi davy_gravy,

- A stock uboot (1.1.1) - so without netconsole access etc.
- Your lenny kernel on sda1
- The LSPro boots to EM using your kernel

If you can boot it into EM, then it can be worked w/ just fine. Is it EM from the hdd sda1 partition, or EM via tftp?

As long as you are in EM mode, you should be able to log in to foonas-em w/ user : root and password : hydr0g3n .

Once in there we can get your booting process set up and fixed.

Also, if you are interested, you can explore the UBoot stuff too, but lets fix the booting first. (or try at least) There is a fair amount of setup required to use netcat and the netconsole, and while it does give serial-like connectivity, it has some caveats to it.

Author:  Dezi [ Sat Jul 19, 2008 1:21 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

It is EM from sda1 .

Author:  davy_gravy [ Sat Jul 19, 2008 1:23 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

that is good news. are you logged into EM?
If so, run
fooboot -n
and post back.


... and don't shut your machine down until this is fixed. The good thing is that while you are in EM, just about anything can be fixed. :up:

EDIT 3: UBoot for V2 will work in V1 machinery ... you just have to change some env vars...

Author:  Dezi [ Sat Jul 19, 2008 1:33 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

Thanks, I will do so later...my little daugther waked up...we have to go swimming now. ;)

Author:  davy_gravy [ Sat Jul 19, 2008 1:36 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

Dezi wrote:
Thanks, I will do so later...my little daugther waked up...we have to go swimming now. ;)

hehe, I know that sort of thing ... post back when ready for next steps ...


1. check your partitions: while in EM run parted, and execute the print command in parted - make sure your partitions are the expected ones

2. reinstall the latest kernel/modules I have posted. the kernel needs to be copied to sda1, and have a symlink to it, named uImage

3. run fooboot -s, fooboot -h and fooboot -n ... post the output and we can work from there...


Author:  Dezi [ Sat Jul 19, 2008 8:15 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

I am getting crazy... back from swimming I tried to "setup" the box again so that I am able to boot into EM mode with your kernel. First it did not work (I was stupid not to write down how I got to EM mode last time). - But now...unbelievable...the box boots into your armel lenny with your rootfs and kernel!

So right now the combination is:
- your uImage
- an initrd.buffalo from freelink or stock buffalo (I am not really sure)
- a stock uboot

WOW...that's the result after 1,5 weeks try and error. I am a lucky boy. :p

But I would feel saver when I could use your initrd.buffalo and maybe the new uboot with netconsole enabled. What do you think? Just an exchange of the freelink/buffalo initrd.buffalo with yours does not work, the box does not boot. I think because of my stock uboot.

Could you please explain me what to do to use your initrd.buffalo?

Here is the output you requested:

LS-GL:/tmp/test# fooboot -s
   The SCSI Adapter (Host) Number is 1, so this box is an LSPro/LiveV1

LS-GL:/tmp/test# fooboot -h
   Switching to normal bootup using kernel at /dev/sda1/uImage and rootfs=/dev/sda2
   Make sure you have a working rootfs at /dev/sda2, otherwise your device won't boot
   Your console settings are : netconsole=6666@,@

Unlocking flash...
Erasing old environment...
Writing environment to /dev/mtd0...
Locking ...

LS-GL:/tmp/test# fooboot -n
     ...current env var values for uBoot:

bootargs=$(bootargs_base) $(bootargs_root)
bootargs_root=root=/dev/sda2 rw initrd=0x00800040,15M panic=5
def_tftp=tftp 0x00100000 $(kernel);tftp 0x00800000 $(initrd);setenv bootargs $(bootargs_base) $(bootargs_root) $(buffalo_ver);bootm 0x00100000 0x00800000
bootcmd=ide reset ; ext2load ide 1:1 0x00100000 /uImage ; setenv bootargs netconsole=6666@,@ root=/dev/sda2 rw ; bootm 0x00100000

Author:  davy_gravy [ Sat Jul 19, 2008 8:31 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

well, I don't actually use an initrd at all... from the directions :
Notes & minutiae:
A. U-Boot (any stock Buffalo U-Boot or derivative thereof) needs to find a nontrivial file it identifies as the initrd - it automatically scans for it just after initializing. Even though this distro doesn't use an initrd, UBoot will whine if it doesn't find it, so fool we it. This is why there is a file in /boot called initrd.buffalo, even though it isn't used.

any non-trivial file on sda1 should work, but for ease-sake I just make a symlink to uImage called initrd.buffalo .
The thing is that uboot (the stock uboot or any derivative thereof - including my enhanced one and the netconsole one) automatically scans for an initrd, and as your output shows, the name it looks for in particular is initrd.buffalo. The contents of this file don't matter so much for my image. Other images/distros do use an initrd, so in that case the contents of initrd or initrd.buffalo would be important.

The last line in your output looks good. The boot command looks correct.

EDIT : it looks good for a V1 LSPro or LSLive. For a LSProV2 or KuroPro, the 1:1 would be changed to a 0:1.

You should explore how fooboot works a bit more, if you are still interested in the netconsole uboot. I see you already changed the CONSOLE setting to netconsole.

Additionally, you would want to look at your subnet, serverip, and your overall network settings. All of that should be setup and figured out before you flash uboot. Also these three articles are a must:
http://buffalo.nas-central.org/index.ph ... and_Values
http://buffalo.nas-central.org/index.ph ... rk_Utility
http://buffalo.nas-central.org/index.ph ... for_LS_Pro
the README - copied below

The netconsole version just gives serial-like connection over the network... that's its only function. ... but it does pretty much completely open up the box w/o you physically opening it up. That is, you can perform the same starts/stops/manipulations of the boot process that one would w/ serial connection, but without the need for a serial header, cable or opening the box physically.

If you are sure you can assume your own risk of doing this and you have read up on netcat, taken into consideration the network changes that might be necessary (in the README ... I copied it below), then pm me w/ your email address and I'll email you a copy of it. Please don't distribute it to anyone else - after I have a few positive results w/ it from users, I'll probably make it openly available.

April 12 2008

README for Netconsole-enabled U-Boot 1.1.4 for the LS-GL

What's included:
u-boot114patchesbasicv12.bin - 240kb image for uboot
u-boot114patchesbasicv12-full.bin - full 256k image for uboot

What it is:
This is a early prototype of a Netconsole-enabled U-Boot for LS-GL. It fulfills the basic need for access to UBoot without having to open up your box and attach a serial cable. It works well with LSPro V2, and should work with the stock firmware or jtymod without any modification. I would guess that it will also work with FreeLink as well, but haven't tried it so you're on your own on that. It will work fine with foonas and foonas-em. It also works with LSPro V1, though you might have to adjust env vars.

It is functional and so far (knock on wood) not a brickmaker (after about 3 weeks of testing/abuse). If you are able to brick your box with it with normal operation/use, please send me the steps you used so I can replicate the bricking/confirm the problem and try to fix it.

As such, it is a starting point, and hopefully enough members in the community will find reason to either develop it further, or make a clean break and create a truly clean port of UBoot (which would be nicer yet).

What it isn't:
It isn't original code, but rather just a port of the Buffalo 109 version (based on UBoot 1.1.1) to UBoot 1.1.4, along with Netconsole being enabled, more commands turned on, and some utility scripts/env vars hard coded in. Some of the ideas are taken from LNI's patches for the PPC UBoot.

If you are looking for the much-awaited clean (non-Marvell, non-Buffalo) port of UBoot, this isn't it. If you want that, I encourage you to build it, and please share it with the rest of the community and me :) . A clean port of UBoot to the ARM machines is my first choice, but is way beyond what I am able to commit in time and energy.

It isn't perfect and isn't polished. There are a few places for improvement in interface, performance (wait times) and integration with the external buttons. Please see the later section "Quirks/Stuff to try to change/add:"

Thanks to bbradley (for giving good advice and suggestions on both uboot and jtag), jonli447 (for his work back in 2007 with the GPL source), and lb_worm (who remembered what had been done w/ jtag and uboot earlier). Also, thanks to linuxnotincluded (LNI) for the PPC UBoot port, which set the standard.

*All the functions of the Buffalo 109 UBoot

*Netconsole (on by default)

*Serial connection (only by executing "run ser" while in netconsole)

*Automatic fallback to tftp_booting if no bootable system is found

*Some very basic scripts for setting env vars for foonas (or other distros w/ root & kernel on /dev/sda1):
fooboot - boot foonas from hdd
foobootem - boot foonas-em from tftp (serverip
envfoohdd - set env var 'bootcmd' for foonas hdd booting
envfooem - set env var 'bootcmd' for foonas-em tftp booting
envreset - reset env vars to stock defaults (for stock Buffalo firmware/OS booting or FreeLink-ARM)
Note: Execute these by issuing "run fooboot", etc.

*Commands (a handful more than in Buff 109):
boot - boot default, i.e., run 'bootcmd'
bootd - boot default, i.e., run 'bootcmd'
boot end .
bootm - boot application image from memory
bootp - boot image via network using BootP/TFTP protocol
bubt - Burn an image on the Boot Flash.
cmp - memory compare
coninfo - print console devices and information
cp - memory copy
cpumap - Display CPU memory mapping settings.
crc32 - checksum calculation
date - get/set/reset date & time
dhcp - invoke DHCP client to obtain IP/boot params
diskboot- boot from IDE device
echo - echo args to console
erase - erase FLASH memory
ext2load- load binary file from a Ext2 filesystem
ext2ls- list files in a directory (default /)
flinfo - print FLASH memory information
go - start application at address 'addr'
help - print online help
ide - IDE sub-system
loadb - load binary file over serial line (kermit mode)
loads - load S-Record file over serial line
loop - infinite loop on address range
md - memory display
micon -command(2byte hex) -data(witin 32byte hex)
mm - memory modify (auto-incrementing)
mtest - simple RAM test
mw - memory write (fill)
nm - memory modify (constant address)
pci - list and access PCI Configuration Space
ping - send ICMP ECHO_REQUEST to network host
printenv- print environment variables
protect - enable or disable FLASH write protection
rarpboot- boot image via network using RARP/TFTP protocol
reset - Perform RESET of the CPU
run - run commands in an environment variable
saveenv - save environment variables to persistent storage
security -device -command -options -password
setenv - set environment variables
shutdown - Poff .
tftpboot- boot image via network using TFTP protocol
version - print monitor version

Installation, Flashing & JTAG:
At your own risk, of course and since this is beta, you really shouldn't do it without access to JTAG
< http://buffalo.nas-central.org/index.ph ... for_LS-Pro >

Directions for flashing this are on the article page
< http://buffalo.nas-central.org/index.ph ... our_LS_Pro >

Your workstation must be have an IP of, and you should have nc (netcat) running, perhaps with something to the effect of:

nc -u -p 6666 -v 6666

The LSPro should be connected in the normal way to your network. When you start up your LSPro, after about 5-10 seconds you will see


If you want to pause booting, you can press <return> 3 times right now, or just let it autoboot. There are some autoboot-stop prompts, but they seem to act quirky so, it sometimes works better just to use the returns after egiga0. After that, something like:



_____ _____ _____ _____ _ _
| | | _ | __|___| |___ ___| |_ ___ ___| | ___ ___ ___
| | | | |__ |___| --| -_| | _| _| .'| |_| . | _| . |
|_|___|__|__|_____| |_____|___|_|_|_| |_| |__,|_|_|___|_| |_ |

Using 88E1118 phy

Marvell Serial ATA Adapter
Integrated Sata device found
Device 0: OK
Model: WDC WD2500JD-00HBC0 Firm: 08.02D08 Ser#: WD-WCAL77520516
Type: Hard Disk
Supports 48-bit addressing
Capacity: 238475.1 MB = 232.8 GB (488397168 x 512)

Using device ide0, partition 1

Loading from block device ide device 0, partition 1: Name: hda1
Type: U-Boot File:/boot/uImage

2282096 bytes read
Using device ide1, partition 1
** Bad partition 1 **
Booting from Device 0
hit any key to switch tftp boot.
Hit any key to stop autoboot: 0
switched to TFTP boot.
Hit any key to stop autoboot: 0

Search_Boot and No initrd warning:
Normal behavior for Buffalo's UBoot 109 is to look for the file specified by the env var 'initrd' on the hdd. If that can't be found, it will attempt to autoboot via tftp whatever is defined by the env var 'def_tftp'. By altering these two variables and the additional variable 'bootcmd', one can customize the booting behavior of the LSPro and keep the ability for UBoot to automatically search attached hard drives for a bootable system, and also automatically fall back to EM booting when no hdd filesystem is present.

Quirks/Stuff to try to change/add:
*Behavior for stopping at the auto-boot prompts is sometimes inconsistent. It would be nice if it was more smooth. Three returns after seeing 'egiga0' is the current workaround for this.

*A miniconsole feature using the power button for boot mode selection, and the reset button for netconsole<->serial console switching would be ideal.

*nfs support needs to be turned on.

*Autosensing for the serial connection would be nice, so that if a serial cable is connected, all output would be automatically sent via serial instead of netconsole.

*The irritating hi-lo tftp-alarm that is normally started when no initrd is found has been disabled. Disabling this has two effects: 1) silencing the shrill siren tone that one would hear on the stock uboot if no initrd is found, and 2) keeping the box from powering down after 5 minutes if no initrd is found at startup. Please tell me if you feel this should be turned back on, as it might be of some benefit. We may be able to change the tone/volume/length of the alarm, as well as including the keepalive signal in the alarm routine (or disabling the code that causes it to power down after 5 minutes in this case).

Additions to this list are welcome, as well as solutions and patches.

Dave Purdy (davygravy)

Author:  ado [ Sun Oct 05, 2008 2:31 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

I had read all the artical and knew what I do.
pls let me access the Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz, thx.

Author:  davy_gravy [ Sun Oct 05, 2008 2:51 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

hi ado, as long as you hold me blameless for whatever happens, and follow the notes/guidance on the Article page, I'll email you a copy.

It has been used by 7 or 8 people so far w/ no bricks, though one person didn't follow directions and had a scary day or two getting it back - it wasn't bricked but he had to work at recovering it.

Did you read the part about the workaround? It needs to be on a network and to see something at ncip... please read that part, as well as be aware it is best to use the network setup that is already in env vars.

PM me w/ your email addy and I'll send you a copy.

Author:  ado [ Thu Oct 09, 2008 7:48 am ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

hi davy_gravy,

i had installed your Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz in my box. it's woking fine.
i followed your instruction and flash u-boot within Linux on my box. and then, i installed the armel image 0.31b on my box.
now all is working fine.
thanks a lot.


Author:  davy_gravy [ Thu Oct 09, 2008 12:27 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

great to hear! Thanks for posting back w/ results.

Author:  FJRMaverick [ Sat Mar 21, 2009 7:42 pm ]
Post subject:  Re: Access to Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz

hi davy_gravy

I read all articles and know what to do. My LS-HGL even still boots up with "your" kernel (2.6.26) and runs with lenny (based on the image from lb_worm). But I want more flexibility an so decided to install a new U-Boot.

Please give me access to the Netconsole_enabled_UBoot-beta_4-12-08-1318.tar.gz. Thanks in advance and for your great work!

Page 1 of 2 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited