Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Fri Sep 19, 2014 12:55 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Wed Oct 31, 2007 4:40 am 
Offline
Regular Member

Joined: Mon Oct 01, 2007 11:29 pm
Posts: 79
optware/mssii => optware/cs05q3armel
optware/mssii-kernel => optware/mssii

The optware-bootstrap scripts have been updated.

Please adjust your existing /opt/ipkg/*.conf accordingly.

- bzhou@nslu2-linux.org


Top
 Profile  
 
PostPosted: Wed Oct 31, 2007 9:10 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7702
Location: Austria, Vienna
ok guys, so the currently configured feed is the kernel feed.

actually i had to adjust /opt/etc/ipkg/cross-feed.conf only. this was all that i did:

Code:
echo "src/gz cross http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable" > cross-feed.conf


afterwards you can execute "ipkg update & ipkg upgrade" again.

bzhou: very nice. i started to collect all the machines with arm926ej-s CPU and marvell orion design with the mv88F5182 SoC here -> http://buffalo.nas-central.org/ALL_COMMUNITIES/ ... %20devices

this is list is far from complete...i think all these boxes can use this general optware feed. and i think that all these boxes might profit from the marvell orion vanilla kernel patches....so far they get accepted sometimes by Russel King and then Linus.....

EDIT: actually i think that
LaCie 2big Network (2-disk RAID)
is also a marvell orion based box

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
 Profile  
 
PostPosted: Wed Oct 31, 2007 10:15 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7702
Location: Austria, Vienna
just encountered a problem because of a missing package in the ipkg feed:
Code:
root@LS-PRO:/opt/etc/ipkg# ipkg update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/Packages.gz
Inflating http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/Packages.gz
Updated list of available packages in /opt/lib/ipkg/lists/cross
Successfully terminated.
root@LS-PRO:/opt/etc/ipkg# ipkg upgrade
Upgrading libtorrent on root from 0.11.8-2 to 0.11.9-1...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/libtorrent_0.11.9-1_arm.ipk
Nothing to be done
Successfully terminated.
Collected errors:
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /opt/ipkg-IiM9RK http://ipkg.nslu2-linux.org/feeds/optware/cs05q3armel/cross/stable/libtorrent_0.11.9-1_arm.ipk'
Failed to download libtorrent. Perhaps you need to run 'ipkg update'?

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
 Profile  
 
PostPosted: Thu Nov 01, 2007 1:21 am 
Offline
Newbie

Joined: Fri Aug 24, 2007 4:59 am
Posts: 37
Same problem here. I actually get the error in the ipkg update step also.


Top
 Profile  
 
PostPosted: Thu Nov 01, 2007 1:32 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7702
Location: Austria, Vienna
did you edit /opt/etc/ipkg/cross-feed.conf ?

then it is no wonder why it happens.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
 Profile  
 
PostPosted: Thu Nov 01, 2007 6:21 am 
Offline
Newbie

Joined: Fri Aug 24, 2007 4:59 am
Posts: 37
I spelt cs05q3armel wrong :oops: It's working now. :up:

By the way, the bootstrap script went from
lspro-bootstrap_1.0-4_arm.xsh to lspro-bootstrap_1.0-9_arm.xsh

What is changed? Anything the end user have to do besides changing the conf file?


Top
 Profile  
 
PostPosted: Thu Nov 01, 2007 11:49 am 
Offline
Site Admin
User avatar

Joined: Mon Jul 11, 2005 7:19 am
Posts: 7702
Location: Austria, Vienna
i don`t think so. it was just renamed so it is recognized as a more "general" feed....no box specific feed anymore.

btw we should compile kernel modules for the boxes.....and make them available via a box specific feed.

_________________
LS1 (2.6 kernel, foonas svn1062, 750 GB, UBoot 1.2) & LS Pro (FreeLink/jtymod/GenLink, changes all the time)
Thx to all donators!


Top
 Profile  
 
PostPosted: Tue Jul 01, 2008 8:40 am 
Offline
Total Newbie

Joined: Tue Jul 01, 2008 8:30 am
Posts: 1
Hi

Thanks for the great job!

The installation on my LS-Live v1 was quite easy with this post.

But i get something confusing. After i opened the the box with acp_commander and telnetted into it, i get a high cpu load by a .cgi file in the /www/cgi-bin folder. Its called error.cgi.

I reinstalled the stock-firmware a few times and all the same. With all configs .. re_create partition , del user confic ect..
And even with other FW versions .. 1.06, 2.10 and also the LS-Pro one.. ??

Now i renamed it and the load has gon.

But what did this script?

Does everyone know ???

Thanks..


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Protected by Anti-Spam ACP
Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group