Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Wed Apr 23, 2014 9:09 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 146 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7, 8, 9, 10  Next
Author Message
PostPosted: Sat Aug 09, 2008 6:49 pm 
Offline
Newbie

Joined: Fri Jul 11, 2008 8:14 pm
Posts: 5
can anyone help?! i have the same problem as the guy above me! i reckon its something to do with the 2.1 update as i had it working before the update on one box, ive just bought another for backup and a dedicated torrent box and went to do all the installs and it wont work! in the process, as i was pdating my new one i updated the old one too and so now everything i installed on that one too wont work properly now.......can somebody help??? please!!


Top
 Profile  
 
PostPosted: Sat Aug 09, 2008 8:25 pm 
Offline
Regular Member

Joined: Mon Oct 01, 2007 11:29 pm
Posts: 79
For those having optware bootstrap problem, can you post the output of "mount; cat /proc/mounts" before bootstraping.

Manual bootstrap instruction should be similar to other optware platforms:
http://www.nslu2-linux.org/wiki/Optware/Dns323
http://www.nslu2-linux.org/wiki/Optware/Slugosbe


Top
 Profile  
 
PostPosted: Sun Aug 10, 2008 3:27 pm 
Offline
Newbie

Joined: Fri Jul 11, 2008 8:14 pm
Posts: 5
hey, i did rm -rf /mnt/disk1.optware and rm -rf /usr/lib/ipkg before running the mount; cat /proc/mounts i hope that was right! this is the output that came out of it

root@HS-DHGL97E:/mnt/disk1/tmp/bootstrap# mount; cat /proc/mounts
rootfs on / type rootfs (rw)
/dev/root on / type xfs (rw)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw)
/proc/bus/usb/ on /proc/bus/usb type usbfs (rw)
/dev/ram1 on /mnt/ram type tmpfs (rw)
/dev/ls_disk1_1 on /boot type ext3 (rw,data=ordered)
/dev/ls_disk1_6 on /mnt/disk1 type xfs (rw)
/dev/ls_disk1_6 on /opt (deleted) type xfs (rw)
rootfs / rootfs rw 0 0
/dev/root / xfs rw 0 0
proc /proc proc rw 0 0
devpts /dev/pts devpts rw 0 0
/proc/bus/usb/ /proc/bus/usb usbfs rw 0 0
/dev/ram1 /mnt/ram tmpfs rw 0 0
/dev/ls_disk1_1 /boot ext3 rw,data=ordered 0 0
/dev/ls_disk1_6 /mnt/disk1 xfs rw 0 0
/dev/ls_disk1_6 /opt\040(deleted) xfs rw 0 0

if i didnt do it right could you tell me what to do and ill try my best! used to coding but quite new to linux commands etc....

thanks!!


Top
 Profile  
 
PostPosted: Mon Aug 11, 2008 1:11 am 
Offline
Regular Member

Joined: Mon Oct 01, 2007 11:29 pm
Posts: 79
NewbieDan wrote:
/dev/ls_disk1_6 on /opt (deleted) type xfs (rw)


This probably is a result of removing /mnt/disk1.optware which was bind mounted to /opt.
Can you do "umount /opt"?
Only try running the xsh script when /opt gets umounted.


Top
 Profile  
 
PostPosted: Mon Aug 11, 2008 8:11 am 
Offline
Newbie

Joined: Fri Jul 11, 2008 8:14 pm
Posts: 5
that umount seemed to work......i dont understand why installing it in the first place would have come up with an error but once you umount and try again it'll work........well i think its working properly, only quickly done this before i go to work.....ill have a better look later when i get home.....thanks!


Top
 Profile  
 
PostPosted: Mon Aug 11, 2008 8:48 am 
Offline
Total Newbie
User avatar

Joined: Wed Aug 06, 2008 7:52 am
Posts: 2
Hi all

umounting doesnt work for me

I rerun
./lspro-bootstrap_1.2-4_arm.xsh
Optware Bootstrap for lspro.
Extracting archive... please wait
bootstrap
bootstrap/bootstrap.sh
bootstrap/ipkg-opt.ipk
bootstrap/ipkg.sh
bootstrap/optware-bootstrap.ipk
bootstrap/wget.ipk
1081+1 records in
1081+1 records out
Creating temporary ipkg repository...
Installing optware-bootstrap package...
Unpacking optware-bootstrap.ipk...Done.
Configuring optware-bootstrap.ipk...Setting up ipkg arch-file
Done.
Installing ipkg...
tar: Short header
tar: Short read
ipkg_install_file: ERROR unpacking control.tar.gz from ipkg-opt.ipk
Removing temporary ipkg repository...
Installing wget...
bootstrap.sh: line 41: /opt/bin/ipkg: No such file or directory

bummer

ahhh found it - again busybox tar is too stupid to take it!

Doing this in advanve fixes it (though tar still complains about short header...)
viewtopic.php?p=70066#p70066

This NEEDS to be fixed by including the required tar:(

Cya

_________________
/ /|( @ )( @ )|\ \


Top
 Profile  
 
PostPosted: Mon Aug 11, 2008 2:41 pm 
Offline
Total Newbie

Joined: Mon Aug 11, 2008 2:39 pm
Posts: 2
I have a small question about ipkg stuff ...
Is there a way to easily uninstall softwares installed with ipkg ?
Is it possible to roll-back all modifications made to the station if i want to start from the beginning ?

Thanks in advance for yours answers !


Top
 Profile  
 
PostPosted: Tue Aug 12, 2008 7:15 am 
Offline
Regular Member

Joined: Mon Oct 01, 2007 11:29 pm
Posts: 79
grm wrote:
I have a small question about ipkg stuff ...
Is there a way to easily uninstall softwares installed with ipkg ?
Is it possible to roll-back all modifications made to the station if i want to start from the beginning ?



"ipkg remove pkg-name" is what you need.
Use the following to remove all optware:
Code:
rm -rf /opt/*
umount /opt
edit /etc/init.d/rcS to remove optware startup (leaving it there is fine too)


Top
 Profile  
 
PostPosted: Wed Aug 13, 2008 2:17 pm 
Offline
Total Newbie

Joined: Mon Aug 11, 2008 2:39 pm
Posts: 2
thanks for your prompt answer bzhou !

i'll give it a try :)


Top
 Profile  
 
PostPosted: Fri Aug 15, 2008 3:02 am 
Offline
Total Newbie

Joined: Thu Aug 14, 2008 10:30 am
Posts: 2
i am a new user with lspro.
i have open stock firmware by the instruction and it works well.
thanks.

_________________
LS-750GL - (open stock firmware for sshd,ipkg )
Linux LS-STONE 2.6.16.16-arm1 #37 Tue May 20 10:01:57 JST 2008 armv5tejl unknown


Top
 Profile  
 
PostPosted: Mon Aug 25, 2008 12:58 pm 
Offline
Newbie

Joined: Fri Aug 22, 2008 8:56 pm
Posts: 9
I have the Linkstation HS-DHGL- Series with 500GB HDD

Firmware is 2.10

How can i install nfs. Work this too with Bootstrap ?


Top
 Profile  
 
PostPosted: Mon Aug 25, 2008 10:22 pm 
Offline
Newbie

Joined: Fri Aug 22, 2008 8:56 pm
Posts: 9
sh lspro-bootstrap_1.2-2_arm.xsh i becomes this error:

Optware Bootstrap for lspro.
Extracting archive... please wait
bootstrap
bootstrap/bootstrap.sh
bootstrap/ipkg-opt.ipk
bootstrap/ipkg.sh
bootstrap/optware-bootstrap.ipk
bootstrap/wget.ipk
1081+1 records in
1081+1 records out

Creating temporary ipkg repository...

Installing optware-bootstrap package...

Unpacking optware-bootstrap.ipk...
Done.
Configuring optware-bootstrap.ipk...
mount: No such file or directory
mkdir: Cannot create directory `/opt/etc': No such file or directory
chmod: /opt/etc: No such file or directory
mkdir: Cannot create directory `/opt/var/': No such file or directory
chmod: /opt/var: No such file or directory
mkdir: Cannot create directory `/opt/tmp': No such file or directory

chmod: /opt/tmp: No such file or directory
mkdir: Cannot create directory `/opt/lib': No such file or directory
chmod: /opt/lib: No such file or directory
//tmp/ipkg/info/optware-bootstrap.ipk.preinst failed. Aborting installation of optware-bootstrap.ipk

Installing ipkg...

Unpacking ipkg-opt.ipk...
Done.
Configuring ipkg-opt.ipk...
tar:
Cannot create directory `./opt/bin': No such file or directory
tar: ./opt/bin/ipkg: No such file or directory
tar: Short header

tar: unexpected end of file
tar: Short header

Done.

Removing temporary ipkg repository...

Installing wget...
bootstrap.sh: line 41: /opt/bin/ipkg: No such file or directory
root@HS-DHGLD56:/mnt/disk1/tmp/bootstrap#


Who is my problem ?


Top
 Profile  
 
PostPosted: Mon Aug 25, 2008 10:36 pm 
Offline
Newbie

Joined: Fri Aug 22, 2008 8:56 pm
Posts: 9
minchenxxl wrote:
sh lspro-bootstrap_1.2-2_arm.xsh i becomes this error:

Optware Bootstrap for lspro.
Extracting archive... please wait
bootstrap
bootstrap/bootstrap.sh
bootstrap/ipkg-opt.ipk
bootstrap/ipkg.sh
bootstrap/optware-bootstrap.ipk
bootstrap/wget.ipk
1081+1 records in
1081+1 records out

Creating temporary ipkg repository...

Installing optware-bootstrap package...

Unpacking optware-bootstrap.ipk...
Done.
Configuring optware-bootstrap.ipk...
mount: No such file or directory
mkdir: Cannot create directory `/opt/etc': No such file or directory
chmod: /opt/etc: No such file or directory
mkdir: Cannot create directory `/opt/var/': No such file or directory
chmod: /opt/var: No such file or directory
mkdir: Cannot create directory `/opt/tmp': No such file or directory

chmod: /opt/tmp: No such file or directory
mkdir: Cannot create directory `/opt/lib': No such file or directory
chmod: /opt/lib: No such file or directory
//tmp/ipkg/info/optware-bootstrap.ipk.preinst failed. Aborting installation of optware-bootstrap.ipk

Installing ipkg...

Unpacking ipkg-opt.ipk...
Done.
Configuring ipkg-opt.ipk...
tar:
Cannot create directory `./opt/bin': No such file or directory
tar: ./opt/bin/ipkg: No such file or directory
tar: Short header

tar: unexpected end of file
tar: Short header

Done.

Removing temporary ipkg repository...

Installing wget...
bootstrap.sh: line 41: /opt/bin/ipkg: No such file or directory
root@HS-DHGLD56:/mnt/disk1/tmp/bootstrap#


Who is my problem ?



Ok it work's
problem was the mount opt


Top
 Profile  
 
PostPosted: Mon Aug 25, 2008 10:38 pm 
Offline
Newbie

Joined: Fri Aug 22, 2008 8:56 pm
Posts: 9
Now i have installed the nfs-server and the nfs-utilis

How can i edit the /opt/etc/exports ?

How can i start the nfs-server automatic ?


Top
 Profile  
 
PostPosted: Thu Aug 28, 2008 11:40 pm 
Offline
Newbie

Joined: Tue Jan 09, 2007 8:01 pm
Posts: 52
Location: Germany
minchenxxl wrote:
Now i have installed the nfs-server and the nfs-utilis

How can i edit the /opt/etc/exports ?

How can i start the nfs-server automatic ?


I think you don't need nfs-server. (When you look at ipkg list|grep nfs you'll see, that only nfs-utils is needed...)

But i'm not sure! I'm using a Linkstation V1 with Firmware 1.15 (Kernel 2.6.16) and when i installed nfs-utils and tried to connect from my Linux-PC, i got the following message:
Code:
getfh failed: Function not implemented


When i tried User Space NFS (unfs3) all works fine....

Some ideas?

Bitspyer

_________________
This is Linux country -
on a quiet night you can hear windows reboot...

Try not! Do or not. There is no try!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 146 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7, 8, 9, 10  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Protected by Anti-Spam ACP
Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group