Buffalo NAS-Central Forums

Welcome to the Linkstation Wiki community
It is currently Tue Oct 21, 2014 6:08 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Fri Jan 26, 2007 3:56 pm 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
Hello,

I seem to be having a problem getting php-4.4.4 (snapshot actually) to install correctly. I get this error on make install:

Code:
Installing PHP SAPI module:       apache2handler
/usr/local/apache2/build/instdso.sh
SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la /usr/local/apache2/modules
/usr/local/apache2/build/libtool --mode=install cp libphp4.la
/usr/local/apache2/modules/
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish
/usr/local/src/php-4.4.4/libs'
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: /usr/local/apache2/modules/libphp4.so: A file or directory in the path
name does not exist.
apxs:Error: Command failed with rc=65536
.
make: *** [install-sapi] Error 1


I do not have libphp4.so in the libs or .libs directory....

I have replaced the crappy grep with grep 2.5. So, I am wondering if it's a libtool error. I've looked up in the php and apache bugmail and have found references to libtool, but there are no details on how to rectify the issue.

So, I'm curious if anyone has successfully compiled php w/ my devtools package, or if anyone has an better idea of what's going wrong here.

_________________
http://www.opifer.net


Top
 Profile  
 
PostPosted: Sat Jan 27, 2007 12:38 am 
Offline
Newbie

Joined: Sun Dec 17, 2006 7:56 am
Posts: 68
Interesting. I had a different error on PHP version 5.2.0 & 5.1.6. Pear would not install.
I successfully installed a newer version of PHP, minus PEAR.


Top
 Profile  
 
PostPosted: Sat Jan 27, 2007 3:42 am 
Offline
Site Admin

Joined: Fri Aug 04, 2006 2:37 am
Posts: 1652
Location: United States of America
Hmmm....I still cannot get php to install. Problem is that I can't seem to find any clear documentation on the error. The install error also doesn't give me a good indication on what the issue is.:(

_________________
http://www.opifer.net


Top
 Profile  
 
PostPosted: Mon Mar 05, 2007 4:45 am 
Offline
Newbie

Joined: Thu Jan 25, 2007 12:34 pm
Posts: 33
Location: Hong Kong
Hi,

jonli447 wrote:
Hmmm....I still cannot get php to install. Problem is that I can't seem to find any clear documentation on the error. The install error also doesn't give me a good indication on what the issue is.


The simply way is :

sudo apt-get install php5*

For your information, please.

Samiux


Top
 Profile  
 
PostPosted: Wed May 16, 2007 3:32 am 
Offline
Newbie

Joined: Sun Dec 17, 2006 7:56 am
Posts: 68
samiux: regarding apt-get. We are using a stock Linkstation, or customized stock Linkstation. Apt is not available. I have considered moving to FreeLink/Debian because of all of the packages that are available.


Top
 Profile  
 
PostPosted: Sun Jan 17, 2010 4:05 pm 
Offline
Total Newbie
User avatar

Joined: Wed Dec 30, 2009 8:42 pm
Posts: 4
near as I can tell (and I'm still a bit of a newb) its that the stock firmware has apache installed, not apache2.

I'm battling with it at the moment to see if I can sidestep apache and use my /opt/apache2 install, but still having newby issues. once thats working it 'feels' like standard ipkg install php etc will work perfectly as it will all be using the same 'root' dir paths to find the additional modules..

but like I say, newb alert, I might be talking nonsense :D


Top
 Profile  
 
PostPosted: Wed Aug 06, 2014 11:32 am 
Offline
Newbie

Joined: Fri May 02, 2014 9:12 am
Posts: 12
Can someone provide step-by-step for upgrading PHP and MySQL on Shonks 1.68 mod?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Protected by Anti-Spam ACP
Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group